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1. Introduction
This is the home of the TouchDraw for Mac (version 1.x) documentation. The layout of the pages and

information displayed in this documentation is based on the User Interface (UI) structure. It is broken down

into six main sections with pages describing each potion of the interface and available functionality:

Section Name Description

Preface The Preface section contains necessary legal and acknowledgement information

regarding TouchDraw for Mac.

Getting Started The Getting Started section contains information for launching TouchDraw and

beneficial web page links.

User Interface The User Interface section can be used to learn more about the application interface.

File Management The File Management section can be used to learn more about managing files and

drawings within TouchDraw.

Editing Drawings The Editing Drawings section can be used to learn more about available features

when working with a drawing in TouchDraw.

Miscellaneous The Miscellaneous section contains additional information outside of the main UI

structure of the application such as file importing and exporting formats.

Information shown in the User Interface, File Management, and Editing Drawings sections, in particular, is

organized based on the layout of the application interface. For example, to find information about changing the

text properties of a figure in the editor, go to the Editing Drawings section, expand these pages, and then select

Text. To find information about importing or exporting a drawing, go to the File Management section and

select one of these pages.

Each of these documentation sections begins with pages describing the basic features of their user interface and

subsequent pages provide further details about a particular feature. Use the links on a page to navigate to

additional information about a particular subject or expand the pages to find a particular section. The search

feature can be also be used to find an item. Simply type in a keyword and a list of pages will appear for

selection.
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2. Preface
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2.1. Legal Notice
This software product is copyrighted and all rights reserved by Elevenworks LLC. The distribution and sale of

this product are intended for the use of the original purchaser only and for the use on their authorized systems.

Copying, duplicating, selling, or otherwise distributing this product with the express written permission of

Elevenworks are violations of U.S. Copyright Law and are hereby expressly forbidden.

Every effort has been made to ensure that the information in this manual is accurate; however Elevenworks is

not responsible for errors.

Apple, the Apple logo, iPhone, iPod touch, and iTunes are trademarks of Apple Inc., registered in the U.S. and

other countries. iPad is a trademark of Apple Inc. App Store is a service mark of Apple Inc. Content purchased

from the iTunes Store is for personal lawful use only. Don’t steal music.

Microsoft, Microsoft Windows and Visio are trademarks of the Microsoft group of companies.

TouchDraw and the TouchDraw logo are trademarks of Elevenworks LLC.

Other company and product names mentioned herein are trademarks of their respective companies. Mention of

third-party products is for informational purposes only and constitutes neither an endorsement nor a

recommendation. Elevenworks assumes no responsibility with regard to the performance or use of these

products.
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2.2. Open Source
Portions of this software may utilize the following copyrighted material, the use of which is hereby

acknowledged.

Name Link License

ModelText CSS http://www.modeltext.com/css/index.aspxCopyright 2008-2011, Christopher Wells

[info@modeltext.com](mailto:info@modeltext.com)

("Licensor")  Licensed under the ModelText CSS License.

Json.Net http://james.newtonking.com/projects/json-net.aspxCopyright (c) 2007 James Newton-King  Licensed under The

MIT License (MIT)

Portions licensed under the Apache License, Version 2.0. You may obtain a copy of the License at:

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed

on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or

implied. See the License for the specific language governing permissions and limitations under the License.

2.2.1. Apache License v2.0
Apache License

Version 2.0, January 2004

http://www.apache.org/licenses/

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

1. Definitions.

http://www.modeltext.com/css/index.aspx
mailto:%5Binfo@modeltext.com%5D%28mailto:info@modeltext.com%29
http://james.newtonking.com/projects/json-net.aspx
http://www.apache.org/licenses/LICENSE-2.0
http://www.apache.org/licenses/
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"License" shall mean the terms and conditions for use, reproduction, and distribution as defined by Sections 1

through 9 of this document.

"Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is granting the

License.

"Legal Entity" shall mean the union of the acting entity and all other entities that control, are controlled by, or

are under common control with that entity. For the purposes of this definition, "control" means (i) the power,

direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (ii)

ownership of fifty percent (50%) or more of the outstanding shares, or (iii) beneficial ownership of such entity.

"You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by this License.

"Source" form shall mean the preferred form for making modifications, including but not limited to software

source code, documentation source, and configuration files.

"Object" form shall mean any form resulting from mechanical transformation or translation of a Source form,

including but not limited to compiled object code, generated documentation, and conversions to other media

types.

"Work" shall mean the work of authorship, whether in Source or Object form, made available under the

License, as indicated by a copyright notice that is included in or attached to the work (an example is provided

in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or derived from)

the Work and for which the editorial revisions, annotations, elaborations, or other modifications represent, as a

whole, an original work of authorship. For the purposes of this License, Derivative Works shall not include

works that remain separable from, or merely link (or bind by name) to the interfaces of, the Work and

Derivative Works thereof.

"Contribution" shall mean any work of authorship, including the original version of the Work and any

modifications or additions to that Work or Derivative Works thereof, that is intentionally submitted to Licensor

for inclusion in the Work by the copyright owner or by an individual or Legal Entity authorized to submit on

behalf of the copyright owner. For the purposes of this definition, "submitted" means any form of electronic,

verbal, or written communication sent to the Licensor or its representatives, including but not limited to
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communication on electronic mailing lists, source code control systems, and issue tracking systems that are

managed by, or on behalf of, the Licensor for the purpose of discussing and improving the Work, but excluding

communication that is conspicuously marked or otherwise designated in writing by the copyright owner as

"Not a Contribution."

"Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom a Contribution has

been received by Licensor and subsequently incorporated within the Work.

2. Grant of Copyright License. Subject to the terms and conditions of this License, each Contributor hereby

grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to

reproduce, prepare Derivative Works of, publicly display, publicly perform, sublicense, and distribute the

Work and such Derivative Works in Source or Object form.

3. Grant of Patent License. Subject to the terms and conditions of this License, each Contributor hereby

grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable (except as stated in

this section) patent license to make, have made, use, offer to sell, sell, import, and otherwise transfer the Work,

where such license applies only to those patent claims licensable by such Contributor that are necessarily

infringed by their Contribution(s) alone or by combination of their Contribution(s) with the Work to which

such Contribution(s) was submitted. If You institute patent litigation against any entity (including a cross-claim

or counterclaim in a lawsuit) alleging that the Work or a Contribution incorporated within the Work constitutes

direct or contributory patent infringement, then any patent licenses granted to You under this License for that

Work shall terminate as of the date such litigation is filed.

4. Redistribution. You may reproduce and distribute copies of the Work or Derivative Works thereof in any

medium, with or without modifications, and in Source or Object form, provided that You meet the following

conditions:

1You must give any other recipients of the Work or Derivative Works a copy of this License; and

2You must cause any modified files to carry prominent notices stating that You changed the files; and

3You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent,
trademark, and attribution notices from the Source form of the Work, excluding those notices that do not
pertain to any part of the Derivative Works; and

4If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that You
distribute must include a readable copy of the attribution notices contained within such NOTICE file,
excluding those notices that do not pertain to any part of the Derivative Works, in at least one of the
following places: within a NOTICE text file distributed as part of the Derivative Works; within the Source
form or documentation, if provided along with the Derivative Works; or, within a display generated by the
Derivative Works, if and wherever such third-party notices normally appear. The contents of the NOTICE
file are for informational purposes only and do not modify the License. You may add Your own
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attribution notices within Derivative Works that You distribute, alongside or as an addendum to the
NOTICE text from the Work, provided that such additional attribution notices cannot be construed as
modifying the License. You may add Your own copyright statement to Your modifications and may
provide additional or different license terms and conditions for use, reproduction, or distribution of Your
modifications, or for any such Derivative Works as a whole, provided Your use, reproduction, and
distribution of the Work otherwise complies with the conditions stated in this License.

5. Submission of Contributions. Unless You explicitly state otherwise, any Contribution intentionally

submitted for inclusion in the Work by You to the Licensor shall be under the terms and conditions of this

License, without any additional terms or conditions. Notwithstanding the above, nothing herein shall supersede

or modify the terms of any separate license agreement you may have executed with Licensor regarding such

Contributions.

6. Trademarks. This License does not grant permission to use the trade names, trademarks, service marks, or

product names of the Licensor, except as required for reasonable and customary use in describing the origin of

the Work and reproducing the content of the NOTICE file.

7. Disclaimer of Warranty. Unless required by applicable law or agreed to in writing, Licensor provides the

Work (and each Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT WARRANTIES

OR CONDITIONS OF ANY KIND, either express or implied, including, without limitation, any warranties or

conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A PARTICULAR

PURPOSE. You are solely responsible for determining the appropriateness of using or redistributing the Work

and assume any risks associated with Your exercise of permissions under this License.

8. Limitation of Liability. In no event and under no legal theory, whether in tort (including negligence),

contract, or otherwise, unless required by applicable law (such as deliberate and grossly negligent acts) or

agreed to in writing, shall any Contributor be liable to You for damages, including any direct, indirect, special,

incidental, or consequential damages of any character arising as a result of this License or out of the use or

inability to use the Work (including but not limited to damages for loss of goodwill, work stoppage, computer

failure or malfunction, or any and all other commercial damages or losses), even if such Contributor has been

advised of the possibility of such damages.

9. Accepting Warranty or Additional Liability. While redistributing the Work or Derivative Works thereof,

You may choose to offer, and charge a fee for, acceptance of support, warranty, indemnity, or other liability

obligations and/or rights consistent with this License. However, in accepting such obligations, You may act

only on Your own behalf and on Your sole responsibility, not on behalf of any other Contributor, and only if

You agree to indemnify, defend, and hold each Contributor harmless for any liability incurred by, or claims

asserted against, such Contributor by reason of your accepting any such warranty or additional liability.
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END OF TERMS AND CONDITIONS

2.2.2. Model Text CSS License
Permission to use without fee

Permission to use, copy, and/or distribute this software for any purpose with or without fee is hereby granted to

you, provided that you accept all the terms of this license.

Transferable

You may copy and distribute this software to other parties ("third parties"), provided that the above copyright

notice and this permission notice appear in all copies, and that third parties are bound by the terms of this

license.

Closed source, no modification

This is closed source, proprietary software. The software's source code (except for some sample code) has not

been released. Although permission is hereby granted to write software which uses this software component,

and to use this software as a component within other software, permission is not granted to modify this

software component, nor to use nor to distribute modified copies.

No warranties

THE SOFTWARE IS PROVIDED "AS IS" AND THE LICENSOR DISCLAIMS ALL WARRANTIES

WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF

MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE LICENSOR BE LIABLE FOR ANY

SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES

WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION

OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN

CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

2.2.3. The MIT License
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The MIT License (MIT)

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated

documentation files (the "Software"), to deal in the Software without restriction, including without limitation

the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to

permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of

the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR

IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,

FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE

AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER

LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,

OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE

SOFTWARE.
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3. Getting Started
TouchDraw supplies everything you need to create structured 2D vector graphics on the go with your Mac.

Create charts, graphs, floor plans, architecture drawings, illustrations or most anything else you can image. Not

only does TouchDraw make it easy to quickly create your drawings, it also delivers a simple to use

environment where you will enjoy changing and manipulating each drawing.
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3.1. Opening TouchDraw
To open the TouchDraw application:

1

Open Finder.

2

Tap on Applications under favorites.

3

Locate the TouchDraw application and perform a Double Tap.



Page 20

TouchDraw for Mac

3.2. Closing TouchDraw
Select the TouchDraw Menu in the main application window and then select Quit TouchDraw to close the

application.
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3.3. Useful Links
Elevenworks Website

Useful links on the Elevenworks.com website.

Description Link

Elevenworks Main Website https://www.elevenworks.com/

TouchDraw Main Web Page https://www.elevenworks.com/touchdraw

TouchDraw Documentation https://www.elevenworks.com/documentation

To get support and/or to provide feedback on TouchDraw, you can contact Elevenworks via our Contact Form

or at the following email address: support@elevenworks.com.

TouchDraw on Twitter

Touchdraw also has a page/stream on Twitter where you can receive updates and/or have an open dialog with

the TouchDraw developers.http://twitter.com/touchdraw

TouchDraw on YouTube

TouchDraw also has a page on YouTube where example "how to" videos have and will be

posted.http://www.youtube.com/user/touchdraw

https://www.elevenworks.com/
https://www.elevenworks.com/touchdraw
https://www.elevenworks.com/documentation
https://www.elevenworks.com/contact
mailto:support@elevenworks.com
http://twitter.com/touchdraw
http://www.youtube.com/user/touchdraw
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4. User Interface
The following screen will open when the TouchDraw application is first launched:

This screen functions as the user interface for creating and managing drawings in TouchDraw for the Mac.

As shown above, the screen is split into two views. The drawing canvas and drawing tools are located on the

left portion of the application window. A sidebar is positioned on the right hand side and can be used to make

additional modifications to objects within a drawing.
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4.1. Menus
The menu bar contains 8 menus to access actions, options and settings related to the application, file

management and drawing manipulation.

Simply click on a menu and choose the desired option.

Menu Name Description

Application

(TouchDraw)

The Application (TouchDraw) menu contains options for application specific

settings and screen viewing.

File The File menu contains all file management options.

Edit The Edit menu contains common editing, duplication, and text manipulation choices.

Arrange The Arrange menu contains options for grouping, locking, moving, aligning, and

distributing objects within a drawing.

Modify The Modify menu contains options for modifying shapes, lines, and paths within a

drawing.

View The View menu contains options for changing what is viewed in the main application

window.

Window The Window menu contains options for application window sizing and drawing

manipulation.

Help The Help menu contains search and help file options.

4.1.1. Application Menu
Use the Application (TouchDraw) Menu to access global application level actions. When this menu is

selected, the options shown below will appear.
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Click on the name of the menu item to find out more details about what action occurs when it is selected.

Menu Item Description

About TouchDraw The About TouchDraw menu item provides application version information.

Preferences... The Preferences... menu item can be used to change general, handle, and

performance options for the application.

Services The Services submenu shows applicable services and contains preferences for those

being utilized.

Hide TouchDraw The Hide TouchDraw menu item hides all of the open TouchDraw related windows.

Hide Others The Hide Others menu item hides all of the open windows from other applications

while leaving the windows for TouchDraw open.

Show All The Show All menu item is enabled when application windows have been hidden and

can be selected to show the currently hidden windows.

Quit TouchDraw The Quit TouchDraw menu item closes the application.

4.1.2. File Menu
Use the File Menu to access actions related to the file management such as opening, saving, importing and

printing drawings. When this menu is selected, the options shown below will appear.
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Click on the name of the menu item to find out more details about what action occurs when it is selected.

Menu Item Description

New The New menu item can be used to create a new drawing.

Open The Open menu item can be used to open an existing TouchDraw document or it can

be used to import a drawing or image in one of the 3rd party file formats that

TouchDraw supports.

Open Recent The Open Recent menu item can be used to select from a list of most recently opened

drawings.

Close The Close menu item closes the current drawing.

Save The Save menu item saves the current drawing.

Save As... The Save As... menu item saves the current drawing as a new drawing.

Duplicate The Duplicate menu item creates a copy of the current drawing as a new save with

Copy added to the end of the file name (i.e. My Drawing Copy.2tl).

Export The Export menu item can be used to export a drawing into a one of the 3rd party file

formats supported for exporting.

Insert Image... The Insert Image menu item can be used to import a bitmap image stored on the local

file system into the current drawing.

Page Setup The Page Setup menu item opens a popup window used to specify page attribute,

formatting, orientation, and scaling options.
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Menu Item Description

Print The Print menu item can be used to print single or multiple pages of a drawing.

4.1.3. Edit Menu
Use the Edit Menu to access actions related to the clipboard, undo and miscellaneous text editing. When this

menu is selected, the options shown below will appear.

Click on the name of the menu item to find out more details about what action occurs when it is selected.

Menu Item Description

Undo The Undo menu item removes drawing changes in the order they were applied

starting with the most recent.

Redo The Redo menu item reapplies drawing changes in the order they were removed

starting with the most recent.

Cut The Cut menu item removes the currently selected item from the active drawing and

places it in the clipboard.

Copy The Copy menu item places a copy of the currently selected item into the clipboard.
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Menu Item Description

Paste The Paste menu item adds the most current item residing in the clipboard to the active

drawing.

Paste Special The Paste Special submenu contains special options related to pasting the contents of

the clipboard into the active drawing.

Delete The Delete menu item permanently removes an item from the active drawing.

Duplicate The Duplicate menu item creates a copy of a selected item in the active drawing.

Duplicate in Place The Duplicate in Place menu item creates a copy of a selected item and places it in

the same location as the original.

Select All The Select All menu item selects all items residing in the currently active drawing.

Deselect All The Deselect All menu item deselects all items residing in the currently active

drawing.

Spelling and

Grammar

The Spelling and Grammer submenu contains options for spelling and grammer

checks within an active drawing.

Transformations The Transformations submenu contains options for text case alterations.

Speech The Speech submenu contains options for speech recognition.

Special

Characters...

The Special Characters... menu item contains options for selecting special characters

and adding them to a favorites list for easy accessibility.

4.1.3.1. Paste Special Submenu
Use the Paste Special Submenu to access special actions related to the pasting the contents of the clipboard

into the active drawing. When this submenu is selected within the Edit Menu, the options shown below will

appear.
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Click on the name of the menu item to find out more details about what action occurs when it is selected.

Menu Item Description

Paste in Place The Paste in Place menu item copies the current clipboard item into the exact

location of the original.

Paste Multiple... The Paste Multiple... menu item can be used to paste multiple copies of a clipboard

item at specific offsets.

Paste Style The Paste Style menu item applies the formatting properties of one object to the

currently selected object.

4.1.4. Arrange Menu
Use the Arrange Menu to access actions for arranging or aligning selected figures within a drawing. When

this menu is selected, the options shown below will appear.

Click on the name of the menu item to find out more details about what action occurs when it is selected.
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Menu Item Description

Group The Group menu item allows currently selected shapes on the drawing canvas to be

manipulated and treated as a single figure. This menu item is enabled when two or

more groupable figures are selected in the drawing canvas. Shapes residing on the

drawing canvas can be manipulated**.**

Ungroup The Ungroup menu item removes the grouping attribute for selected shapes to allow

for individual manipulation. This menu item is enabled when one or more grouped

figures are selected in the drawing canvas.

Lock The Lock menu item prevents a selected figure(s) or group of figures from being

moved or resized. This menu item is enabled when one or more unlocked (and

lockable) figures are selected in the drawing canvas.

Unlock The Unlock menu item removes a previously instated lock on a figure(s) or group of

figures to allow for moving and resizing.This menu item is enabled when one or more

locked figures are selected in the drawing canvas.

Bring to Front The Bring to Front menu item moves a currently selected figure(s) to the front of all

figures residing in the same layer. This menu item is enabled when one ore more

figures are selected in the drawing canvas.

Bring Forward The Bring Forward menu item moves a currently selected figure(s) one step closer to

the top of the stack within the layer they reside in. This menu item is enabled when

one ore more figures are selected in the drawing canvas.

Send Backward The Send Backward menu item moves a currently selected figure(s) one step closer

to the bottom of a stack within their residing layer. This menu item is enabled when

one ore more figures are selected in the drawing canvas.

Send to Back The Send to Back menu item moves a currently selected figure(s) behind all other

figures residing within the same layer. This menu item is enabled when one ore more

figures are selected in the drawing canvas.

Align The Align submenu contains options to align figures in relation to each other.

Distribute The Distribute submenu contains options to distribute figures evenly in relation to

each other.
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4.1.4.1. Align Submenu
Use the Align Submenu to access actions for aligning selected figures within a drawing. When this submenu is

selected within the Arrange menu, the options shown below will appear.

Click on the name of the menu item to find out more details about what action occurs when it is selected.

Menu Item Description

Align to Grid The Align to Grid menu item aligns figures with the grid. This menu item is enabled

when two or more unlocked figures are selected in the drawing canvas.

Align Top The Align Top menu item moves all currently selected figures to match the top (Y

position) of the first selected figure. This menu item is enabled when two or more

unlocked figures are selected in the drawing canvas.

Align Vertical

Center

The Align Vertical Center menu item moves all currently selected figures to match

the vertical center (Y position + 1/2 of the height of all figures) of the first selected

figure. This menu item is enabled when two or more unlocked figures are selected in

the drawing canvas.

Align Bottom The Align Bottom menu item moves all currently selected figures to match the the

bottom (Y position + Height) of the first selected figure. This menu item is enabled

when two or more unlocked figures are selected in the drawing canvas.
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Menu Item Description

Align Left The Align Left menu item moves all currently selected figures to match the left (X

position) of the first selected figure. This menu item is enabled when two or more

unlocked figures are selected in the drawing canvas.

Align Horizontal

Center

The Align Horizontal Center menu item moves all currently selected figures to

match the horizontal center (X position + 1/2 of the width) of the first selected figure.

This menu item is enabled when two or more unlocked figures are selected in the

drawing canvas.

Align Right The Align Right menu item moves all currently selected figures to match the right (X

position + Width) of the first selected figure. This menu item is enabled when two or

more unlocked figures are selected in the drawing canvas.

4.1.4.2. Distribute Submenu
Use the Distribute Submenu to access actions for distributing the selected figures within a drawing. When this

submenu is selected within the Arrange menu, the options shown below will appear.

Click on the name of the menu item to find out more details about what action occurs when it is selected.
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Menu Item Description

Distribute

Horizontally

The Distribute Horizontally menu item adjusts the positioning of selected figures to

create an even amount of horizontal space between each figure. This menu item is

enabled when three or more unlocked figures are selected in the drawing canvas.

Distribute

Vertically

The Distribute Vertically menu item adjusts the positioning of selected figures to

create an even amount of vertical space between each figure. This menu item is

enabled when three or more unlocked figures are selected in the drawing canvas.

Pack Horizontally The Pack Horizontally menu item takes a set of selected shapes and "packs" them

into the smallest space possible horizontally.

Pack Vertically The Pack Vertically menu item takes a set of selected shapes and "packs" them into

the smallest space possible vertically.

Pack The Pack menu item takes a set of selected shapes and "packs" them into as small of a

rectangular space as possible. Be aware that the arrangement of selected figures might

be altered in order to pack them into the smallest space.

4.1.5. Modify Menu
Use the Modify Menu is used to transform or move the selected figures within a drawing. When this menu is

selected, the options shown below will appear.
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Click on the name of the menu item to find out more details about what action occurs when it is selected.

Menu Item Description

Rotate The Rotate submenu contains options to rotate the selected figures within a drawing.

Flip The Flip submenu contains options to flip the selected figures within a drawing.

Transform The Transform submenu contains options to transform (move, scale, etc...) the

selected figures within a drawing.

Open Path The Open Path menu item is enabled when one or more closed paths are selected.

This option removes a line segment or simply separates the last end/start points into

two separate handles to transform a closed path into an open path.

Close Path The Close Path menu item is enabled when one or more open paths are selected. This

option adds a line segment between the last end point and the start point of a selected

path or connects the start and end points of a curve segment to create a closed path.

Split All Segments The Split All Segments menu item is enabled when one or more paths are selected.

This option splits a selected path into segments at each end point handle to create

multiple individual path figures.

Join Lines/Paths The Join Lines/Paths menu item is enabled when two or more lines and/or open

paths are selected. This option joins the end point handles of segments to create a

single path figure.

Trim Lines/Paths The Trim Lines/Paths menu item is enabled when two or more shapes are selected

and at least one of those shapes is a line or open path. This option trims the ends of

intersecting lines, paths, or connections when the intersection is near the end of the

line/path.

Make Compound

Path

The Make Compound Path menu item is enabled when two or more paths are

selected. This option combines two or more selected paths into one compound path to

provide attribute sharing capabilities.

Separate

Compound Path

The Separate Compound Path menu item is enabled when one ore more compound

paths are selected. This option separates a compound path into individual paths.

Add Shapes The Add Shapes menu item is enabled when two shapes and/or closed paths are

selected. This option combines two selected shapes into one figure.
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Menu Item Description

Subtract Shapes The Subtract Shapes menu item is enabled when two shapes and/or closed paths are

selected. This option removes the intersecting portions of the second selected shape

from the first figure selected in the drawing canvas.

Intersect Shapes The Intersect Shapes menu item is enabled when two shapes and/or closed paths are

selected. This option removes all non-intersecting portions of selected figures from

the drawing canvas.

Exclude Shapes The Exclude Shapes menu item is enabled when two shapes and/or closed paths are

selected. This option removes the intersecting portions of selected figures from the

drawing canvas.

Convert Shape to

Path

The Convert Shape to Path is enabled when one or more shapes or lines are selected.

This option converts the bordering lines of a selected shape into a closed path by

adding the necessary handles.

Convert Text to

Path

The Convert Text to Path is enabled when one or more text figures are selected. This

option converts a text figure created with the Text tool into a path.

4.1.5.1. Rotate Submenu
Use the Rotate Submenu to access actions for rotating the selected figures within a drawing. When this

submenu is selected within the Modify Menu, the options shown below will appear.

Click on the name of the menu item to find out more details about what action occurs when it is selected.

Menu Item Description

Rotate 90° Right The Rotate 90° Right menu item rotates a selected figure to the right by 90°.
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Menu Item Description

Rotate 90° Left The Rotate 90° Left menu item rotates a selected figure to the left by 90°.

Rotate 180° The Rotate 180° menu item rotates a selected figure by 180°. The figure is flipped

upside down or back to its original position depending on the number of times this

selection is made.

Reset Center

Rotation

The Reset Center Rotation menu item is enabled when the "Center of Rotation"

option in the Handles Settings popup menu is selected and has been altered on a

shape. This option changes the "Center of Rotation" for a shape back to its original

centered location.

4.1.5.2. Flip Submenu
Use the Flip Submenu to access actions for flipping the selected figures within a drawing. When this submenu

is selected within the Modify Menu, the options shown below will appear.

Click on the name of the menu item to find out more details about what action occurs when it is selected.

Menu Item Description

Flip Horizontally The Flip Horizontally menu item interchanges the position of a figure horizontally.

Flip Vertically The Flip Vertically menu item interchanges the position of a figure vertically.

4.1.5.3. Transform Submenu
Use the Transform Submenu to access actions for transforming (moving, scaling, etc...) the selected figures

within a drawing. When this submenu is selected within the Modify Menu, the options shown below will

appear.
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Click on the name of the menu item to find out more details about what action occurs when it is selected.

Menu Item Description

Move By... The Move By... menu item changes the location of a figure based on input coordinates.

Scale By... The Scale By... menu item alters figure size based on input coordinates to create a

smaller or larger figure spanning over a specific area.

4.1.6. View Menu
Use the View Menu to access actions for changing settings of the currently visible drawing canvas. When this

menu is selected, the options shown below will appear.

Click on the name of the menu item to find out more details about what action occurs when it is selected.
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Menu Item Description

Zoom In The Zoom In menu item increases the magnification level of the drawing canvas to

allow for working on the drawing in more detail.

Zoom Out The Zoom Out menu item decreases the magnification level of the drawing canvas

make a larger portion of the drawing viewable in the window at once.

Zoom to Fit The Zoom to Fit menu item will dynamically resize the magnification level and the

location of the drawing within the drawing canvas to make the complete drawing

visible in the window.

Zoom to Actual

Size

The Zoom to Actual Size menu item returns a drawing back to the normal

magnification level (100%).

Zoom to Origin The Zoom to Origin menu item returns a drawing back to it's normal magnification

level (100%) and resets the visible portion of the drawing canvas so that the

coordinates 0,0 are in the upper left hand corner.

Hide Rulers The Hide Rulers menu item removes the left and top rulers from the main application

window. Select this menu option again for the rulers to reappear.

Hide Grid The Hide Grid menu item removes the background grid from the main application

window to show a blank canvas. Select this menu option again for the grid to reappear.

Show Page Bounds The Show Page Bounds menu item places page boundary lines on the drawing

canvas when enabled. This option is disabled by default within TouchDraw and must

be selected from the menu to be enabled. Select this menu option again to disable it

and remove the boundary lines.

Snapping Submenu The Snapping submenu contains options related to the snapping behavior of the

active drawing canvas.

Enter Full Screen The Enter Full Screen menu item switches the main application window from the

current setting to full screen mode.

Hide Format Bar The Hide Format Bar menu item removes the formatting bar from the TouchDraw

application window. Select this menu option again for the formatting bar to reappear.

Hide Side Bar The Hide Side Bar menu item removes the side bar from the TouchDraw application

window. Select the menu option again for the side bar to reappear.

Show Colors The Show Colors menu item can be used to toggle the visibility of the Mac OS X

https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/Sidebar-Old.md
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Menu Item Description

standard color picker.

Hide Toolbar The Hide Toolbar menu item removes the main toolbar from the TouchDraw

application window. Select the menu option again for the Toolbar to reappear.

Customize Toolbar The Customize Toolbar menu item can be used to alter what buttons appear in the

main toolbar.

4.1.6.1. Snapping Submenu
Use the Snapping Submenu to access the settings related to the snapping for the active drawing canvas. When

this submenu is selected within the View Menu, the options shown below will appear.

Click on the name of the menu item to find out more details about what action occurs when it is selected.

Menu Item Description

Snap to Grid The Snap to Grid menu item aligns objects to the grid for more precise drawing

modifications.

Snap to Lines The Snap to Lines menu item aligns objects with the nearest lines.

Snap to

Pixels/Points

The Snap to Pixels/Points menu item aligns objects to whole pixel numbers for

simplified object modification and increased accuracy.
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Menu Item Description

Snap to Shapes The Snap to Shapes option snaps a figure to a selected shape vertex or center point.

To see this option in action, disable the Snap to Grid option, make certain Snap to

Shapes is enabled, and then draw a star or rectangle. Once the shape is completed,

select the Line Tool and try to draw a line from one of the vertexes of the shape or its

center point. The drawn line will snap to one of these locations.

4.1.7. Window Menu
Use the Window Menu to access actions applicable to the active window. When this menu is selected, the

options shown below will appear.

Click on the name of the menu item to find out more details about what action occurs when it is selected.

Menu Item Description

Minimize The Minimize menu item minimizes the main application window.

Zoom The Zoom menu item expands and decreases the main application window.

Bring All to Front The Bring All to Front menu item moves TouchDraw application windows to the

front of all other currently open Mac application windows.

4.1.8. Help Menu
Use the Help Menu to access help and feedback options for TouchDraw. When you select this menu, the

options shown below will appear.
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Click on the name of the menu item to find out more details about what action occurs when it is selected.

Menu Item Description

Search The Search menu item can be used to search the general Mac OS X help topics.

Documentation... The Documentation menu item will take you to this documentation.

Acknowledgements... The Acknowledgements menu item will take you to the Open Source

acknowledgements page.

Send Feedback... The Send Feedback menu item will create a new feedback email message in your

preferred email client addressed to the TouchDraw team.

Report an Issue... The Report and Issue menu item will create a new issue reporting email message in

your preferred email client addressed to the TouchDraw team.
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4.2. Toolbar
The Main Toolbar appears at the top of the main screen as shown below and can be used to perform various

functions on selected objects or on an entire drawing. In addition to the actions that are shown by default, you

can configure the main toolbar to add or remove other actions based on how you want to use TouchDraw.

Changing the actions in the toolbar is covered in the Customizing the Main Toolbar section.

4.2.1. Toolbar Actions
The following list describes all of the actions that are available to be configured as part of the toolbar:

Icon Name Description

Print The Print toolbar option can be used to print a currently

opened drawing.

Lock This option will be enabled if one or more unlocked figures are

selected in the current drawing window. The Lock toolbar

option prevents moving and resizing actions on the selected

figure(s).

Unlock This option will be enabled if one or more locked figures are

selected in the current drawing window. The Unlock toolbar

option removes a lock on single or multiple figures for moving

and resizing.

Group This option will be enabled if two or more figures are selected

in the current drawing window. The Group toolbar option

combines selected figures into a single object for performing

manipulation actions.

Ungroup This option will be enabled if one or more grouped figures are

selected in the current drawing window. The Ungroup toolbar
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Icon Name Description

option separates a previously grouped set of figures for

individual manipulation.

Front This option will be enabled if one or more figures are selected

in the current drawing window. The Front toolbar option will

move the currently selected figure(s) to the front of all other

figures within the layer they reside in.

Forward This option will be enabled if one or more figures are selected

in the current drawing window. The Forward toolbar option

will move the currently selected figure(s) one step closer to the

top of the stack within their residing layer.

Backward This option will be enabled if one or more figures are selected

in the current drawing window. The Backward toolbar option

will move the currently selected figure(s) one step closer to the

bottom of the stack within their residing layer.

Back This option will be enabled if one or more figures are selected

in the current drawing window. The Back toolbar option will

move the currently selected figure(s) behind all other figures

within their residing layer.

Add This option will be enabled if two figures are selected in the

current drawing window. The Add toolbar option will combine

two selected figures to form one object.

Subtract This option will be enabled if two figures are selected in the

current drawing window. The Subtract toolbar option will

remove the bottom layered figure from the drawing canvas

along with any portion intersecting the additionally selected

figure.

Intersect This option will be enabled if figures are selected in the current

drawing window. The Intersect toolbar option will remove all

portions of the two selected figures while leaving the section

where they meet.

Exclude This option will be enabled if two figures are selected in the
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Icon Name Description

current drawing window. The Exclude  toolbar option will

remove the intersecting portion of two selected figures while

leaving the remaining portions on the drawing canvas.

Left This option will be enabled if two or more figures are selected

in the current drawing window. The Align Left toolbar option

moves all currently selected figures to match the left (X

position) of the first selected figure.

Horizontal Center This option will be enabled if two or more figures are selected

in the current drawing window. The Align Horizontal Center

toolbar option moves all currently selected figures to match the

horizontal center (X position + 1/2 of the width) of the first

selected figure.

Right This option will be enabled if two or more figures are selected

in the current drawing window. The Align Right toolbar option

moves all currently selected figures to match the right (X

position + Width) of the first selected figure.

Top This option will be enabled if two or more figures are selected

in the current drawing window. The Align Top toolbar option

moves all currently selected figures to match the top (Y

position) of the first selected figure.

Vertical Center This option will be enabled if two or more figures are selected

in the current drawing window. The Align Vertical Center

toolbar option moves all currently selected figures to match the

vertical center (Y position + 1/2 of the height of all figures) of

the first selected figure.

Bottom This option will be enabled if two or more figures are selected

in the current drawing window. The Align Bottom toolbar

option moves all currently selected figures to match the the

bottom (Y position + Height) of the first selected figure.

Sidebar The Sidebar toolbar option will toggle (display or hide based

on the current state) the sidebar for the current drawing window.
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Icon Name Description

Rotate 90° Right The Rotate 90° Right toolbar option rotates selected figures in

the current drawing to the right by 90°.

Rotate 90° Left The Rotate 90° Left toolbar option rotates selected figures in

the current drawing to the left by 90°.

Rotate 180° The Rotate 180° toolbar option rotates selected figures in the

current drawing by 180°. The figure is flipped upside down or

back to its original position depending on the number of times

this selection is made.

Flip Horizontally The Flip Horizontally toolbar option interchanges the position

of selected figures horizontally.

Flip Vertically The Flip Vertically toolbar option interchanges the position of

selected figures vertically

Colors The Colors toolbar option will toggle (display or hide based on

the current state) the standard Mac color picker floating

window.

Fonts The Fonts toolbar option will toggle (display or hide based on

the current state) the standard Mac font picker floating window.

Bigger This option will be enabled if one or more figures are selected

in the current drawing window. The Bigger toolbar option

increases the font size of text within a figure(s) by increments

of 1.

Smaller This option will be enabled if one or more figures are selected

in the current drawing window. The Smaller toolbar option

decreases the font size of text within a figure(s) by increments

of 1.

Undo The Undo toolbar option reverts the last change that was made

to a drawing. This option is disabled (dimmed) when no

changes have been made and enabled as soon as something is

altered on the Drawing Canvas.

Redo The Redo toolbar option cancels the last undone change made
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Icon Name Description

to the Drawing Canvas . This option is disabled (dimmed) when

nothing has been undone and is enabled as soon as the Undo 

command has been used or something is altered.

4.2.2. Customizing the Main
Toolbar
The Main Toolbar is located above the menu bar in the TouchDraw application window and can be used to

perform specific drawing manipulation functions quickly with a single mouse click. The toolbar can be

customized to show a desired set of functions or to contain a default set depending on user preferences. Follow

the steps below to alter what icons appear when using the application.

Select the View Menu> Customize Toolbar... to open the customization window.

The customization window will appear as shown below:
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The Main Toolbar is customized by one of two actions:

1

Dragging individually selected icons to a desired position in the Main Toolbar.

2

Dragging the default set onto the Main Toolbar.
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The Show drop down menu options alter how the selected icons appear within the Main Toolbar: Icons and

Text, Icons Only, or Text Only. Use the Show Small Size setting to make shown icons appear smaller and

receive increased space for additional toolbar selections.

Click on the Done button when all desired actions and settings have been chosen.

Fixed or flexible spaces can be added to any location as a method for creating individual groups of icons within

the toolbar.
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4.3. Format Bar
The Format Bar appears between the main toolbar and the drawing canvas of the application window. It can

be used to perform text, stroke, and fill color alterations on a selected object or an entire drawing.

Click on the name of the menu item to find out more details about what action occurs when the menu item is

selected.

Name Description

Text Attributes The Text Attribute buttons are used to change font family, style, size, color, and

additional text properties for currently selected figures or an entire drawing.

Stroke Attributes The Stroke Attribute buttons are used to change style, size, and color stroke

properties for currently selected figures or an entire drawing.

Fill Attributes The Fill Attribute button alters the fill color of a selected figure, group of figures, or

an entire drawing.
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4.4. Drawing Canvas
The Drawing Canvas is the area of the screen that displays the currently active drawing. All added figures

appear in this portion of TouchDraw.

The Menus and Sidebar can be used access several options for altering figure size, attributes, and positioning

within the Drawing Canvas.
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4.5. Drawing Toolbar
The Drawing Toolbar, located on the left side of the screen, contains all available drawing tools for adding to

or manipulating the current drawing. The tools and their exact functionality are detailed in the following

sections; however there are some general concepts of the toolbar that need to be discussed first. All tools with

the exception of the move/zoom/select tool can operate in two modes: "Normal" or "Sticky".

Normal Mode

In Normal Mode, which is activated by selecting the tool through a single click, the tool is used to insert one

figure into the drawing. Upon completion of creating that figure, the Move, Zoom and Selection Tool will be

reactivated and the newly created figure is selected. A tool is in Normal Mode when it's background is

highlighted with a blue gradient as shown in the first figure below.

Sticky Mode

Sticky Mode, which is activated by selecting a tool by a double click, makes it possible to add many figures

into the drawing without having to reselect the tool. Upon completion of creating a figure, the tool will remain

selected, and you can immediately begin creating/inserting additional figures of the same type. To cancel/end

creating the selected figure type, simply select another tool. A tool is in Sticky Mode when it's background is

highlighted with a blue gradient and contains a lock symbol in the lower right hand corner as shown in the

figure below.
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The Selection, Connection, Oval, and Polygon Tools have additional options as indicated by the right facing

arrow at the bottom of each button. Perform an extended Click to access these features. Available choices will

appear as shown below:
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These Drawing Toolbar options are explained in further detail under the Selection Tool, Connection Tool,

Oval Tool, and Polygon Tool sections of the documentation.

4.5.1. Selection Tool
The Selection Tool is the chosen tool default within the application each time a drawing is created or opened.

The following described functions can be performed when this tool is selected.

The simplest and most common method for selecting objects is to perform a click within bounds of a figure (for

ovals, rectangles, rounded rectangles, polygons, filled paths, text and images) or on a line (for lines and paths).

Handles are displayed as a visual indicator of successful figure selection.

Figures can also be selected by outlining an area within the grid. Click in a grid location where no figures are

present and drag the selection rectangle over the drawing canvas to select all objects within a desired area. All

figures residing in or intersecting the defined area are automatically selected when the drag action is completed.
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Single Selection

Using the methods above, without pressing the Shift Key, results in what TouchDraw considers to be single

selection. By single selection, we mean that only the figure or figures selected within the enactment of one

action will be selected.
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Multiple Selection

To select multiple figures in an individual manner, hold down the Shift Key and click on a desired figure. Each

"shift-click" will add the figure as part of the overall selection when not already selected or deselect the figure

if it is already selected. This application option allows you to have fine grained control over the selected figures.

Zooming

To zoom in or out when viewing a drawing, you can use one of two methods:

1Use a pinching action on the mousepad. Bring your fingers together on the mousepad to zoom in and
move them away from each other to zoom out.

2Use the Zoom In and Zoom Out options within the View Menu.

Moving (Panning)

To move around in a drawing, make certain the cursor is within the Drawing Canvas and then drag two fingers

(without pinching or expanding them) on the mousepad to pan around.

The Move and Zoom Tool and Zoom Rectangle Tool

Two additional Selection Tool options are made available when an extended Click action is performed over

the tool button.

The Move and Zoom Tool selection allows the grid to be moved with a Click/Drag option for panning,

zooming in, or zooming out on an entire drawing rather than moving the objects residing on the drawing

canvas. The Zoom Rectangle Tool can be used to draw a rectangle over a portion of the drawing canvas to

specify a precise zooming location.
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4.5.2. Move and Zoom Tool
The Move and Zoom Tool selection allows the visible portion of the drawing to be moved with a Click/Drag

action for performing panning or zooming actions on an entire drawing rather than moving the objects residing

on the drawing canvas. This option is accessible when an extended Click is performed over the Selection Tool

button and will appear as shown below.

4.5.3. Zoom Rectangle Tool
The Zoom Rectangle Tool selection can be used to draw a rectangle over a portion of the drawing canvas to

specify a precise zooming location. It provides finer control than the Pinch and Zoom gesture when zooming in

on specific figures within the drawing canvas. This option is accessible when an extended Click is performed

over the Selection Tool button. Click on the Zoom Rectangle Tool and it will appear in place of the standard

Selection Tool in the Drawing Toolbar.
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Use a Click/Drag action to drag the rectangle over a desired area and then release this action to complete the

selection. In this example, the red circle and blue square are selected with the Zoom Rectangle Tool.

The Drawing Editor will automatically zoom in on the figures within the selected area.
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4.5.4. Pen Tool
The Pen Tool uses a technique called curve fitting to create a smooth curve from a freehand path that is drawn

by using a Click/Drag combination to drag the tool to desired points on the drawing canvas.

To use the tool, simply select it, and then draw a freehand path by using a Click/Drag combination to
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maneuver the pen. The Pen Tool  converts the drawn path into a smooth curve once the click action is released.

The following figure illustrates what a curve looks like when drawn by hand, and then what it looks like after

the Pen Tool  has created the curve.

The Pen Tool can create shapes instead of paths by using the Shift key in conjunction with the pen tool.

Holding down the Shift key during shape (path) drawing creates a closed shape instead of an open path.

4.5.5. Line Tool Old

4.5.6. Line Tool
The Line Tool can be selected to draw straight lines. Use a Click/Drag combination to draw the line from a set

starting point to a desired end point. The trackpad performs the necessary dragging action between two line
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points and a release of the Click  action completes this drawing function.

Holding down the Shift Key during line creation constrains the line to increments of 90 degrees.

The length and angle of a line can be altered any time after a line has been created. To alter the length or angle

of a line:

1

Choose the Selection Tool in the Drawing Toolbar and then highlight the desired line.

2
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Click on the Adjustment Tab located under "Info" on the Sidebar.

3

You will find the Line Length and Line Angle options in the bottom right portion of the Shape Specific

section in the Sidebar. Use the "up" or "down" arrow buttons to change either value or click on the text entry

field to key in a value.

4

When entering a value into the Line Length or Line Angle options, a different unit of measure other than the

default of Inches or Degrees can be entered. Enter the desired value and unit of measurement. Then use the

Enter Key on your keyboard or click in another area of TouchDraw and the entered value will automatically

be converted to its equivelent value in Inches.

For example, the Line Length value could be 10 centimeters (10 cm) or 50 millimeters (50 mm) and the Line

Angle could be 5 radians (5 rad). Once the desired value and unit of measurement have been entered,

TouchDraw will automatically convert it to the equivelent value in Inches or Degrees.

1

Example 1: Entering 10 cm for the Line Length:
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2

Example 2: Entering 50 mm for the Line Length:

3

Example 3: Entering 5 rad for the Line Angle:

The Style As Dimension Line option within the Contextual Menu may be used to add dimensional aspects to

an existing line figure. When this option is used, TouchDraw automatically adds arrowheads and a  variable to

the selected line(s). At least one line must be selected in the Drawing Canvas for this option to appear within

the Contextual Menu. Follow the steps shown below to use this option:

1

Select the line figure you would like to alter.
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2

Then right click on the Drawing Canvas to bring up the Contextual Menu.

3

Click on Style As Dimension Line and the selected line figure(s) will appear similar to the example shown

below:
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4.5.7. Connection Tool
The Connection Tool can be used to draw lines for connecting one figure to another and makes it easy to

create connected graphs such as flow charts.

Perform the following actions to create a connected graph on the drawing canvas:

1

Begin by creating two figures and then select the Connection Tool. All figures including path shapes, text

blocks, and images can be connected with the exception of lines and open paths.
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2

Maneuver the mouse to the desired connection point in the first figure and perform a Click action. The figure

will be "highlighted" with a light blue border when the selection has been performed correctly. The light blue

border indicates the ability to connect the figure.

3

Use the trackpad to drag from the start figure to the end figure where the connection will terminate. When the

mouse is within the "target" figure, it will be "highlighted" with a light blue border. The light blue border

indicates the ability to connect the second figure to the source figure.

4
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The connection line is created between the two figures when the Click action is released.

5

Performing a Click/Drag combination on the second figure after the connection is established results in the

connection line position being adapted to keep the two figures connected.
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To learn more about using different connector types and the connection tool, please see the following pages:

6Connection Tool Options

7Line Connection Tool

8East-West Connection Tool

9North-South Connection Tool

10Horizontal-Vertical Connection Tool

11Vertical-Horizontal Connection Tool

12Path Connection Tool

13Hub Connection Tool

4.5.7.1. Connection Tool Options
Connection Tool options are made available when an extended Click action is performed over the tool button.

Click on the name of an available Connection Tool choice to find out more details about what action occurs

when it is selected.

Icon Name Description

Line Connection

Tool

The Line Connection Tool draws a line connection that

connects two shapes in the shortest path.

East-West

Connection Tool

The East-West Connection Tool draws a connection line that

originates from the side (either west/left or east/right) of the

source figure and connects to the side (either west/left or

east/right) of the target figure.
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Icon Name Description

North-South

Connection Tool

The North-South Connection Tool draws a connection line

that originates from the side (either north/top or south/bottom)

of the source figure and connects to the side (either north/top or

south/bottom) of the target figure.

Horizontal-Vertical

Connection Tool

The Horizontal-Vertical Connection Tool draws a connection

line that originates horizontally from the right or left side of the

source figure and connects vertically to the side (top) of the

target figure.

Vertical-Horizontal

Connection Tool

The Vertical-Horizontal Connection Tool draws a connection

line that originates vertically from the side (either top or

bottom) of the source figure and connects to the side (either left

or right) of the target figure.

Path Connection

Tool

The Path Connection Tool creates a path connection that

connects two shapes. As with paths created with the Path Tool,

path connections can be manipulated to add additional line or

curve segments.

Hub Connection

Tool

The Hub Connection Tool creates a connection line that is

able to receive connections. This is typically used for creating

network diagrams.

4.5.7.2. Line Connection Tool
The Line Connection Tool draws a line connection from a source figure and connects in the shortest way to a

target figure. The start, line, and end points of a connection line can be altered in the Stroke tab located in the

Info portion of the Sidebar. To create a connection with this tool:

1

Select the Line Connection Tool in the drawing toolbar.
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2

Perform a Click/Drag combination at the desired starting point on the source figure and move the handle to a

desired end point on the target figure.

3

Release the Click action to complete the connection line. Each selected figure will be highlighted in blue when

a valid connection has been made.

4

The completed connection line will appear as shown below:
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Performing a Click/Drag combination on the second figure after the connection is established results in the

connection line position being adapted to keep the two figures connected.
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4.5.7.3. East-West Connection Tool
The East-West Connection Tool draws a connection line that originates from the side (either west/left or

east/right) of the source figure and connects to the side (either west/left or east/right) of the target figure. To

select the East-West Connection Tool, perform an extended Click on the connection tool button in the Drawing

Toolbar to bring up the popup menu.

This connection between the figures is created in the same manner as with the Line Connection Tool, but the

connection path remains orthogonal with the source and target lines remaining horizontal.

Perform a Click/Drag combination from the desired starting point on a figure to the desired end point on

another figure and then release the Click action to complete the connection. The selected figures will be

highlighted in blue when a valid connection has been made. Refer to the images below:
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The completed connection line will appear as shown below:
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The connection line will automatically contain a rounded corner. To change the Corner Size of the created

connection line, make certain it is selected. Then click on the tab in the Sidebar and then alter the Corner Size

value by pressing on the Up and Down buttons.

Changing the Corner Size to zero for a selected connection line causes the corners to become ninety degree

angles as shown below.
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Note: Performing a Click/Drag combination on the second figure after the connection is established results in

the connection line position being adapted to keep the two figures connected.

4.5.7.4. North-South Connection
Tool
The North-South Connection Tool draws a connection line that originates from the side (either north/top or

south/bottom) of the source figure and connects to the side (either north/top or south/bottom) of the target

figure. To select the North-South Connection Tool, perform an extended Click on the connection tool button in

the Drawing Toolbar to bring up the popup menu.
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This connection between the figures is created in the same manner as with the Line Connection Tool, but the

connection path remains orthogonal with the source and target lines remaining vertical.

Perform a Click/Drag combination from the desired starting point on the source figure to the desired end point

on the target figure and then release the Click action to complete the connection. The selected figures will be

highlighted in blue when a valid connection has been made. Refer to the images below:
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The completed connection line will appear as shown below.

The connection line will automatically contain a rounded corner. To change the Corner Size of the created

connection line, make certain it is selected. Then click on the tab in the Sidebar and then alter the Corner Size

value by pressing on the Up and Down buttons.
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Changing the Corner Size to zero for a selected connection line causes the corners to become ninety degree

angles as shown below.

Performing a Click/Drag combination on the second figure after the connection is established results in the

connection line position being adapted to keep the two figures connected.

4.5.7.5. Horizontal-Vertical
Connection Tool
The Horizontal-Vertical Connection Tool draws a connection line that originates horizontally from the right

or left side of the source figure and connects vertically to the side (top) of the target figure. To select the
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Horizontal-Vertical Connection Tool, perform an extended Click  on the connection tool button in the Drawing

Toolbar  to bring up the popup menu.

This connection between the figures is created in the same manner as with the Line Connection Tool, but the

connection path remains orthogonal with the source lines remaining horizontal and target lines remaining

vertical.

Perform a Click/Drag combination from the desired starting point on the source figure to a desired end point

on the target figure and then release the Click action to complete the connection. The selected figures will be

highlighted in blue when a valid connection has been made. Refer to the images below:
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The connection line will appear as shown below:
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The connection line will automatically contain a rounded corner. To change the Corner Size of the created

connection line, make certain it is selected. Then click on the tab in the Sidebar and then alter the Corner Size

value by pressing on the Up and Down buttons.

Changing the Corner Size to zero for a selected connection line causes the corners to become ninety degree

angles as shown below.
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Performing a Click/Drag combination on the second figure after the connection is established results in the

connection line position being adapted to keep the two figures connected.

4.5.7.6. Vertical-Horizontal
Connection Tool
The Vertical-Horizontal Connection Tool draws a connection line that originates vertically from the side

(either top or bottom) of the source figure and connects to the side (either left or right) of the target figure. To

select the Vertical-Horizontal Connection Tool, perform an extended Click on the connection tool button in the

Drawing Toolbar to bring up the popup menu.
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This connection between the figures is created in the same manner as with the Line Connection Tool, but the

connection path remains orthogonal with the source lines remaining vertical and target lines remaining

horizontal.

Perform a Click/Drag combination from the desired starting point on the source figure to a desired end point

on the target figure and then release the Click action to complete the connection. The selected figures will be

highlighted in blue when a valid connection has been made. Refer to the images below:
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The completed connection will appear as shown below.

The connection line will automatically contain a rounded corner. To change the Corner Size of the created

connection line, make certain it is selected. Then click on the tab in the Sidebar and then alter the Corner Size

value by pressing on the Up and Down buttons.
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Changing the Corner Size to zero for a selected connection line causes the corners to become ninety degree

angles as shown below.
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Note: Performing a Click/Drag combination on the second figure after the connection is established results in

the connection line position being adapted to keep the two figures connected.

4.5.7.7. Path Connection Tool
The Path Connection Tool creates a path connection that connects two shapes. As with paths created with the

Path Tool, path connections can be manipulated to add additional line or curve segments. To select the Path

Connection Tool, perform an extended Click on the connection tool button in the Drawing Toolbar to bring up

the popup menu.

This connection between the figures is created in the same manner as with the Line Connection Tool, but the

created path can be modified just as items generated with the Path Tool. See the handling paths section of this

documentation to learn more.

Perform a Click/Drag combination from the desired starting point on the source figure to a desired end point

on target figure and then release the Click action to complete the connection. The selected figures will be
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highlighted in blue when a valid connection has been made. Refer to the images below:

The completed connection will appear as shown below.

Performing a Click/Drag combination on the second figure after the connection is established results in the

connection line position being adapted to keep the two figures connected.

Altering the Route of Path Connection Lines

Once the Path Connection Line has been added to the desired target figure from the selected source figure, it

can be manuplated in the same manner as a Path Figure. In this example, the connection line currently goes
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through the middle rectangle.

To route the Path Connection Line around another figure, handles must be added to the connection line or it

must be converted to a quadratic or cubic segment. These options can be accessed by performing a Right Click

(Control/Click) on the connection line to open the Contextual Menu and then selecting the Paths Submenu.

Several options will appear within the Contextual Menu for modifying the connection line and routing it

around a specific figure. Handles and/or curved segments can be added to alter the route of the connection line.

Please note that if you select Delete Segment without adding any additional handles or segments, then the

connection line will be completely removed from the drawing.

Example 1: Inserting Handles
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Inserting handles and then dragging them to desired points in the Drawing Canvas is one method for altering

the route of a Path Connection Line. Follow the steps below to learn how to do so.

1

Perform a Right Click (Control/Click) on the connection line in a location to the left of the crossed figure and

then select Insert Handle from the Paths Submenu.

2

A new Path Handle (Orange) will appear within the Path Connection Line as shown below:

3

Perform a Right Click (Control/Click) on the connection line in a location to the right of the crossed figure

and then select Insert Handle from the menu again to add another Path Handle (Orange).
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4

Then click and drag down or up on the left handle to change the direction/path of the connection line.

5

Notice that the line still intersects the figure. Click and drag on the right handle to continue altering the

direction/path of the connection line. This will result in the straight segment residing below the figure and a

successfully routed Path Connection Line.
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    Note: Please note that the handles may be moved in any direction; however, for this example both are moved

down to route the connection line around the figure.

Example 2: Segment to Quad

A Path Connection Line can also be routed differently by converting the line to a quadratic segment. This

example will use the same original figures as shown previously and will display how to convert the current

connection line to a quadratic segment for path routing.

1

Perform a Right Click (Control/Click) on the connection line and then select Segment to Quad from the

Paths Submenu.

2

A Control Point Handle (Green) will appear in the middle of the connection line.
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3

Click and drag the handle downward (or upward) to create a curved segment. The Control Point Handle may

be moved in any direction; however, for this example, it is moved downward below the figure.

Example 3: Segment to Cubic

A Path Connection Line can also be routed differently by converting the line to a cubic segment. This

example will use the same original figures as shown previously and will display how to convert the current

connection line to a quadratic segment for path routing.
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1

Perform a Right Click (Control/Click) on the connection line and then select Segment to Cubic from the

menu.

2

Two Control Point Handles (Green) will appear within the connection line.

3

Click and drag in any direction on the left handle to change the position of the Path Connection Line. In this
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example, both handles are dragged downward.

4

Then do the same for the right handle to finish routing the connection line around a figure within a drawing.

4.5.7.8. Hub Connection Tool
The Hub Connection Tool creates a connection line that is able to receive connections and is typically used

for creating network diagrams.The connection line can originate from any side of the source figure and

connects to any side of the target figure or to another hub connection line. To select the Hub Connection Tool,

perform an extended Click on the connection tool button in the Drawing Toolbar to bring up the popup menu.
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This connection between the figures is created in the same manner as with the Line Connection Tool; however,

the connection path can be placed between two hub connection lines to create a networking or alternative type

of diagram.

Perform a Click/Drag combination from the desired starting point on the source figure to the desired end point

on the target figure or hub connection line and then release the Click action to complete the connection. The

selected figures or hub connection lines will be highlighted in blue when a valid connection has been made.

Refer to the images below to see a hub connection between figures:



Page 94

TouchDraw for Mac

The completed connection line will appear as below.

The following example shows a hub connection line joining two previously drawn hub connection lines.
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Performing a Click/Drag combination on the second figure after the connection is established results in the

connection line position being adapted to keep the two figures connected.

4.5.8. Oval Tool
The Oval Tool is used to create ovals or circles within a drawing. To use the tool, simply select it and then

perform a Click/Drag combination at the point in the drawing panel where one of the bounding corners of the

oval or circle should be. Drag in any direction and release the Click action where the other bounding corner

should be.

Using the Oval Tool while holding down the Shift key allows for the creation of perfect circles by constraining
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the width and the height of the created object to equal values.

An oval can also contain text. See the Handling Text section for additional details.

Circle Tool

Additional Oval Tool options are made available when an extended Click action is performed over the tool

button.
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This Circle Tool creates a perfect circle where the radius increases in increments as the size of the shape

increases.

4.5.9. Circle Tool
This Circle Tool creates a perfect circle where the radius increases in increments as the size of the shape

increases. To select the Circle Tool, perform an extended Click on the Oval Tool button in the Drawing Toolbar

 to bring up the popup menu.
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Click on the point in the drawing canvas where the center of the circle should be and Drag outward until the

circle consists of a desired radius or size. Release the Click action to complete the circle. The radius and angle

values will increase as the size of the circle increases. Refer to the images below:

The radius of a circle can be altered any time after it's creation. To set the radius:

1

Choose the Selection Tool in the Drawing Toolbar and then highlight the desired circle.
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2

Click on the Adjustment Tab located under "Info" on the Sidebar.

3

You will find the Radius option in the bottom right portion of the Shape Specific settings section. Use the "up"

or "down" arrow buttons to change the value or click on the text entry field to key in a value.

When typing in a Radius value, a different unit of measure (i.e. points, pixels, millimeters, centimeters, inches,

feet, meters, etc.) other than the default of Inches can be entered for the dimensional attribute. Enter the desired

value and unit of measurement. Then use the Enter Key on your keyboard or click in another area of

TouchDraw and the entered value will automatically be converted to its equivelent value in Inches.

1

For example, if 1 centimeter (1 cm) is entered for the Radius, then it will be converted to 0.394 inches.
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2

In this example, 15 millimeters (15 mm) is entered for the Radius and is converted to 0.591 inches.

3

If you enter 100 pixels (100 px), then the value would be 1.389 inches.

    Note: A circle can also contain text. See Handling Text for further details.
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4.5.10. Rectangle Tool
The Rectangle Tool can be used to create rectangles or squares within a drawing. To use the tool, simply select

it and then use a Click/Drag combination at the point in the drawing canvas where one of the bounding corners

of the rectangle or square should be. Then drag in any direction and release the Click action where the other

bounding corner should reside on the drawing canvas.

Using the Rectangle Tool while holding down the Shift key allows for the creation of perfect squares by

constraining the width and the height of the created object to equal values.

In the example below, a square that is 2 inches in height and width has been created:
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A rectangle can also contain text. See the Handling Text section for additional details.

4.5.11. Rounded Rectangle Tool
The Rounded Rectangle Tool can be used to create rounded rectangles or rounded squares within a drawing.

To use the tool, simply select it and use a Click/Drag combination at the point in the drawing canvas where

one of the bounding corners of the rounded rectangle or square should be. Then drag in any direction and

release the Click action where the other bounding corner should reside on the drawing canvas.
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Use the Rounded Rectangle Tool in conjunction with the Shift key to create perfectly rounded squares.

Holding down the Shift key while creating a rounded rectangle constrains the width and the height to equal

values. In the example below, a rounded square that is 2 inches in height and width has been created:

A rounded rectangle can also contain text. See Handling Text for additional details.
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The size of rounded corners can be specified prior to drawing the shape or altered any time after it has been

created. To set the corner size after creating a shape:

1

Choose the Selection Tool in the Drawing Toolbar and then highlight the desired rounded rectangle or square.

2

Click on the Adjustment Tab located under "Info" on the Sidebar.

3

You will find the Corner Size option in the bottom right portion of the Shape Specific settings section. Use the

"up" or "down" arrow buttons to change the value or click on the text entry field to key in a value.

4
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In the example below, the corner size has been changed to 1 inch.

5

When keying in a Corner Size value, another unit of measurement (i.e. pixels, points, millimeters, centimeters,

inches, feet, etc.) can be entered and will be converted into its equivelent measurement in Inches. Enter the

number value and the abbreviation for the desired unit of measurement. The number value will be converted to

Inches after hitting enter on the keyboard or selecting another item in TouchDraw.

6

Example 1: A value of 100 centimeters (100 cm) is entered for the corner size and converted to 39.37 inches.
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7

Example 2: A value of 10 millimeters (10 mm) is entered for the corner size and converted to 0.394 inches.

8

Example 3: A vaue of 25 pixels (25 px) is entered for the corner size and converted to 0.347 inches.

This measurement can also be altered before creating a shape by choosing the Selection Tool and changing the

Corner Size setting located in the Shape Specific settings on the Adjustment Tab in the Info section of the

Sidebar.

https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/Adjustment-Old.md
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The unit of measure for the corner size is the unit of measure for the drawing, thus if your unit of measure is

inches, and the corner size is set to .25, that means the corner size is 1/4 of an inch.

4.5.12. Polygon Tool
The Polygon Tool can be used to create regular polygons within a drawing. To use the tool, simply select it

and then use a Click/Drag combination at the point in the drawing canvas where the center of the polygon will

be. Then drag in any direction and release the Click action where one of the outer points of the polygon should

reside on the drawing canvas.
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The number of polygon sides can be specified prior to drawing the shape or altered any time after it has been

created. To set the number of sides after creating a shape:

1

Choose the Selection Tool in the Drawing Toolbar and then highlight the desired polygon.

2

Click on the Adjustment Tab located under "Info" on the Sidebar. The # of Sides option is located in the

bottom center portion of the Shape Specific settings section.

3

Use the "plus" or "minus" buttons to change the value or click on the text entry field to key in a value.

4
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In the example below, the value has been changed to 8.

This measurement can also be altered before creating a shape by choosing the Selection Tool and changing the

# of Sides setting located in the Shape Specific settings on the Adjustment Tab in the Info section of the

Sidebar.
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Note: A polygon can also contain text. See the Handling Text section for additional details.

4.5.13. Star Tool
The Star Tool can be used to create stars within a drawing. To select the Star Tool, perform an extended Click

on the Polygon Tool in the Drawing Toolbar to bring up the menu and then select the Star Tool in the provided

selection menu.
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Click on the point in the drawing canvas where the center of the star should be and Drag outward. Do not

release the Click action until the star consists of a desired radius, angle, and size. The radius and angle values

will increase as the size of the star increases, as shown in the images below.

The number of star points can be specified prior to drawing the shape or altered any time after it has been

created. To set the number of points:

1

Choose the Selection Tool in the Drawing Toolbar and then highlight the desired star.



Page 112

TouchDraw for Mac

2

Click on the Adjustment Tab located under "Info" on the Sidebar.

3

You will find the # of Points option in the bottom left portion of the Shape Specific settings section. Use the

"up" or "down" arrow buttons to change the value or click on the text entry field to key in a value.

4

In the example below, the value has been changed to 8.
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This measurement can also be altered before creating a shape by choosing the Selection Tool and changing the

# of Points setting located in the Shape Specific settings on the Adjustment Tab in the Info section of the

Sidebar.
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Note: A star can also contain text. See Handling Text for further details.

4.5.14. Path Tool
The Path Tool is the most powerful and complex tool available within TouchDraw. It can be used to create

complex curves and shapes with detailed control on every aspect of the shapes appearance. Paths created with

this tool are made up of many segments and three different types of line segments are possible:

• Straight Lines

• Quadratic Curves (lines with 1 control point)

• Cubic Curves (lines with 2 control points)

It's also important to understand that, like the Pen Tool, the Path Tool can be used to create both paths and

shapes. The Path selection is different from the pen selection in that a continuous line is not drawn. A separate

Click action is required to create each path segment of a line or shape and this is accomplished in one of either

two ways depending on whether or not the end result should be a path or shape.

Use a Single Click to add each line end point or a Click/Drag combination to add a line end point and a

corresponding control point in one action. To Create a Path, Double Click on the drawing canvas or choose

another drawing tool when the path is complete. To Create a Shape, click on the first (start) handle (the orange

handle with a white dot) to automatically draw a line from the current position to the start position to close the

path.

Path Tool Actions

A control point is displayed in gray when it has not been used and is referred to as a "phantom" control point.

This characteristic provides a hint to the TouchDraw application that it should function as a control point in

scenarios where the next drawn segment is a curve. A few basic actions can be used to alter the type of created

segment, curve positioning, and "phantom" control point position as a path is being created. Refer to the table
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below to learn more about each available action.

Action Description

Click/Drag A Click/Drag combination can be use to create a curve segment and allows the

"phantom" control point to be dragged to a any drawing canvas position to generate a

desired curve segment.

Single Click A Single Click adds a line or curve segment depending on the actions taken during

initial path creation. For example, clicking on two points within the drawing canvas

after selecting the path tool causes a straight line segment; however, an initial

Click/Drag combination creates a curve segment. An additional curve segment (based

on the "phantom" control point position) is created when a Single Click action is

performed in this scenario.

Double Click A Double Click action anywhere on the drawing canvas completes the path and

causes the Selection Tool to be automatically chosen as the active drawing tool.

Shift/Click A Shift/Click combination when adding the next path segment alerts TouchDraw to

ignore the "phantom" control point and creates a straight line segment.

Option/Click An Option/Click combination allows the "phantom" control point position to be set to

a desired location on the drawing canvas after a Click/Drag combination has been

performed to create a curve segment. Please refer to the Option Key page to learn

more about this application feature.

Option/Click/Drag An Option/Click/Drag combination allows the "phantom" control point to be

dragged to any point on the drawing canvas and changes a corner point back to a

smooth curve after the initial Click/Drag combination has ben completed for creating

the curve segment. Please refer to the Option Keypage to learn more about this

application feature.

4.5.14.1. Adding Straight Line
Segments
To create a Straight Line Segment, perform a single tap at the starting point and then again at the

corresponding line end point. For example, the objective of drawing a parallelogram could be accomplished
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with the Path Tool .

The following screenshots and description outlines the steps required for creating a parallelogram with this tool.

1

Select the Path Tool.

2

Click on the drawing canvas at the location where the starting point should be established for the path. An

orange handle with a white dot will appear in this specific location to signify the starting point of the path.

3

Click on the drawing canvas at the location where the second corner of the parallelogram will be. This action

draws a line between these two set points. It also creates a second handle (orange with no dot) at the point

where the first segment ends and the second one begins.
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4

Click on the drawing canvas at the location where the third corner of the parallelogram should be. As before,

the action will cause a line to be drawn from the last point to the newest point and add an orange handle to the

drawing.

5

Click on the drawing canvas at the location where the fourth corner should be. The same end results are

provided as previously discussed for this additional line segment.
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6

Perform a Click on the start point (orange handle with white dot) to automatically draw the last line to connect

the first point to the last (i.e. closing a path) The action closes the shape and exits the path tool when Sticky

Mode is not enabled. Once a path has been created and selected, a few handles will be seen in addition to the

path point handles created in the steps above. The blue handles are "bounds handles" that allow for shape

resizing with a dragging action. The red handle is a "rotation" handle, which allows for shape rotation around

it's center point.

A Double Click in the drawing view creates a path as illustrated in the screenshot below.
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4.5.14.2. Adding Quadratic Curve
Segments
A Quadratic Curve is a line segment with two end points and a control point that determines the exact curve

to be drawn. The figure below illustrates an example of a quadratic curve.

Two core gestures are used when creating path segments. A Single Click adds an end point and a Click/Drag

combination adds an end point with a corresponding control point. Since a Quadratic Curve contains two end

points and one control point, the above mentioned core gestures provide two ways to create this type of path:

• Performing a Single Click and then a Click/Drag combination.

• Performing a Click/Drag combination and then a Single Click.

For example, the Path Tool can be used to draw a shape resembling the fireplace below by combining 3 line

segments and one quadratic curve segment.
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The following instructions outline the steps for accomplishing this shape.

1

Select the Path Tool.

2

Click (but do not release) on the drawing canvas at the location where the starting point for the path should be

established. Any of the corner points could be a starting point for creating this shape; however, the upper left

corner point is the starting location for this tutorial. Next, drag the segment to the established control point

location without releasing the click action. TouchDraw will draw a lashed line from the start point to the

control point while the dragging action is performed and then show a slightly transparent circle in the control

point location upon completion.
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A control point is displayed in gray when it has not been used and is referred to as a "phantom" control point.

This characteristic provides a hint to the TouchDraw application that it should function as a control point in

scenarios where the next drawn segment is a curve. The control point is ignored when a straight line segment is

added.

3

Next, click on the drawing canvas location where the second corner of the path should be (the upper right hand

corner). This action creates a quadratic curve between the two end points, with the added control point

functioning as an indicator to TouchDraw as to how to draw the curve.
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The handles for curve control points are green. The color and look of the control points are an indicator of how

they relate to the selected shape. Refer to the handles reference page to learn about the types of handles.

4

Next, click on the drawing in the location where the third corner of the path should be. As in the previous

examples, it will have drawn a line from the last created point to the new point.

5

Next, click on the drawing in a the location where the fourth corner should be. Again, the same results are

provided as before.
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6

To close the shape, Click on the start point (the orange handle with a white dot in it). This action closes the

shape and exits the path tool (assuming sticky mode has not been enabled).
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In addition to the approach above, the same figure can be drawn performing these actions in a slightly different

order, as shown below:

1

Click in the upper left hand corner to create the first point of the curved portion of the fireplace.

2

Perform a Click/Drag combination at the location where the ending point of the curve segment should be.

Drag the "phantom" control point outward to the right and bottom until the desired curve has been created.
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Performing an Option/Click combination on any location in the drawing canvas alters the position of the

"phantom" control point to the selected location. Refer to the Path Tool section to learn more about this action.

3

Add a line to the next corner in the shape by clicking where the next end point should be located.

4

Obviously, this is not the desired result. If a "phantom" control point exists and a Click is performed on the

drawing, TouchDraw will use this control point to create a quadratic curve segment. In this case, the "phantom"

control point should be ignored and discarded. Select the Edit Menu and choose Undo or use the

Command-Zkeyboard shortcut to remove this last addition.

5
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To draw a straight line from the last end point to the new end point, use the Shift Key as the path end point is

selected. This action instructs TouchDraw to ignore the "phantom" control point and to draw a straight line.

6

Click on the next corner end point to create the bottom of the fireplace.
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7

To close the shape, Click on the start point (the orange handle with a white dot in it). This action closes the

shape and exits the path tool (assuming sticky mode has not been enabled).
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4.5.14.3. Adding Cubic Curve
Segments
A Cubic Curve is a line segment with two end points and two control points that determine the exact curve to

be drawn. The image below illustrates an example of a cubic curve.

Two core gestures are available when creating path segments. A Single Click will add just an end point and

Click/Drag combination will add an end point with a corresponding control point. Since a cubic curve contains

two end points and two control points, a cubic curve can only be added by performing a Click/Drag

combination at one point and then by performing a Click or Click/Drag combination at another point.

For example, complete the following steps to draw a path like the one displayed in the example above:

1

Select the Path Tool.

2

Click on a desired starting point on the drawing canvas and drag to another location to establish the first control
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point. The orange handle with the white dot signifies the starting point of the path. The gray circle or

"phantom" control point will turn into a control point when a curve segment is drawn.

A control point is displayed in gray when it has not been used and is referred to as a "phantom" control point.

This characteristic provides a hint to the TouchDraw application that it should function as a control point in

scenarios where the next drawn segment is a curve. The control point is ignored when a straight line segment is

added.

3

Next, click on the point within the drawing canvas where the segment end point will be and then drag the

"phantom" control point outward toward the right and bottom of the drawing canvas to create the desired curve.

A real control point will be placed exactly opposite (relative to the endpoint) from the current location of the

"phantom" control point.
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Performing an Option/Click combination on any location in the drawing canvas alters the position of the

"phantom" control point to the selected location. Refer to the Path Tool section to learn more about this action.

4

Since a path is being created rather than a shape, a Double Click must be performed on the drawing to inform

TouchDraw of the completed path.

The handles for curve control points are green. The color and look of the control points are an indicator of how

they relate to the selected shape. Refer to the handles reference page to learn about the types of handles.

The next step is to create a shape like the one shown below.
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1

Select the Path Tool.

2

Repeat the steps above to create curve on the bottom of the shape as shown below.

3

Next, draw the edge on the right hand side of the shape. If a control point exists and a Click is completed to

add a single endpoint, TouchDraw will use the "phantom" control point to create a curve. Hold the Shift Key

down while performing the Click action on the end point location to inform TouchDraw that a straight line

should be added. The following screenshot illustrate what happens when the Shift Key is not used:
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The following screenshot illustrates what happens when the Shift Key is held as the Click action is completed.

4

Next, click in the upper left hand corner where the next end point should be.
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5

Finally, to close the path and to create a shape, Click on the start point (the orange handle with a white dot).

6

To set the color, click on the fill button located on the main toolbar and choose light blue. Refer to the

Handling Colors portion of the documentation to learn more about using colors.
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4.5.15. Text Tool
The Text Tool can be used to create a text area within a drawing. To use this tool, simply select it and perform

a Click/Drag combination at the point in the drawing canvas where one of the bounding corners of the text

area should be. Then drag in any direction and release the Click action where the other bounding corner to

should be located.

After a text area has been added, the image shown below containing the default text "Double tap to edit text"

will appear.
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Double Clicking on a figure also causes the text editor to appear for entry.

Entered text is reflected in the drawing view to provide instant feedback as to how the completed text will look,

will wrap, etc...

The text figure is different from all other types of figures because it only shows text. It cannot have a border

(stroke) or be filled; however, displayed text can include a shadow.

Adding Text to a Figure

To add text to the inside of a of rectangle with a border, a circle, or a rounded rectangle:

1

Use one of the drawing tools to create a figure.
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2

Double Click on the desired figure and the editor shown above will open.

3

Enter text and then click on the figure area to close the editor.
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For more information on how to change the font, text size, text color and alignment, see the Handling Text

section.

To simplify things, the text tool also supports adding a text area by simply clicking (without dragging) in the

drawing area.

4.5.16. Option Key
When the Option Key is used, it acts as an indicator to the tools that they should behave in a different manner

than they normally would. For example, the Option Key can be used to alter the "phantom" control point

position within the Drawing Canvas for a Path or to change a corner point back to a smooth curve after a curve

segment has been created with the Path Tool.

Option/Click

An Option/Click combination allows the "phantom" control point position to be set to a desired location on the

drawing canvas after a Click/Drag combination has been performed to create a curve segment. The following

image shows the "phantom control point at the 3,3.5 position:

An Option/Click combination is completed at the 4,1 position causing the "phantom" control point to be

moved to this location on the drawing canvas. Refer to the image below:
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Option/Click/Drag

An Option/Click/Drag combination allows the "phantom" control point to be dragged to any point on the

drawing canvas and changes a corner point back to a smooth curve after the initial Click/Drag combination has

ben completed for creating the curve segment.
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4.6. Sidebar
The Sidebar can be found on the right hand side of the main application window. It is used to make attribute

changes for objects (shapes, lines, paths, and text), to manage drawing layers, and for inserting stencils into a

drawing.

Click on the name of the Sidebar Section to find out more details about what actions are possible when it is

selected.

Section Name Description

Info The Info section contains options for altering shape, line, path, and text attribute

settings.

Layers The Layers section contains options for managing multiple layers of objects residing

on the drawing canvas.
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Section Name Description

Libraries The Libraries section contains options for inserting stencils into a drawing.

The Sidebar can be hidden if desired by performing a Click on the "Sidebar" button located in the upper right

corner of the main application window.

4.6.1. Measurement Conversion
Several attributes within the Info portion of the Sidebar support measurement conversion to make working with

different scales easier. For each attribute that supports measurement conversion, you will see the abbreviation

next to the value within the field, as shown below in the Adjustment Tab and the Stroke Tab.

For example, the Position and Size attributes show Inches (in) as the current value. The Rotation attribute
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displays the Degrees (°)  symbol. In any location where the measurement unit abbreviation is shown, you can

enter a different unit of measurement and it will be converted to its equivalent value in the default unit (i.e.

points, inches, degrees...). These standard units of measurement are supported for measurement conversion

within TouchDraw:

• Kilometers

• Meters

• Yards

• Feet

• Inches

• Pixels

• Points

• Centimeters

• Millimeters

Length measurements (in, ft, yards, mm, cm, m, and km) are applicable for dimensional attributes: width,

height, length, and radius. For example, if 100 centimeters (cm) is typed into the Width attribute on the

Adjustment Tab, then it will be converted to its equivalent value of 39.37 inches (in). Simply, type in 100 cm

and then press the Enter Key on your keyboard or click in another area within TouchDraw for the conversion

to take place.
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If 10 millimeters (mm) is typed as the Line Length on the Adjustment Tab, then it will be converted to 0.394

inches.
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Dimensional attributes can also be converted based off points or pixels. For example, if you type in 50 points

(pt) for the Line Length, then it will be converted to the equivelent value in inches (in), which is 0.694.
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TouchDraw additionally supports measurement conversion for items that use the default measurement unit of

Degrees (°). The Radian unit of measurement may be entered for conversion into its degree equivalent for any

angle attributes including the line angle, radius, and rotation values. In the example below, 2 radians (rad) is

entered as the Rotation value on the Adjustment Tab and converted into 114.592°.

Measurement conversion is applicable for many Sidebar attributes including the Position, Size, Line Length,

Line Angle, Radius, and Corner Size attributes on the Adjustment Tab.
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This ability is present on the Stroke Tab for altering Stroke Size and Meter Limit values. For example, if you

enter 1 inch (in) as the Stroke Size, it will automatically be converted to the equivalent value in points, which

is 72 points.

Measurement conversion is also supported on the Text, Shadow, and Canvas Size tabs.
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4.6.2. Info
The Info portion of the Sidebar contains attribute options for shapes, lines, paths, and text. Each tab

corresponds to a set of attributes and is explained in further detail below.
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Values displayed in the Info portion of the Sidebar default to Inches or Degrees; however, alternative units of

measurement (i.e. centimeters, meters, feet, yards, etc.) or radians rather than degrees may be typed in. These

values will be automatically converted to their equivelent in Inches or Degrees.

For example, if 10 centimeters (10 cm) is entered for the Width of a selected figure, then it will be

automatically converted to Inches after pressing the Enter Key on your keyboard or selecting another item

within the application.
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If you enter 100 millimeters (mm) for the Width of a selected figure, then it will be automatically converted to

3.937 inches, as shown below:

Click on the name of a specific Attribute Tab to learn more about available setting changes.

Icon Tab Name Description

Adjustment The Adjustment tab contains options for altering attributes on

a selected figure or to make path related changes to a figure.

Stroke The Stroke tab contains options for altering the attributes of a

line (stroke).

Fill The Fill tab contains options for altering the fill attributes of a

shape or pen object.

Text The Text tab contains options for altering text attributes (size,

style, margins, color, and alignment).
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Icon Tab Name Description

Shadow The Shadow tab contains options for altering shadowing,

opacity, and blending attributes of a figure(s).

Units and Rulers The Units and Rulers tab contains options for altering the unit

of measure, the background and other drawing canvas related

settings. These options can be used to control the layout and

divisions of the ruler. Unit settings are additionally used when

drawings are exported in alternative formats such as PNG

images and PDF files.

Canvas Size The Canvas Size tab contains options for altering printing

units, page width, page height, and print margin attributes.

4.6.3. Adjustment
The Adjustment Tab contains options for gaining enhanced control of a selected figure or to make path related

changes to a figure. The tab will appear as shown below when selected in the sidebar.

The Position Header located in the upper right corner can be toggled from Position to Center. The Center

Header sets the center point of a selected shape or group of shapes. Click on the position header to toggle to

the center header options, which appear as shown below:



Page 150

TouchDraw for Mac

Values displayed in the Adjustment Tab default to Inches or Degrees; however, alternative units of

measurement (i.e. centimeters, meters, feet, yards, etc.) or radians rather than degrees may be typed in. These

values will be automatically converted to their equivelent in Inches or Degrees.

For example, if 10 centimeters (10 cm) is entered for the Width of a selected figure, then it will be converted to

Inches after pressing the Enter Key on your keyboard or selecting another item within the application.
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If 100 millimeters (mm) is entered for the Width of a selected figure, then it will be converted to 3.937 inches.

Conversion can also be used for angle measurments that use Degrees (°) as the unit of measurement. For

example, if you enter 1 radian (rad) as the Line Angle, it will be converted to 57.296°.
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Click on the corresponding Adjustment Attribute name to learn more about what the option does.

Attribute Name Description

X The X attribute can be used to set the X position of the currently selected figure to the

entered value. It functions as a nudge tool when multiple figures are selected by

moving all figures in a manner relative to the entered change.

Y The Y attribute can be used to set the Y position of the currently selected figure to the

entered value. It functions as a nudge tool when multiple figures are selected by

moving all figures in a manner relative to the entered change.

W The W (width) attribute can be used to set the width of all currently selected figures to

the entered value. The width of all figures is set to this value when multiple items are

selected. To scale the width based on the relative size within the selected figures,

group all of the figures and then resize.

H The H (height) attribute can be used to set the height of the currently selected figure to
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Attribute Name Description

the entered value. The height of all figures is set to this value when multiple items are

selected. To scale the width based on the relative size within the selected figures,

group all of the figures and then resize.

Rotation The Rotation attribute can be used to set the angle of the currently selected figure to

the chosen slider or keyboard entered value. In the instance of a multiple figure

selection, this option will set the angle of all selected figures to the entered value and

rotate them relative to their own centers. It is best to group all desired figures and then

rotate them as a group when wanting to make this change relative to the center of the

selection.

Line Length The Line Length attribute can be used to set the length of a selected line(s). A line

must be selected for this option to be enabled.

Line Angle The Line Angle attribute can be used to set the rotation angle of a selected line(s). A

line must be selected for this option to be enabled.

Radius The Radius attribute can be used to set the radius of the currently select circle to the

entered value. In the instance of multiple figure selection, this option will set the

radius of all selected figures to the entered value.

# of Points The # of Points attribute can be used to set the number of points for a star. In the

instance of multiple figure selection, this option will set the number of points of all

selected figures to the entered value.

# of Sides The # of Sides attribute can be used to set the number of sides for a polygon. In the

instance of a multiple figure selection, this option will set the number of sides of all

selected figures to the entered value.

Corner Size The Corner Size attribute can be used to set the size of the corner for a rounded

rectangle. The units for the corner size are the units of measure of the drawing. For

example, if the units of measure for the drawing were inches and the size of the corner

is set to ".25", the corner size is 1/4 of an inch.

Note: The value displayed in the text field of each attribute setting represents the value of the first selected

figure.
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4.6.4. Stroke
The Stroke Tab contains options for setting the attributes of a line (stroke). The tab will appear as shown

below when selected in the sidebar.

Values displayed in the Stroke Tab default to Points; however, alternative units of measurement may be typed

in: Pixels, Centimeters, Millimeters, Inches, etc. These values will be automatically converted to their

equivelent in Points.

For example, if 5 pixels (5 px) is entered for the Stroke Size, then it will be automatically converted to Points

after pressing the Enter Key on your keyboard or selecting another item in TouchDraw.
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Pixels and points will have the same number value after conversion when the default measurement is points;

however, you can enter points or pixels for conversion to inches in other parts of the Sidebar such as the

Adjustment Tab.

If 5 centimeters (cm) is entered as the Stroke Size, then it will be converted to 141.732 points.

If 10 millimeters (mm) is entered as the Stroke Size, then it will be converted to 28.346 points.
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Click on the corresponding Stroke Attribute name to learn more about what the option does.

Attribute Name Description

Stroke The Stroke attribute is an "On/Off" toggle button for setting the visibility of strokes

or lines of a figure(s). The border or line of a figure is not drawn when this option is

disabled.

Start The Start attribute can be used to set the style of the beginning portion of a created

line.

Line The Line attribute can be used to set the style of the line being created.

End The End attribute can be used to set the style of the ending portion of a created line.

Start Scale The Start Scale attribute can be used to scale the start of a line independently from

the stroke size.

Size The Size attribute can be used to set the width of a stroke in pixels.

End Scale The End Scale attribute can be used to scale the end of a line independently from the

stroke size.

Line Cap The Line Cap attribute can be used to set the cap of a line to Butt, Rounded, or

Square.

Line Join The Line Join attribute can be used to set the join of a line to Mitered, Rounded, or

Beveled.

Location The Location attribute can be used to set the location where the line will join with

another object.

Miter Limit The Miter Limit attribute can be used to set the angle of connected line segments

where they join. The join will be more jagged or sharp depending on the entered or
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Attribute Name Description

selected value. Miter limits are relative to stroke size and become increasingly

noticeable for line segments with increased thickness.

Color The Color attribute can be used to specify the color of a stroke. Refer to the Handling

Colors section to learn more about color attribute changes.

4.6.5. Fill
The Fill Tab contains options for setting the fill attributes of all objects with the exception of the Line and

Connection tools. The tab will appear as shown below when selected in the Sidebar.

Click on the corresponding Fill Attribute name to learn more about what the option does.

Attribute Name Description

Fill The Fillattribute is an "On/Off" button for toggling the visibility of the fill of a

figure(s). Shapes have no fill when this option is disabled.

Fill Style The Fill Style attributes are located in a drop down menu underneath the Fill button.

This option sets the type of fill pattern used for a figure(s).   - Solid - Fills a figure

with solid color.  - Linear Gradient - Transitions from the specified start color to the

specified end color at a designated angle.  - Radial Gradient - A radial gradient

transitions from the specified start color to the specified end color by starting from the
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Attribute Name Description

center of the figure and then moving outward in a circular manner.

Color The Color attribute is used to choose the fill color for a figure(s). See the Handling

Colors section for additional details.

4.6.6. Text
The Text Tab contains options for setting the text attributes of a figure(s). The tab will appear as shown below

when selected in the Sidebar.

Values displayed in the Text Tab default to Points; however, alternative units of measurement may be typed in

(i.e. pixels, millimeters, centimeters, inches, feet, etc.). These values will be automatically converted to their

equivelent in Points after pressing the Enter Key on your keyboard or clicking in another area of TouchDraw.

If you enter 5 pixels (px) as the Font Size, then it will be converted to 5 points (pt).
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Pixels and points will have the same number value after conversion when the default measurement is points;

however, you can enter points or pixels for conversion to inches in other parts of the Sidebar such as the

Adjustment Tab.

For example, if 1 centimeter (1 cm) is entered for the Font Size, then it will be automatically converted to

Points after pressing the Enter Key on your keyboard or selecting another item in TouchDraw.

If 5 millimeters (5 mm) is entered as the Font Size, then it will be converted to 14.173 points.
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Click on the corresponding Text Attribute name to learn more about what the option does.

Attribute Name Description

Font Family The Font Family attribute is used to choose a set of fonts with the same typeface, but

varying qualities such as size and weight.

Font Size The Font Size attribute sets the height of characters in a selected font family.

Font Style The Font Style attribute sets the style or angle of text within a figure(s).

Text Margin The Text Margin attribute set the margins for text within a figure(s). The

measurement spans from the text box edge to the actual text.

Alignment The Alignment attribute set the vertical and horizontal text alignment modes for text

within a figure(s).

Text Color The Text Color attribute sets the color of text appearing in a figure(s).

This button opens the standard Fonts selection window for the Mac.

Note: Refer to the Handling Text section of this documentation to learn more about attribute changes or editing

text for figures.
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4.6.7. Shadow
The Shadow Tab contains options for altering shadowing, opacity, and blending attributes of a figure(s). The

tab will appear as shown below when selected in the Sidebar.

Values displayed in the Shadow Tab default to Points; however, alternative units of measurement may be

typed in (i.e. pixels, millimeters, centimeters, inches, feet, etc.). These values will be automatically converted

to their equivelent in Points after pressing the Enter Key on your keyboard or clicking on another item within

TouchDraw.

For example, if you enter 5 pixels (px) as the X Offset, then it will be converted to 5 points (pt).
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Pixels and points have the same number value after conversion when the default measurement is points;

however, you can enter points or pixels for conversion to inches in other parts of the Sidebar such as the

Adjustment Tab.

If 1 centimeter (1 cm) is entered for the X Offset, then it will be automatically converted to Points after

pressing on the Enter Key or selecting another item in TouchDraw.
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If 5 millimeters (5 mm) is entered as the X Offset, then the value will be converted to 14.173 points.

Click on the corresponding Shadow Attribute name to learn more about what the option does.

Attribute Name Description

Shadow The Shadow attribute is used to toggle the shadow visibility of a figure(s). A shadow

is not drawn if this option is disabled.
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Attribute Name Description

X Offset The X Offset attribute sets the offset of the shadow in the X axis.

Y Offset The Y Offset attribute sets the offset of the shadow in the Y axis.

Blur The Blur attribute sets the amount of blur applied to the shadow.

Shadow Color The Shadow Color attribute sets the shadow color for a figure(s). Refer to the

Handling Colors section of this documentation to learn more about color attribute

alterations.

Opacity The Opacity attribute can be used to alter the opaqueness (opposite of transparency)

of a selected color.

Blending Mode The Blending Mode attribute sets the style of blend applied to a figure(s).

4.6.8. Units and Rulers Tab
The Units and Rulers Tab contains options for altering the unit of measure, background, and additional

drawing canvas related settings. These options are used to control the layout and divisions of the ruler. Unit

settings are additionally used when drawings are exported in alternative formats such as a PDF file. The tab

will appear as shown below when selected in the Sidebar.

Click on the corresponding Units and Rulers Attribute name to learn more about what the option does.
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Attribute Name Description

Drawing Units The Drawing Units attribute sets the form of unit measurement on the drawing

canvas (inches, pixels, etc.).

Major Gridline The Major Gridline attribute sets the interval (in the current unit of measure) that a

major gridline will be drawn. For example, if the unit of measure is centimeters and

the major gridline is set to 2, it will draw the major gridline every two centimeters.

Subdivisions The Subdivisions attribute sets the number of subdivisions (minor gridlines) that are

drawn between the Major Gridlines. For example, if the unit of measure is centimeters

and the major gridline is set to 2, and the subdivisions is set to 4, it will draw a minor

gridline ever 1/2 cm (5mm)

Background Color The Background Color attribute sets the background color of the drawing. Refer to

the Handling Colors section in this documentation to learn more about color selection.

Transparent The Transparent attribute toggles whether or not the background of the drawing is

transparent. For example, if you want to export your drawing as a transparent PNG,

then you'd want this option selected.

Limit Stroke

Scaling

The Limit Stroke Scaling attribute is used to configure TouchDraw so that lines

having a thickness smaller than 1 (based on the current zoom level) are drawn at 1

pixel. This setting makes certain these lines are always visible.

Note: A change from one unit of measurement to another does not numerically change the size of figures. For

example, changing from inches to centimeters where the objects were previously 1 inch wide causes the objects

to become 1 centimeter wide. You can use the "Scale By..." option to scale the drawing after the conversion.

4.6.9. Canvas Size Tab
The Canvas Size Tab contains options for altering the print margins of a drawing. The tab will appear as

shown below when selected in the Sidebar.
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The Scale header located in the bottom right corner can be toggled from Scale to Points per Unit, as shown

below:

Values displayed in the Canvas Size Tab default to Inches; however, alternative units of measurement (i.e.

centimeters, millimeters, and pixels) can be chosen as the Canvas Unit.
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Regardless of the chosen Canvas Unit, alternative units of measurement (i.e. millimeters, centimeters, meters,

kilometers, yards, feet, etc.) can be entered into a field and will be automatically converted to the equivelent

value for the current unit selection.

For example, if 1 foot (1 ft) is entered for the Top Margin when the Canvas Unit is set to Pixels, then it will be

automatically converted to Pixels after pressing the Enter Key on your keyboard or selecting another item in

TouchDraw.
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Click on the corresponding Canvas Size Attribute name to learn more about what the option does.

Attribute Name Description

Canvas Units The Canvas Units attribute sets the unit of measurement used to define the

attributes on this page.

Canvas Width The Canvas Width attribute sets the width of the page in printing units.

Canvas Height The Canvas Height attribute sets the height of the page in printing units.

Top Margin   Bottom

Margin   Left Margin

Right Margin

The Top Margin, Bottom Margin, Left Margin and Right Margin

attributes can be used to set the page margins in user specified printing units.

Scale The Scale attribute can be used to change the scale of the drawing to the size

of the printed drawing.

Points per Unit The Points per Unit attribute can be used to configure the number of points

on the screen that are equal to the units of the printed drawing.
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Note: Refer to Printing a Drawing to learn more about setting the print options for drawings.

4.6.9.1. Drawing Scale
An option to change the Scale of the printed drawing is provided on the Canvas Size Tab of the Sidebar. This

option allows a value other than the default scale of 1 inch to be applied when printing the drawing. The default

value is Inches (in); however, another form of measurement may be used such as Feet (ft) or Centimeters

(cm) to control the scale of the drawing to the size of the printed drawing.

For example, if the current scale value is 1 inch = 1 inch (as shown below), then each inch within the drawing

will be precisely 1 inch in actual size when printed.

This is the default drawing scale setting and the Drawing Canvas will appear as shown below:

To change this value, click on the text field and enter a new number value along with the desired unit of

measurement. Then click in another area of the application or press the Enter Key on your keyboard. The
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value will automatically be converted to its equivalent in Inches (in) . In the example below, 1 centimeter (cm) 

is entered as the Drawing Scale  value.

You may also use the up and down arrows to alter the number value without changing the unit of measurement.

Example 1:

In the example below the Drawing Scale has been changed to 2 in = 1 in. This means that each inch displayed

within the Drawing Canvas will be two inches in width when the drawing is printed.



Page 171

TouchDraw for Mac

The Drawing Canvas will be altered to reflect the change, as shown below:

If a square 1 inch in height and 1 inch wide is drawn, then it will appear to be 1 in by 1 in within the Drawing

Canvas. However, when it is printed, it will actually be 2 by 2 inches. You can see this by using a ruler to

measure each side of a figure within the printed drawing. The image below shows what the figure will look like

within TouchDraw and then what it will look like when printed.



Page 172

TouchDraw for Mac

Example 2:

Drawings may be scaled by a different unit of measurement such as millimeters, centimeters, or feet. If the

printed drawing neeeds to be scaled by Feet (ft), then a number value and the abbreviation for feet (ft) may be

entered in this field. A drawing that will be scaled by one foot per inch may be configured as shown below.
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Please note that the value does not have to be 1, it is used in this example for simplicity. The value can be

whatever is needed to meet your specific scaling needs for a printed drawing.

The measurement will automatically be converted to the equivelent of 1 foot in inches or 12 inches. This means

that 1 inch within the printed drawing will represent 1 foot. This makes it easier to determine measurements

from the printed page when needed.

The Drawing Canvas will appear differently after the scale has been changed from 1 in to 1 ft (12 in) on the

Canvas Size Tab, as shown below:
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A good example of this would be a simple floorplan for a space that has a total area of 10 feet by 6 feet. Please

note that this has been zoomed out to show the entire drawing. The actual printed drawing will be represented

as 1 in equaling 1 foot.

Example 3:

The same standard units of measurement listed on the Measurement Conversion page are applicable for scaling

a drawing. To provide another example, if 1 millimeter (mm) is entered then it will be converted to 0.039

inches (the equivelent in inches of 1 millimeter).
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The Drawing Canvas will be altered to reflect the change. Now 0.039 inches (1 cm) in a drawing will be 1 inch

in the printed drawing.
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4.6.9.2. Points per Unit
TouchDraw also allows the number of Points per Unit within a drawing to be changed. It is hepful for sizing

attributes such as Font Size or Stroke Width, which default to the points measurement. In TouchDraw, the

Points per Unit (PPU) value automatically defaults to 72, which matches the standard unit measurement of 72

dots per unit used by a printer (or PDF). The default value of 72 is equivelent to 1 drawing inch = 1 printed

inch.

Points per Unit can be used to change this value so that the drawing units match the desired units for the

printed drawing. To access this setting, click on Scale located in the lower portion of the Canvas Size Tab in

the Info section of the Sidebar.

The Points per Unit can be altered by clicking directly on the text field and typing a value or using the "Up"

and "Down" buttons to increase or decrease the value by 1.
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If the default setting of 72 points is used for Points per Unit and a line has a Stroke Width of 1, then the line

would be 1/72 of an inch wide in the printed drawing. If the Font Size is set to 72, then the font size is

precisely 1 inch on the printed drawing.

Example 1

If Points per Unit is changed to 144 points, then each inch (72 points) in the drawing equals 144 points in the

printed drawing. The Drawing Canvas will be altered so it matches the new Points per Unit value.
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For example if a square that is 1 inch by 1 inch with a Stroke Size of 12 is drawn, it will actually be 144 points

squared or 2 inches by 2 inches in the printed drawing.

A Font Size of 72 would actually equal 2 inches or 144 points in the printed drawing.
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The printed text would appear as shown below:

Example 2

If Points per Unit is changed to 36 points (1/2 inch) and the Stroke Width is 36, then the width of a line on

the printed drawing would equal half of an inch or 36 points.
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The line would appear as shown below in the Drawing Canvas and be 1/2 inches wide (36 points) in the printed

drawing.
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4.7. Layers
Layers provide the capability to incorporate more than one level of objects into a drawing. Each added layer

builds on top of the previous created layer to create a multidimensional drawing. They are managed and

controlled through the Layers Portion of the Sidebar located on the right hand side of the main application

window. This section appears as shown below.

Click on the corresponding Layer Function name to learn more about what the option does.

Icon Function Name Description

Add The Add function adds a layer to the bottom of the layer list.

Delete The Delete function removes the top layer from the layer list.

Move Down The Move Down function moves a selected layer down one

level in the layer list.

Move Up The Move Up function moves a selected layer up one level in

the layer list.

Layer Settings

Menu

The Layers Settings Menu contains options for adding,

deleting, re-ordering, and merging layers.

Visibility The Visibility option is an "On/Off" toggle button for setting

the visibility of each created layer. It appears to the right of

each layer name in the list as an "eye" icon and indicates the

visibility of the layer. To hide (or show) a layer, simply Click

on the eye icon of the layer to be toggled. An eye icon with a

line through it indicates that a particular layer is not visible,

whereas an eye with no line indicates a layer is visible.



Page 182

TouchDraw for Mac

Icon Function Name Description

Lock The Lock option is an "On/Off" toggle button for locking or

unlocking a layer. It is located to the right of the visibility icon

and indicates whether or not a layer is locked. To lock (or

unlock) a layer, simply Click on the lock icon of the layer to be

toggled. A closed lock icon indicates that a layer is locked and

an open lock icon indicates a layer is unlocked.

Note: Layers located at the top of the Layers Sidebar list are drawn above the layers below it.

4.7.1. Layers Settings Menu
The Layers Settings drop down menu is used to perform specific actions on a created layer or set of layers. It

is located in the upper right hand corner of the Layers section in the Sidebar as shown in the image below.

Perform a single Click on this menu to acces additional options.
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Click on the corresponding Layers Setting Menu name to learn more about what the option does.

Option Name Description

Add Layer The Add Layer option adds a layer above existing layers. A new layer appears at the

top of the sidebar list.

Duplicate Layer The Duplicate Layer option creates an exact copy of a selected layer and adds it to

the top of the sidebar list.

Move Layer Up The Move Layer Up option moves a selected layer up one level in the sidebar list.

Move Layer Down The Move Layer Down option moves a selected layer down one level in the sidebar

list.

Merge Layer Up The Merge Layer Up option merges the selected layer with the one residing above it

in the sidebar list.

Merge Layer Down The Merge Layer Down option merges the selected layer with the one residing below

it in the sidebar list.

Merge All Layers The Merge All Layers option merges all existing layers into a single layer.

Delete Layer The Delete Layer option permanently removes a selected layer from the sidebar list.

Show All Layers The Show All Layers option makes all layers within the currently open drawing

visible.

Hide All Layers The Hide All Layers option hides all layers within the currently open drawing.

Lock All Layers The Lock All Layers option locks all layers within the currently open drawing.

Unlock All Layers The Unlock All Layers option unlocks all layers within the currently open drawing.

Note: The Move and Merge options are enabled when two or more layers exist in the sidebar list.

Corresponding up and down options for these categories require a layer to be available above or below the

selected layer to appear as a menu selection.

4.7.2. Adding a Layer
A Layer can be added in one of two ways:
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1

Perform a Click action to select the desired layer and then click on the Layers Settings Menu menu to choose

the Add Layer option.

2

Click to select the desired layer and then click on the Add Button located at the top left of the Layers Sidebar

section.
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4.7.3. Renaming a Layer
The selected layer must be in "edit" mode to be named or renamed. This is accomplished by performing a

Double Click on the desired layer. The layer selected in the Sidebar list will look as shown below once it is in

edit mode.

A layer is in text editing mode when it is highlighted in blue and has or can have a cursor placed in the name

section of a layer. Any desired name can be entered for a layer.
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4.7.4. Duplicating a Layer
A Layer can be duplicated to create another layer with the same objects and properties. Follow the steps below

to duplicate a selected layer:

1

Perform a Click action to select a layer within the Layers List.

2

Click on the Layers Settings Menu menu and then choose Duplicate Layer.

3

The duplicated layer will appear above the original and can be renamed, re-ordered, merged, or deleted.
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4.7.5. Re-ordering Layers
Perform a Click action to select the desired layer and then Click on the Layers Settings Menu menu to choose

from available re-ordering functions. The Layers Settings menu will appear as shown below.

A Layer can be moved up or down in the Sidebar list and this action will alter the layering positions in the

drawing canvas. Layers can be re-ordered by using a Click/Drag combination to another location or by using

one of the methods shown below.

Use the Move Layer Up menu option to move the selected layer up by one in the Layers List.
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Use the Move Layer Down option to move the selected layer down by one in the Layers List.
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The Move Layer Up/Down Buttons may also be used to perform the same action. Simply select the desired

layer and then click on the appropriate button to move the layer to a different ordering position within the

Layers List.

The Move Layer Up option will only be enabled when a layer resides above the selected one in the Layers

List. The Move Layer Down menu option will only be enabled when a layer resides below the selected one in

the Layers List.

4.7.6. Merging Layers
Perform a Click action to select the desired layer and then Click on the Layers Settings Menu menu to choose

from available merging functions. The Layers Settings menu will appear as shown below.
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A Layer can be merged up or down in the Sidebar list and this action will combine the drawing canvas

contents and properties of the selected layer with the one above or below it depending on the made selection.

An additional option is available for merging all layers in a drawing.

Use the Merge Layer Up menu option to merge the selected layer with the one residing above it in the Layers

List.
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Use the Merge Layer Down option to merge the selected layer with the one residing below it in the Layers

List.

The Merge All Layers function combines every layer of a drawing showing in the Layers list.
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The Merge Layer Up and Merge Layer Down menu choices are only enabled when a layer resides above or

below the selected one. More than one layer must be present in the Layer list for the Merge All Layers menu

choice to be enabled.

4.7.7. Deleting a Layer
A Layer can be deleted in two ways:

1

Perform a Click action to select the desired layer and then click on the Layers Settings Menu menu to choose

the Delete Layer option.
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2

Perform a Click action to select the desired layer and then click on the Delete Button located at the top left of

the Layers Sidebar section.

4.7.8. Layer Visibility



Page 194

TouchDraw for Mac

The Visibility option is an "On/Off" toggle button for setting the visibility of each created layer. It appears to

the right of each layer name in the list as an "eye" icon and indicates the visibility of the layer. To hide (or

show) a layer, simply Click on the eye icon of the layer to be toggled. An eye icon with a line through it

indicates that a particular layer is not visible, whereas an eye with no line indicates a layer is visible.

The Layers Settings Menu provides additional options for changing the visibility of all layers residing within a

drawing. To access these options, click on the Layers Settings Menu in the Sidebar and then choose Show All

Layers or Hide All Layers from the provided drop down menu.
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All layers will be made visibile or hidden within the currently open drawing depending on the chosen option.

The "eye" icon serves as a visual indicator and will appear differently after a selection has been made as shown

in the screenshots below.

4.7.9. Locking Layers
The Lock option is an "On/Off" toggle button for locking or unlocking a layer. It is located to the right of the

visibility icon and indicates whether or not a layer is locked. To lock (or unlock) a layer, simply Click on the

lock icon of the layer to be toggled. A closed lock icon indicates that the layer is locked and an open lock icon

indicates a layer is unlocked.
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The Layers Settings Menu provides additional options for locking or unlocking all layers residing within a

drawing. To access these options, click on the Layers Settings Menu in the Sidebar and then choose Lock All

Layers or Unlock All Layers from the provided drop down menu.
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All layers will be locked or unlocked within the currently open drawing depending on the chosen option. The

"lock" icon serves as a visual indicator and will appear differently after a selection has been made as shown in

the screenshots below.
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4.8. Libraries
Libraries are used to add and manage stencils stored within the application and for adding these objects to a

drawing. They are managed and controlled through the Libraries Portion of the Sidebar located on the right

hand side of the main application window. This section appears as shown below.

A search option is provided at the bottom of this sidebar section to find a specific stencil within a selected

library.

Click on the corresponding Libraries Menu name to learn more about what the option does.

Icon Function Name Description

Library Selection

Menu

The Library Selection Menu can be used to select a specific

library for stencil additions, library modifications, or drawing

stencil insertion.

Libraries Settings

Menu

The Libraries Settings Menu contains options for adding or

deleting stencils and library manipulation.

4.8.1. Libraries Settings Menu
The Libraries Settings drop down menu is used to create, alter, or delete librairies. It is located in the upper
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right hand corner of the Libraries  section in the Sidebar  as shown in the image below.

Perform a single Click on this menu to acces additional options.

Click on the corresponding Libraries Setting Menu name to learn more about what the option does.

Option Name Description

Add Selection To

Library

The Add Selection To Library option inserts a new stencil into the selected

library.

New Library The New Library option creates a new library in TouchDraw.

Rename Library... The Rename Library... option assigns a new name to a selected library.

Delete Library The Delete Library option removes a library from TouchDraw

Import Library... The Import Library... option imports a library into TouchDraw from another

location.
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Option Name Description

Export Library... The Export Library... option exports a library from TouchDraw to a chosen

directory.

Delete Stencil From

Library

The Delete Stencil From Library option removes a stencil from the selected

library.

4.8.2. Library Functions
The Library Functions can be accessed through the Libraries Settings Menu and provide the ability to add,

delete, import, export and rename libraries.
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4.8.3. Adding a Library
A Library is added by clicking on the Libraries Settings Menu and then choosing the New Library option.
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Note: An Untitled Library can be renamed with the Rename Library... option.

4.8.4. Renaming a Library
A Library is renamed by selecting a desired library and then choosing the Rename Library... option in the

Libraries Settings Menu. Follow the steps below to rename a library:

1

Use the Library Selection Menu to select the library to be renamed.
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2

Click on the Libraries Settings Menu and choose Rename Library...
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3

Enter a new name in the Rename Library prompt and click on Rename.

4

The entered name will appear in the Library Selection Menu.

    Note: A rename is not possible if the entered name has already been used.
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4.8.5. Deleting a Library
A Library is deleted by selecting a desired library and then choosing the Delete Library option in the

Libraries Settings Menu. Follow the steps below to delete a library:

1

Use the Library Selection Menu to select the library to be deleted.

2

Click on the Libraries Settings Menu and choose Delete Library.
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3

The Confirm Deletion prompt will appear. Choose Confirm to delete the library or Cancel to back out of this

process.

4.8.6. Importing a Library
A library can be imported into TouchDraw for use during drawing creation and manipulation. Follow the steps

below to Import a Library:

1
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Click on the Library Settings Menu and choose Import Library....

2

Browse to the appropriate file directory and click Open.
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3

A confirmation popup window will appear if the library is imported successfully. Click Okay to close the

confirmation window.

4.8.7. Exporting a Library
An existing library can be exported as a .t2l file for use within another application or to be imported for a later

drawing. Follow the steps below to Export a Library:

1

Click on the Library Settings Menu and choose Export Library...
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2

Enter a different name (i.e.name.t2l) for the library if desired and choose a save directory. Then click on Save

to finish exporting the TouchDraw library to the chosen directory.

    Note: A library file can be renamed before completing the exporting process by clicking in Save As and

entering a desired name prior to clicking on the Save button.

4.8.8. Stencil Functions
The Stencil Functions can be accessed through the Libraries Settings Menu and provide the ability to add,
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delete, and rename stencils.

4.8.8.1. Adding a Stencil
A Stencil is added by choosing the Add Selection To Library option in the Libraries Settings Menu. To add a

new stencil into a library:

1

First, draw the figure within the drawing editor.
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2

Select the figure (or figures) being made into a stencil.

3

Open the Library Selection Menu and navigate to the desired insertion library.
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4

Select the Libraries Settings Menu and choose the Add Selection To Library option.

5

The stencil will appear in the selected library as shown below and can renamed after the addition is complete.
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Note: To learn how to change the name of an added stencil, refer to the Renaming a Stencil section of the

documentation.

4.8.8.2. Renaming a Stencil
The selected stencil must be in "edit" mode to be renamed. This is accomplished by performing a Double Click

on the desired stencil. The stencil selected in the sidebar list will look as shown below once it is in edit mode.

A stencil is in text editing mode when it is highlighted in blue and has or can have a cursor placed in the name

section. Any desired name can be entered for a stencil.

4.8.8.3. Re-ordering Stencils
To re-order stencils within a library:
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1

Select the corresponding library in the Library Selection Menu.

2

Click on the desired stencil and perform a Drag to move it to a new location. In the example below, the Kite

stencil has been moved above the Blue Triangle stencil.
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4.8.8.4. Deleting a Stencil
A Stencil is deleted from a library by selecting the desired stencil and then choosing the Delete Stencil From

Library option in the Libraries Settings Menu. Follow the steps below to delete a stencil:

1

Use the Library Selection Menu to select the library where the stencil is saved.
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2

Perform a Click on the stencil to be deleted.

3

Click on the Libraries Settings Menu and choose Delete Stencil From Library.
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4

The stencil will automatically be removed from the library, as shown below:

4.8.8.5. Inserting a Stencil into a
Drawing
To insert a stencil into a drawing:

1

Select the appropriate library in the Library Selection Menu.
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2

Perform a Click/Drag combination from a selected stencil to the Drawing Canvas.
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4.9. Bottom Bar
At the bottom of the drawing window, to the left of the horizontal scroll bars, is a small Bottom Bar offering

quick access to a few common settings.

Control Name Description

Zoom Popup The Zoom Popup allows you to quickly access common zoom levels from a popup

menu.

Handle Settings The Handle Settings allows you to quickly access and control which handles are

visible within the current editing session.

4.9.1. Handle Settings
The Handle Settings Menu is used to configure which handles are visible for a selected figure.
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The menu is broken up into three sections: Primary Handles, Secondary Handles and Miscellaneous.

Primary Handles

Handle Name Description

Bounds The Bounds option toggles the visibility of the boundaries of path handles.

Boundaries can be shown on handles for all figures, strokes, and paths or for

everything but paths.

Path Segments The Path Segments option toggles the visibility of segment handles for paths.

Path Control Points The Path Control Points option toggles the visibility of path control points between

always showing, only showing active points, or showing none at all.

Secondary Handles

Handle Name Description

Rotation The Rotation option toggles the visibility of the rotation handle on the drawing

canvas.

Gradient Locations The Gradient Locations option toggles the visibility of the gradient location handle

within a figure(s) on the drawing canvas.

Center of Rotation Enabling the the Center of Rotation option allows the point at which a figure or

shape is rotated around to be edited.

Miscellaneous

Handle Name Description

Easy Drag Mode The Easy Drag Mode option hides all handles to prevent a selected figure from being

altered as it is moved. The option can be applied to single figure by selecting the

object prior to choosing this setting or set when no figures are selected to apply the

setting to every item on the drawing canvas.
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4.9.2. Zoom Popup
The Zoom Popup supplies quick access to common zoom levels from a popup menu, as shown below:

To change the zoom percentage, click on the zoom popup menu located on the bottom bar of the main

application window and choose the desired zoom level.

The currently selected zoom level will have a checkmark located next to the value.
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4.10. Contextual Menu
The Contextual Menu provides quick access to various editing functions made available through the

TouchDraw application. Hold the Shift Key and Click (right click) anywhere on the drawing canvas or on a

selected figure(s) to bring up this menu. Choices may or may not be enabled depending on the selected figure

where right clicking occurs.

Click on the name of the menu item to find out more details about what action occurs when it is selected.

Option Name Description

Cut The Cut menu item removes the currently selected item from the active drawing and

places it in the clipboard.

Copy The Copy menu item places a copy of the currently selected item into the clipboard.

Paste The Paste menu item adds the most current item residing in the clipboard to the active

drawing.

Paste Special

Submenu

The Paste Special submenu contains special options related to pasting the contents of

the clipboard into the active drawing.

Duplicate The Duplicate menu item creates a copy of a selected item in the active drawing.

Duplicate in Place The Duplicate in Place menu item creates a copy of a selected item and places it in

the same location as the original.
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Option Name Description

Select All The Select All menu item selects all items residing in the currently active drawing.

Deselect All The Deselect All menu item deselects all items residing in the currently active

drawing.

Arrange Submenu The Arrange Submenu contains options for grouping, locking, and ordering figures

within a drawing.

Align Submenu The Align Submenu contains options for aligning selected figures within a drawing.

Canvas Submenu The Canvas Submenu contains an option for resetting the point of origin within a

drawing.

Distribute

Submenu

The Distribute Submenu contains options for distributing the selected figures within

a drawing.

Paths Submenu The Paths Submenu contains options for altering handles and segments of a path.

Move to Layer

Submenu

The Move To Layer Submenu contains options for moving selected figure(s) to a

new or existing layer.

Style as

Dimension Line

The Style as Dimension Line option adds arrowheads and a  variable to a selected

line(s). At least one line must be selected in the drawing canvas for this option to

appear.

4.10.1. Arrange Submenu
Use the Arrange Submenu to access actions for grouping, locking, and ordering selected figures within a

drawing. When this submenu is selected, the options shown below will appear.
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Click on the name of the menu item to to find out more details about what action occurs when it is selected.

Menu Item Description

Group The Group menu item allows currently selected shapes on the drawing canvas to be

manipulated and treated as a single figure. This menu item is enabled when two or

more groupable figures are selected in the drawing canvas. Shapes residing on the

drawing canvas can be manipulated**.**

Ungroup The Ungroup menu item removes the grouping attribute for selected shapes to allow

for individual manipulation. This menu item is enabled when one or more grouped

figures are selected in the drawing canvas.

Lock The Lock menu item prevents a selected figure(s) or group of figures from being

moved or resized. This menu item is enabled when one or more unlocked (and

lockable) figures are selected in the drawing canvas.

Unlock The Unlock menu item removes a previously instated lock on a figure(s) or group of

figures to allow for moving and resizing.This menu item is enabled when one or more

locked figures are selected in the drawing canvas.

Bring to Front The Bring to Front menu item moves a currently selected figure(s) to the front of all

figures residing in the same layer. This menu item is enabled when one ore more

figures are selected in the drawing canvas.

Bring Forward The Bring Forward menu item moves a currently selected figure(s) one step closer to
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Menu Item Description

the top of the stack within the layer  they reside in. This menu item is enabled when

one ore more figures are selected in the drawing canvas.

Send Backward The Send Backward menu item moves a currently selected figure(s) one step closer

to the bottom of a stack within their residing layer. This menu item is enabled when

one ore more figures are selected in the drawing canvas.

Send to Back The Send to Back menu item moves a currently selected figure(s) behind all other

figures residing within the same layer. This menu item is enabled when one ore more

figures are selected in the drawing canvas.

4.10.2. Canvas Submenu
Use the Canvas Submenu to reset the point of origin within a drawing. When this submenu is selected, the

submenu will appear as shown below.

Click on the name of the menu item to to find out more details about what action occurs when it is selected.

Menu Item Description

Set Drawing Origin The Set Drawing Origin menu item may be used to reset the point of origin with a

drawing.
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4.10.3. Paths Submenu
Use the Paths Submenu to alter selected handles and segments within a path figure on the drawing canvas.

When this menu is selected, the options shown below will appear.

Click on the name of the menu item to find out more details about what action occurs when it is selected.

Menu Item Description

Delete Handle The Delete Handle menu item deletes the currently selected handle from a path

segment.

Split at Handle The Split at Handle menu item divides a path into two separate sections at the chosen

handle and allows each section to be altered as an individual figure.

Insert Handle The Insert Handle menu item inserts a handle into the currently selected path

segment.

Delete Segment The Delete Segment menu item deletes the currently selected segment from a path.

Segment to Line The Segment To Line menu item can be used to convert a quadratic or cubic path

segment into a line segment.

Segment to Quad The Segment To Quad menu item can be used to convert a line or cubic path
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Menu Item Description

segment into a quadratic segment.

Segment to Cubic The Segment To Cubic menu item can be used to convert a line or quadratic path

segment into a cubic segment.

4.10.4. Move to Layer Submenu
The Move To Layer Submenu contains options for moving selected figure(s) to a new or existing layer. It is

accessed by right clicking anywhere in the Drawing Canvas.

Click on the corresponding Move to Layer Submenu item name to learn more about what the option does.

Option Name Description

Existing Layers Existing Layers within the drawing are shown in the top portion of the submenu.

Choose a layer from this menu to move a selected figure(s) to a specified layer within

the active drawing.

New Layers The New Layers option creates a new layer and places the selected figure(s) in that

layer.
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5. File Management
TouchDraw provides numerous File Management options to make working with new, saved, or imported

drawings easier. The following pages explain how to perform basic file operations.
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5.1. Creating a New Drawing
Click on the File Menu and select New to create a new drawing from the main application window.

A blank Drawing Canvas will appear as shown below.
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5.2. Opening a Drawing
Click on the File Menu and select Open to open an existing drawing in the main application window for

editing.

Select the file location in the Open Window and then click on Open located in the bottom right corner of the

screen.

The selected file will appear in the main application window as part of the Drawing Canvas.
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Note: A recently created or edited file can be opened by clicking the File Menu and choosing Open Recent.
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5.3. Importing a Drawing
TouchDraw supports the ability to open alternative file types besides native documents. The list of supported

file types are:

• TouchDraw Native (.t2d)

• Scalable Vector Graphics (.svg)

• Visio XML Drawing (*.vdx)

• Portable Network Graphic (.png)

• JPEG (.jpg, .jpeg)

• BMP (.bmp)

• TIFF (.tif, .tiff)

• Enhanced Metafile (.emf)

• Windows Metafile (.wmf)

Importing Non-Native File Formats

Follow the steps below to complete a file import:

1

Click on the File Menu and select Open.

2

Navigate to the directory containing the file to be imported.
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3

Click on the appropriate file name. In this example, Connected Graph.svg in the Drawings Folder is selected.

4

Click on the Open Button.
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5

The selected file will automatically be opened in TouchDraw as a new drawing. In this example, the Connected

Graph.svg file has been imported.
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    Note: Only files with the appropriate extension will be presented as a selectable item in the shown directory

list.
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5.4. Saving a Drawing
TouchDraw offers two methods for Saving a Drawing (Save and Save As...). Follow the steps below if saving

a drawing for the first time.

1

Click on the File Menu and choose Save.

2

Enter a file name, choose a save location, and click Save.
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The Save As window will not appear if the Save option is chosen and the file has previously been saved.

Save

An existing file can be saved at any time by selecting the Save option under the File Menu. The drawing will

automatically be saved if it has been previously saved regardless of any made changes.

Save As

An existing file can be saved under another name by using the Save As... option under the File Menu. Enter a

new file name in the Save As window, select the save location, and then click on Save.
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If a file with the same name already exists, TouchDraw shows a warning message asking if the current file

should be replaced. Click Replace to overwrite the existing file or Cancel to exit the operation.

Duplicate

A copy of an existing file can be created by using the Duplicate option under the File Menu.

A copy of the drawing will automatically be created with Copy added to the file name. The file name will be

highlighted in blue and available for editing.



Page 241

TouchDraw for Mac

Enter a new file name for the duplicated drawing and then hit Enter on your keyboard to save the change.
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5.5. Revert Document
TouchDraw offers the option to revert to a saved copy of a drawing after changes have been made. To access

this option, click on the File Menu and choose the Revert Document... option as shown in the example below.

In this example, the white square is the originally saved drawing and the fill color is changed to blue after the a

save is performed.

To revert the current drawing to the last save point:

1

Click on File Menu and choose Revert Document... menu option.

2

The drawing canvas will refresh to what was previously saved.

https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/File-Menu-Old.md
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The Revert Document... option becomes enabled if a save was previously performed and changes have been

made to the drawing since the save. It will only revert back to the most recent save and is disabled after being

selected.
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5.6. Exporting a Drawing
TouchDraw running Mac OS 10.10 (Yosemite) or newer does not support exporting to EPS.

TouchDraw currently support 5 different exporters to Export a Drawing:

• Bitmap Image (PNG, JPEG, TIFF, BMP)

• PDF (Portable Document Format)

• SVG (Scalable Vector Graphics)

• Microsoft Visio (VDX Format)

• EPS (Encapsulated Postscript) (On Mac OS 10.9 or older)

Follow the steps below to export a drawing:

1

Select the File Menu and choose Export... to open the file export popover or use the Command-EKeyboard

Shortcut to open this window.

2

Choose which file format the drawing will be exported as. The popover will reconfigure itself to show all valid

options for the selected format. The screenshot example shown below represents available options for

exporting as an image and includes the capability of configuring maximum image size among additional

options.
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Visible Layers within a drawing can be exported as separate image files. Refer to the Bulk Exporting of

Individual Layers portion of the documentation to learn more about this feature.

3

Click on the Export Button once the appropriate file format and all corresponding options have been set.
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When you export a drawing as an image the popover window will show a drawing preview. A preview is not

given when exporting a drawing in another format such as Visio.

For detailed information on all of the options, limitations and known issues for the supported file formats,

please refer to the Exporting sub section of the File Format Support section.

5.6.1. Exporting a Bitmap Image
A drawing can be exported as an bitmap image file in any of the PNG, JPEG, TIFF, GIF, or BMP file formats.
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Click on the name of the Image Export Option to learn more about what actions occur upon selection.

Option Name Description

Content The Content option is used to select what will be exported: entire drawing, selected

content, or selected layer.

Format The Format option is used to select the type of image file to be created by the export.

Image Size The Image Size option shows the current width and height of the image and can be

altered prior to exporting.

Scale The Scale option sets the dimension of the exported image to a specific percentage

relative to the drawings actual size.

Constrain

Proportions

The Constrain Proportions option links the width and height when selected.

Include Grid The Include Grid option tells TouchDraw to include (or not include) the grid in the

generated file.
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Option Name Description

Half Pixel Shift The Half Pixel Shift option shifts pixel half a pixel-width toward the right.

Force Transparent

Background

The Force Transparent Background option makes the background transparent to

only show the images to be exported.

Include Border The Include Border option generates a border at a selected location on the drawing.

Quality The Quality option alters the image quality for JPEG image exports.

Zoom The Zoom slider can be use to increase or decrease the zoom level in the export

preview pane.

5.6.2. Exporting to SVG
A drawing can be exported as an SVG (Scalable Vector Graphics) file format.

Click on the name of the SVG Export Option to learn more about what actions occur upon selection.

Option Name Description

Content The Content option is used to select what will be exported: the entire drawing,

selected content, or a selected layer.

Include Border The Include Border option generates a border of a specified size around the drawing

to be exported.

Include Inkscape The Include Inkscape Attributes option informs TouchDraw to include Inkscape
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Option Name Description

Attributes specific attributes when exporting a drawing as an SVG File.

Force Transparent

Background

The Force Transparent Background option forces the exported image to be created

with a transparent background. Only the images to be exported will be shown.

5.6.3. Exporting to VDX
A drawing can be exported as an VDX (Microsoft Visio XML Drawing) file format.

Click on the name of the VDX Export Option to learn more about what actions occur upon selection.

Option Name Description

Content The Content option is used to select what will be exported: the entire drawing,

selected content, or a selected layer.

5.6.4. Exporting to PDF
A drawing can be exported as an PDF (Portable Document Format) file format.
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Click on the name of the PDF Export Option to learn more about what actions occur upon selection.

Option Name Description

Content The Content option is used to select what will be exported: the entire drawing,

selected content, or a selected layer.

Include Grid The Include Grid option tells TouchDraw to include (or not include) the grid in the

generated file.

Include Border The Include Border option generates a border of a specified size around the drawing

to be exported.

5.6.5. Exporting to EPS
TouchDraw running Mac OS 10.10 (Yosemite) or newer does not support exporting to EPS.

A drawing can be exported as an EPS (Encapsulated PostScript) file format on Macs running Mac OS 10.9 or

older. TouchDraw running Mac OS 10.10 (Yosemite) does not support exporting to EPS.
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Click on the name of the EPS Export Option to learn more about what actions occur upon selection.

Option Name Description

Content The Content option is used to select what will be exported: the entire drawing,

selected content, or a selected layer.

Include Grid The Include Grid option tells TouchDraw to include (or not include) the grid in the

generated file.

Include Border The Include Border option generates a border at a selected location on the drawing.

5.6.6. Bulk Exporting of Individual
Layers
The All Visible Layers Individually option resides under the Content section of the File Export Window for

each supported file format (Image, Visio, PDF, SVG, EPS). It is used to export each visible layer within a

drawing as a separate image. Each resulting image is saved under the name applied to the individual layer

within TouchDraw.

This bulk exporting option makes it easy to create a large drawing with numerous layers and then export

individually selected (visible) layers at once rather than by one at a time. In this example, three layers have

been created with each containing one icon, as shown below:
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To access the All Visible Layers Individually option and complete a bulk export:

1

Click on the File Menu and select the Export option.

2

Click on the desired File Type at the top of the export window. Image is chosen in this example.
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3

Click on the Content drop down menu and select the All Visible Layers Individually option.

4

Alter any additional exporting options and then click on the Export Button to complete the bulk export. Click

on the Cancel Button to exit the screen without exporting.
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5

Choose a Target Directory for saving by Double Clicking on the directory or folder name.

6

A file for each individual layer will be added to the selected target directory.
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5.7. Printing a Drawing
TouchDraw supports the capability of printing drawings to local printers. The print options can be accessed

from two locations: the Main Toolbar and the File Menu as shown below.

The Printer Options view will open. This view is used to configure printers, set the number of copies, choose

the number of pages, and set additional print settings.



Page 257

TouchDraw for Mac

Use the Show Details button to view more TouchDraw specific options for printing:

The TouchDraw specific options can be set on the Drawing Options tab and are described below:

Printer Option Description

Fit To Page This option will scale the current drawing to fit onto the page.

Include Grid This option will tell TouchDraw to draw the grid onto the page.
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5.8. Closing a Drawing
To Close a Drawing, select the File Menu and click on the Close option as shown below.

You may also use the Command-Wkeyboard shortcut to perform the same action within TouchDraw.
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5.9. Inserting an Image
An image file can be inserted as part of a drawing. These image types are supported by the TouchDraw

application:

• Portable Network Graphic (.png)

• JPEG (.jpg, .jpeg)

• BMP (.bmp)

• TIFF (.tif, .tiff)

• GIF (.gif)

Follow the steps below to Insert an Image:

1

Select the File Menu and click on Insert Image....

2

Navigate to the directory location of a desired image file.



Page 260

TouchDraw for Mac

3

Click on the appropriate file name.

4

Click on the Open button.
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5

The selected image will appear in the drawing canvas.
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    Note: Only files with the appropriate extension will be presented as a selectable item in the shown directory

list.
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6. Editing Drawings
The options for Editing Drawings in TouchDraw are designed to make working with figures, lines, paths, and

handles easier. The following pages explain how to perform drawing editing operations.
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6.1. Editing Basics
The Drawing Editor contains the features and tools necessary for creating and editing new or existing

drawings. The editor appears after creating a new drawing or opening an existing file and consists of six

sections as shown in the image below.

Click on the name of the Drawing Editor section to learn more about what actions can be performed.

Section Name Description

Main Toolbar The Main Toolbar provides access to most object actions and drawing properties.

Drawing Toolbar The Drawing Toolbar is the activation location for application drawing tools.

Drawing Canvas The Drawing Canvas is used to view, create and change drawings.

Format Bar The Format Barp rovides quick access to text, stroke, and fill attributes.

Sidebar The Sidebar provides access to object attribute settings.
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Section Name Description

Bottom Bar The Bottom Bar provides quick access to common application settings.

6.1.1. Selecting a Figure
TouchDraw contains five types of figures:

• Lines (including open paths)

• Shapes (including closed paths)

• Text

• Images

• Stencils and Groups (compound figures)

For the purposes of selecting a figure, there are really only two types: Lines and shapes.

Images, text figures and compound figures all behave like shapes for selection, so we won't discuss them

separately.

To select a line, click on the line and its handle endpoints will appear.

To select a shape, click anywhere within the shape and its handles will appear.
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Multiple Selections

By default, a previously selected shape will be deselected when another is selected; however, TouchDraw does

support multiple selections. Hold down the Shift key and Click to select multiple lines or shapes. Continue to

hold the Shift key while clicking on each desired figure to complete a multiple selection in the drawing canvas.

The Selection Rectangle may also be used to select multiple figures. Click and drag the Selection Rectangle

from left to right or right to left over an area within the Drawing Canvas and then release the click action once

the rectangle covers the desired area to complete the selection. When the rectangle is dragged from left to right,
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it will select all figures within its bounds and every figure intersecting it, as shown below.

Dragging the Selection Rectangle from right to left from any point within the Drawing Canvas informs

TouchDraw to select only the figures within the rectangle's bounds, as shown below.
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The Select All command can be used to select every figure, line, path, etc. on the drawing canvas. This option

is accessible through both the Edit Menu and the Contextual Menu or with the Command-A keyboard

shortcut. Figures are deselected in the same manner by using the Deselect All menu option or by clicking on an

empty drawing canvas location.

6.1.2. Deleting a Figure
An object must be selected before it can be deleted. A currently selected figure can be deleted in one of two

ways:

1

Select the Edit Menu and click on Delete.
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2

Press the Delete key on the Mac keyboard.

Note: Please keep in mind that TouchDraw has support for Undo and Redo. If a figure is deleted by accident,

choose the Undo option under the Edit Menu to redisplay the object.

6.1.3. Renaming a Drawing
Performing a Click on the Drawing Title opens a prompt window for renaming the currently open drawing.

After a new drawing name has been entered in the prompt window, press on the Enter Key on your keyboard

to complete the change.
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The new drawing name will appear above the Toolbar, as shown below:

6.1.4. Using the Clipboard
The Clipboard holds the most recent change made to a figure within the drawing canvas. Changes are stored

on the clipboard when an item is copied, cut or undone. They are reapplied by choosing the Paste, Paste Style,

or Redo commands. Additional options are available under the Paste Special Submenu for pasting in the same

exact location, a formatting style, and multiple figures.

All Clipboard actions are accessible through the Edit Menu or Contextual Menu as shown below:
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The command shortcuts may also be used to gain quick access to Clipboard actions.

6.1.4.1. Paste Style
The Paste Style command allows formatting to be copied from one shape and pasted (applied) to another.

The process for this command is shown in the following example:

1

Select the source shape/figure with the formatting to applied to another object.
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2

Copy the shape to the clipboard.

3

Select the target shape.

4

Select the Paste Style command from the Edit Menu or from the Contextual Menu to apply formatting from

the source figure to the target figure.

The Paste Style command is also accessible by using the Option-Command-Vkeyboard shortcut.

6.1.5. Copying a Figure
A figure or group of figures must be selected before copying can occur. Figures can be copied in one of three

ways after a selection has been made.

1
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Click on the Edit Menu and choose Copy.

2

Open the Contextual Menu and choose Copy.

3

Use the Command-Ckeyboard shortcut.

Once a figure(s) has been copied, use the same menus or the Command-V keyboard shortcut to Paste in a

desired location. The Paste Style command may also be used to copy the formatting of one figure to another.
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6.1.6. Duplicating a Figure
A figure can be duplicated to make sharing the same attributes easy. At least one figure or a group of figures

must be selected for the Duplicate and Duplicate in Place options to be available.

The Duplicate option creates a copy of a selected figure(s) and places it at an offset position in the drawing

canvas.

The Duplicate in Place option creates a copy of a selected figure(s) and places it in the same exact location as

the original. Click and drag on the top figure to move it to a new position in the drawing canvas.
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Figures can be duplicated in one of three ways after a selection has been made:

1

Click on the Edit Menu and choose Duplicate or Duplicate in Place.
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2

Open the Contextual Menu and choose Duplicate or Duplicate in Place.
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3

Use the Command-D or Shift-Command-DKeyboard Shortcuts.

6.1.7. Cut and Paste
Cutting and pasting works in the same manner as copy and delete. The Cut command removes the figure

from the drawing canvas and adds it to the clipboard. Select a figure or group of figures and use one of the

following three methods to perform a cut:

1

Select the Edit Menu and choose Cut.
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2

Open the Contextual Menu and choose Cut.

3

Use the Command-X keyboard shortcut.

The Paste command adds the current clipboard contents to the drawing canvas. To Paste current clipboard

contents:

1

Select the Edit Menu and choose Paste.
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2

Open the Contextual Menu and choose Paste.

3

Use the Command-Vkeyboard shortcut.

Pasting the clipboard contents multiple times into the Drawing Canvas causes the figure(s) to be placed in

slightly offset positions as shown below.
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The Paste Special Submenu can be used to perform additional pasting actions.
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To paste a figure in the same exact location, click on the Edit Menu or Contextual Menu, select Paste Special,

and choose Paste in Place.

To see the pasted figure select the figure and drag in any direction. In the example below, the pasted figure is

dragged to the right.
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To paste multiple instance of a figure in the clipboard, bring up one of the above shown menus, select Paste

Special, and choose Paste Multiple...
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Multiple pastes of the clipboard content will cause each figure to be placed in slightly offset positions as shown

below:

To paste the style of a figure, bring up one of the above shown menus, select Paste Special, and choose Paste

Style. Refer to the Paste Style section of this documentation to learn more.
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An additional option resides in the Contextual Menu. The Paste as Image Fill option may be used to copy a

figure, image, etc. and then paste the item into the selected figure as a fill. In the example below, an Oval figure

has been pasted into the Rectangle.
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6.1.8. Undo and Redo
The Undo command reverts the last change that was made to a drawing. This option is disabled (dimmed)

when no changes have been made and enabled as soon as something is altered on the drawing canvas. Perform

one of the following actions to revert the last made change:

1

Select the Edit Menu and choose Undo.

2
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Use the Command-Zkeyboard shortcut.

The Redo command cancels the last undone change made to the drawing canvas. This option is disabled

(dimmed) when nothing has been undone and is enabled as soon as the Undo command has been used or

something is altered. Perform one of the following actions to reapply the last undone change:

1

Select the Edit Menu and choose Redo.

2

Use the Shift-Command-Zkeyboard shortcut.

The Undo and Redotoolbar buttons may also be used to perform these actions within TouchDraw.
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6.2. Handling Figures
TouchDraw supplies a variety of options for handling figures within a drawing. An individual shape or group

of figures can be:

• Moved

• Stretched

• Resized

• Rotated

• Flipped

• Scaled

• Shifted

The following pages describe these actions in further detail and provide steps for using each method of figure

handling.

6.2.1. Moving a Figure
A figure must be selected to be moved to another location on the drawing canvas. Perform a Drag action to

move an already selected figure or use a Click/Drag combination within the figures bounds to accomplish the

move in one step. To change the position of a group of selected figures, perform a Click/Drag combination

within bounds of any selected object to move the entire selection. A move is completed when the Click action

is released.

6.2.2. Stretching a Figure
Most shapes have handles in the top, center, bottom center, left middle, and right middle that allow the figure to

be stretched and made wider or taller. The screenshot below demonstrates these handles for a rounded rectangle.
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To Stretch a Figure, click on one of the above shown handles and then drag it to a desired location. The figure

will stretch itself dynamically as the handle is dragged.

Pressing the shift key as a figure is stretched allows it's current aspect ratio to be maintained.

Multiple figures can be stretched at once by placing them into a group.

6.2.3. Resizing a Figure
In addition to the handles for stretching a figure, shapes also have handles in the upper left, upper right, lower

left and lower right for resizing the figure. The screenshot below shows these handles for a rounded rectangle:

To Resize a Figure, perform a Click/Drag combination on one of the above shown handles. The width and

height of a figure will change dynamically as the handle is dragged.

Pressing the Shift Key while resizing a figure allows it's current aspect ratio to be maintained.
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Multiple figures can be resized at once by placing them into a group.

6.2.4. Rotating a Figure
Every figure, with the exception of lines, can be rotated. A red handle will be shown to the right of a figure

when it is selected for rotation. This red handle can be dragged to change the rotation angle of a selected shape.

A semi-transparent gray line going from the rotation handle to the figure's center of rotation point (typically

represented by a gray circle in the middle) will also be displayed.

Perform a Click/Drag combination on the red handle to rotate the object in increments of 1° around it's center

of rotation point. In the example below, the red handle is dragged down and to the left.
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Pressing the shift key as a figure is rotated causes this action to occur in 15° increments.

A figure may be rotated at 90° increments to the right or left by using the Rotate 90° Right or Rotate 90° Left

options in the Rotate Submenu. To access this submenu, click on the Modify Menu and then click on the

Rotate Submenu.

The example below shows what a figure looks like prior to and after being rotating 90 degrees to the left.
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The Rotate 180° command may also be used to rotate a figure and is accessible through the same menu as

discussed above. Below is an example of what a figure looks like prior to and after being rotated 180 degrees.

The Center of Rotation can be changed to a different point within a shape or reset after it has been altered. See

Changing the Center of Rotation or Resetting the Center of Rotation for additional information.
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6.2.4.1. Changing the Center of
Rotation
A selected shape will show a gray semi-transparent circle connected to the rotation handle. This gray circle

indicates a selected shape's Center of Rotation and can be changed to any desired point within the shape's

bounds. By default, the option to change a shape's Center of Rotation is not enabled.

Use the Handles Settings popup menu to to enable the "Center of Rotation" handle.
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A new handle will replace the original semi-transparent circle once this option has been enabled.

To alter the Center of Rotation, drag the newly visible handle to a desired location.

The shape will rotate around the new point rather than its natural center once it has been set.
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6.2.4.2. Resetting the Center of
Rotation
A selected shape will show a gray semi-transparent circle connected to the rotation handle. This gray circle

indicates a selected shape's Center of Rotation and can be changed to any desired point within the shape's

bounds.This point can be set back to its natural center after it's location has been altered. Follow the steps

below to Reset the Center of Rotation:

1

Select the desired Shape.

2

Select the Modify Menu.
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3

Choose the Rotate Submenu and click on Reset Center of Rotation.

4

The point will be adjusted back to its natural center.



Page 296

TouchDraw for Mac

6.2.5. Flipping a Figure
A figure can be flipped either horizontally or vertically in the drawing canvas. These options can be found in

the Flip Submenu under the Modify Menu. See image below:

A figure must be selected to choose one of the above options.

Choose Flip Horizontally from this menu to interchange a figure horizontally. The images below show a

before and after of this figure transition:
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Choose Flip Vertically from the above menu to interchange a figure vertically. The images below show a

before and after of this figure transition.

6.2.6. Scaling a Figure
The Scale By... option can be used to alter figure size based on input coordinates to create a smaller or larger

figure spanning over a specific area. It is accessible through the Transform Submenu of the Modify Menu.

To Scale a Figure or group of figures:

1

Select the figure(s) to be altered.
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2

Select the Modify Menu, choose Transform, and click on Scale By....

3

Enter the desired X and Y coordinates into the Scale By popup window by using the incremental buttons to the

right of each field or by performing a Click/Keyboard entry action.



Page 299

TouchDraw for Mac

4

Select or deselect desired options in the Scale By popup window.

5

Click on the Scale Button when finished.
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6

The selected figure will be scaled according to the entered coordinates and selected options. It will appear in

scaled form with the Scale By popup window remaining available to make further changes.

    Note:Scale By... changes can be reverted by using the Undo option under the Edit Menu or with the

Command-Z keyboard shortcut.
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6.2.6.1. Scale Size
The Scale Size option informs TouchDraw to scale the size of the selected figure(s) based on the entered

Factor X and Factor Y values. If enabled, the check box will have a checkmark with a blue background, as

shown below:

This option must be enabled for the selected figure(s) to be scaled by the entered values.
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If Factor Y is changed to 4 for the above figure, it will appear as shown below:

If the Scale Size option is disabled (no checkmark), the size will not be scaled. However, if the Scale Attributes

option remains enabled, then the attributes (stroke, text, etc.) will be scaled according to the entered values, as

shown below:
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Please note that if both options have been disabled, then the selected figure(s) will not be scaled.

6.2.6.2. Scale Attributes
The Scale Attributes option informs TouchDraw to scale the attributes (stroke, text, etc) of the selected

figure(s) based on the entered Factor X and Factor Y values. If enabled, the the check box will appear with a

check mark and blue background, as shown below:
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If the Scale Size option has been enabled as well, then the selected figure's size and attributes will be scaled

according to entered values. If 4 is entered for Factor Y, then the height of the selected figure(s) will be scaled

by that value.

The above figure would appear as shown below:
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When the Scale Attributes option is disabled (no checkmark), only the size of the selected figure(s) will be

scaled by the entered Factor values.
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In the example below, the size of the figure is scaled; however, the stroke and text attributes are not.

If Scale Attributes is the only enabled option, then only the attributes of the selected figure(s) will be scaled

according to the entered Factor values.
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Please note that if both options have been disabled, then the selected figure(s) will not be scaled.

6.2.7. Shifting a Figure
The Move By... option can be used to shift a selected figure or group of figures by an entered set of

coordinates. This option changes the location of a figure based on input coordinates and is accessible through

the Transform Submenu of the Modify Menu.
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To Shift a Figure or group of figures:

1

Select a Figure or grouping of figures to be shifted.

2

Select the Modify Menu, choose Transform, and click on the Move By... option.

3

Enter the desired X and Y grid coordinates in the Move By popup window.
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4

Click on the Move Button to finish the shift.
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5

The selected figure or group of figures will shift in accordance to the entered coordinates.
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6.2.8. Arranging Figures
TouchDraw allows figures within the drawing canvas to be grouped or locked. Grouped figures are treated as a

single object where all attribute, movement, and sizing changes are applied to the group as a whole. Locked

figures cannot be moved or resized, but still allow for attribute changes such as the fill color or stroke

properties. Figures can be ungrouped or unlocked any time object modification requirements change and then

regrouped or locked again as needed.

6.2.8.1. Grouping Figures
Shapes residing on the drawing canvas can be manipulated and treated as a single figure with the Group

feature. More than one figure will need to be selected in order for this option to be enabled. Use a Shift

Key/Click combination to select multiple figures. The methods for Grouping Figures are described below:

1

Select the Arrange Menu and choose Group.

2

Open the Contextual Menu, select the Arrange Submenu, and choose Group.
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3

Use the Group Button located on the Main Toolbar.

4

Use the Command-Gkeyboard shortcut.

Paths are an exception to the multiple selection rule because a path or path shape can be added to a group by

itself. This allows for path interaction without having to worry about the occurrence of reshaping when

grabbing one of the available handles.

The screenshots below show a before and after for creating a group from a multiple selection of figures.
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New bounds handles will appear after the selected figures are grouped. These handles correspond to the group

as a whole rather than each individual figure. A new rotation handle is provided for making an entire group

rotation. The standard "blue" handles are replaced by "blue handles with dots" to provide a visual indicator as

to whether the entire group or a separate figure has been selected.

6.2.8.2. Ungrouping Figures
A Group must be selected for the ungrouping option to be enabled. Use one of the following methods to

ungroup a set of grouped figures:

1

Select the Arrange Menu and choose Ungroup.

2

Open the Contextual Menu, select the Arrange Submenu, and choose Ungroup.
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3

Use the Ungroup Button located on the Main Toolbar.

4

Use the Shift-Command-Gkeyboard shortcut.

Any transformations made to the group (such as rotating, resizing, etc...) will be retained by previously grouped

objects after the ungrouping action has been completed. Grouping provides a nice way to quickly make bulk

changes to multiple figures or all objects within a drawing.

6.2.8.3. Locking Figures
A Locked Figure is one that cannot be moved or resized until it has been unlocked. Attributes such as stroke,

fill, shadow, etc... can still be manipulated on a locked figure. A minimum of one figure must be selected in

order for this option to be enabled. Use one of the following methods to Lock a Figure(s):

1

Select the Arrange Menu and choose Lock.
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2

Open the Contextual Menu, select the Arrange Submenu, and choose Lock.

3

Use the Lock Button located on the Main Toolbar.

4

Use the Command-Lkeyboard shortcut.

Use a Shift/Click combination to select multiple figures for locking. All objects within a drawing can be

selected at once by choosing Select All in the Edit Menu or by using the Command-Akeyboard shortcut.
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A group of figures will appear as shown below when they are unlocked.

The group will appear as shown below once they have been locked.

The handles appear gray after a figure(s) or group of figures are locked. This handle attribute change serves as

a visual indicator of the selected figure(s) being locked.

6.2.8.4. Unlocking Figures
A figure(s) or group of figures can be unlocked to allow for moving and resizing. Use one of the following

methods to Unlock Figures:

1

Select the Arrange Menu and choose Unlock.
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2

Open the Contextual Menu, select the Arrange Submenu, and choose Unlock.

3

Use the Unlock Button on the Main Toolbar.

4

Use the Shift-Command-Lkeyboard shortcut.

This Arrange Menu item will only be enabled when a locked figure(s) or group of figures has been selected

within the drawing panel.
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6.2.9. Aligning Figures
TouchDraw provides methods for aligning a set of figures to an attribute of the first selected figure in the set.

Relative Alignment

The first type of alignment that can be done is relative alignment, where figures are aligned in relation to one

another. The list below outlines the relative alignment options available.

• Top

• Vertical Center

• Bottom

• Left

• Horizontal Center

• Right

Grid Alignment

In addition to relative alignment, a figure (or set of figures) can also be aligned to the grid of the drawing

canvas in the case that they were drawn or modified while the snap to grid option was disabled.

6.2.9.1. Align to Grid
The Align to Grid option is available to align figures with the grid. Select each desired figure and use one of

the following methods to align a figure(s) to the grid:

1

Click on the Arrange Menu, select the Align Submenu, and choose Align to Grid.
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2

Open the Contextual Menu, select the Align Submenu, and choose Align to Grid.

The option will first align the upper left hand corner of the selected figures to the grid and then resize it to

make all four corners align with the grid.

The following screenshots show a before and after of a shape that has been aligned to the grid.
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The Snap To Grid option must be disabled to place an figure anywhere within the grid lines on the drawing

canvas. This option must be enabled for the Align to Grid option to provide the results shown above.

6.2.9.2. Align Top
The Align Top option moves all currently selected figures to match the top (Y position) of the first selected

figure. At least two figures must be selected for this application feature to be enabled. Use one of the following

methods to align selected figures with to the top position of the first selected figure:

1

Click on the Arrange Menu, select the Align Submenu, and choose Align Top.
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2

Open the Contextual Menu, select the Align Submenu, and choose Align Top.

3

Use the Top button located on the main toolbar.

The following images display the selection order of items to be aligned.
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The following image displays the selected objects after the alignment has been performed.
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6.2.9.3. Align Vertical Center
The Align Vertical Center option moves all currently selected figures to match the vertical center (Y position

+ 1/2 of the height of all figures) of the first selected figure. At least two figures must be selected for this

application option to be enabled. Use one of the following methods to align the vertical center of a figure(s):

1

Click on the Arrange Menu, select the Align Submenu, and choose Align Vertical Center.

2

Open the Contextual Menu, select the Align Submenu, and choose Align Vertical Center.
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3

Use the V. Center button located on the main toolbar.

The following images display the selection order of items to be aligned.
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The following image displays the selected objects after the alignment has been performed.

6.2.9.4. Align Bottom
The Align Bottom option moves all currently selected figures to match the the bottom (Y position + Height) of

the first selected figure. At least two figures must be selected for this application feature to be enabled. Use one

of the following methods to align figures with the bottom position of the first selected figure:

1

Click on the Arrange Menu, select the Align Submenu, and choose Align Bottom.
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2

Open the Contextual Menu, select the Align Submenu, and choose Align Bottom.

3

Use the Bottom button located on the main toolbar.

The following images display the selection order of items to be aligned.



Page 327

TouchDraw for Mac

The following image displays the selected objects after the alignment has been performed.
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6.2.9.5. Align Left
The Align Left option moves all currently selected figures to match the left (X position) of the first selected

figure. At least two figures must be selected for this application feature to be enabled. Use one of the following

methods to align figures with the left position of the first selected figure:

1

Click on the Arrange Menu, select the Align Submenu, and choose Align Left.

2

Open the Contextual Menu, select the Align Submenu, and choose Align Left.



Page 329

TouchDraw for Mac

3

Use the Left button located on the main toolbar.

The following images display the selection order of items to be aligned.
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The following image displays the selected objects after the alignment has been performed.

The following figures show an example of using the Align Left action.
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6.2.9.6. Align Horizontal Center
The Align Horizontal Center option moves all currently selected figures to match the horizontal center (X

position + 1/2 of the width) of the first selected figure. At least two figures must be selected for this application

feature to be enabled. Use one of the following methods to align figures with the horizontal center of the first

selected figure:

1

Click on the Arrange Menu, select the Align Submenu, and choose Align Horizontal Center.

2

Open the Contextual Menu, select the Align Submenu, and choose Align Horizontal Center.
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3

Use the H. Center button located on the main toolbar.

The following images display the selection order of items to be aligned.
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The following image displays the selected objects after the alignment has been performed.

6.2.9.7. Align Right
The Align Right option moves all currently selected figures to match the right (X position + Width) of the first

selected figure. At least two figures must be selected for this application feature to be enabled. Use one of the

following methods to align figures with the right position of the first selected figure:

1

Click on the Arrange Menu, select the Align Submenu, and choose Align Right.
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2

Open the Contextual Menu, select the Align Submenu, and choose Align Right.

3

Use the Right button located on the main toolbar.

The following images display the selection order of items to be aligned.
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The following image displays the selected objects after the alignment has been performed.
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6.2.10. Snapping Figures
TouchDraw supplies options for snapping figures to specific points on the grid, positions on the Drawing

Canvas or positions relative to other shapes. Figures can be snapped to these locations:

• Grid

• Lines

• Pixels

• Points

• Shapes

The Snapping Submenu provides access to these settings and can be used to make changes for the currently

active drawing canvas. This menu is located in the View Menu, as shown below.

6.2.10.1. Snap to Grid
The Snap to Grid option toggles whether or not figures (and their handles) should be aligned to the grid as

they are created and modified. Use one of the following methods to enable/disable this option:

1

Click on the View Menu, select the Snapping Submenu, and choose on Snap to Grid.
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2

Use the Shift-Command-Apostrophekeyboard shortcut.

The Snap to Grid option will show a checkmark symbol next to the menu selection area when enabled.

6.2.10.2. Snap to Lines
The Snap to Lines option allows dragged handles to snapped to the endpoints or the midpoints of lines in the

drawing canvas. Click on the View Menu, select the Snapping Submenu, and choose Snap to Lines to

enable/disable this option.



Page 338

TouchDraw for Mac

The Snap to Lines option will show a checkmark symbol in the menu selection area when enabled.

6.2.10.3. Snap to Pixels/Points
The Snap to Pixels/Points option aligns objects to whole pixel numbers for simplified modification and

increased accuracy. This option remains disabled until the unit of measure for the drawing is changed to pixels

or points.

To change the Units attribute, click on the Units and Rulers Button located in the Info portion of the Sidebar.
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To enable/disable this option, click on the View Menu, select the Snapping Submenu, and choose Snap to

Pixels/Points.

The Snap to Pixels/Points option will show a checkmark symbol in the menu selection area when enabled.

6.2.10.4. Snap to Pixels/Points Old

6.2.10.5. Snap to Shapes
The Snap to Shapes option snaps a figure to a selected shape vertex or center point. This option is enabled by
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default in TouchDraw. To enable/disable this option, click on the View Menu , select the Snapping Submenu ,

and choose Snap to Shapes .

The Snap to Shapes option will show a checkmark when enabled and no checkmark when disabled.

To see this option in action, disable the Snap to Grid option, make certain Snap to Shapes is enabled, and then

draw a star or rectangle. Once the shape is completed, select the Line Tool and try to draw a line from one of

the vertexes of the shape or its center point. The drawn line will snap to one of these locations.
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In the example below, the line snaps to the center point of the rectangle.

6.2.11. Ordering Figures
TouchDraw supplies application functions for altering the order of a figure or multiple figures within a specific

layer on the drawing canvas. Figures can be moved to the front of a layer or moved forward by one level from

their previous position. They may also be moved to the back of a layer or moved backward by one level within

a layer.

6.2.11.1. Bring to Front
The Bring to Front option moves a currently selected figure(s) to the front of all figures residing in the same

layer. At least one figure within a layer must be selected for this option to be enabled. Use one of the following

methods to bring a figure(s) to the front of a layer:

1
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Select the Arrange Menu and choose Bring to Front.

2

Open the Contextual Menu, select the Arrange Submenu, and choose Bring to Front.

3

Use the Front button located on the main toolbar.

4

Use the Shift-Command-Closing Bracketkeyboard shortcut.
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The following images display the position of a selected rectangle prior to and after using the Bring to Front

option.

6.2.11.2. Bring Forward
The Bring Forward option moves a currently selected figure(s) one step closer to the top of the stack within

the layer they reside in. At least one figure within a desired layer must be selected for this option to be enabled.

Use one of the following methods to bring a figure(s) forward within a layer:

1

Select the Arrange Menu and choose Bring Forward.
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2

Open the Contextual Menu, select the Arrange Submenu, and choose Bring Forward.

3

Use the Forward button located on the main toolbar.

4

Use the Command-Closing Bracketkeyboard shortcut.

The following images display the position of a selected rectangle prior to and after using the Bring Forward

option.
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Note: The Bring Forward option can be chosen multiple times to continue moving a selected figure(s) to the

front of a layer.

6.2.11.3. Send Backward
The Send Backward option moves a currently selected figure(s) one step closer to the bottom of a stack within

their residing layer. At least one figure within a layer must be selected for this option to be enabled. Use one of

the following methods to send a figure(s) back one step within a layer:

1

Select the Arrange Menu and choose Send Backward.
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2

Open the Contextual Menu, select the Arrange Submenu, and choose Send Backward.

3

Use the Backward button located on the main toolbar.

4

Use the Command-Opening Bracketkeyboard shortcut.

The following images display the position of a selected pentagon prior to and after using the Send Backward

option.
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The Send Backward option can be chosen multiple times to continue moving a selected figure(s) to the back

of a layer.

6.2.11.4. Send to Back
The Send to Back option moves a currently selected figure(s) behind all other figures residing within the same

layer. At least one figure within a layer must be selected for this option to be enabled. Use one of the following

methods to send a figure(s) to the back of a layer:

1

Select the Arrange Menu and choose Send to Back.
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2

Open the Contextual Menu, select the Arrange Submenu, and choose Send to Back.

3

Use the Back button located on the main toolbar.

4

Use the Shift-Command-Opening Bracketkeyboard shortcut.

The following images display the position of a selected pentagon prior to and after using the Send to Back

option.
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6.2.12. Distributing Figures
TouchDraw offers options for apportioning figures evenly in relation to each other. A set of figures can be laid

out to have equal spacing between each figure measured either horizontally or vertically. A group of selected

figures may also be packed into the smallest rectangular space possible with the Pack command.

6.2.12.1. Distribute Horizontally
The Distribute Horizontally option adjusts the positioning of selected figures to create an even amount of

horizontal space between each figure. This option is enabled when three or more unlocked figures are selected

in the drawing canvas. Use one of the following methods to distribute a set of figures horizontally:
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1

Click on the Arrange Menu, select the Distribute Submenu, and choose Distribute Horizontally.

2

Open the Contextual Menu, select the Distribute Submenu, and choose Distribute Horizontally.

The following images display the positions of a selected set of figures prior to and after using the Distribute

Horizontally option.
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In the above example, the first and middle figures were originally 2.5 inches apart. The spacing between the

middle and last figure totaled 1.5 inches. After this option has been applied, the horizontal space between each

figure is adjusted to 2 inches to provide three evenly spaced figures.

6.2.12.2. Distribute Vertically
The Distribute Vertically option adjusts the positioning of selected figures to create an even amount of

vertical space between each figure. This option is enabled when three or more unlocked figures are selected in

the drawing canvas. Use one of the following methods to distribute a set of figures vertically:

1

Click on the Arrange Menu, select the Distribute Submenu, and choose Distribute Vertically.
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2

Open the Contextual Menu, select the Distribute Submenu, and choose Distribute Vertically.

The following images display the positions of a set of figures prior to and after using the Distribute Vertically

option.
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In the above example, the spacing between the top and middle squares totals 2 inches. The middle and bottom

figures have a vertical spacing of 1.5 inches. After this option has been applied, the vertical space between each

figure is adjusted to 1.75 inches to provide three evenly spaced figures.

6.2.12.3. Pack Horizontally
The Pack Horizontally menu item takes a set of selected shapes and "packs" them into the smallest space

possible horizontally.
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This option is enabled when three or more unlocked figures are selected in the drawing canvas. Complete the

following steps to pack a set of figures horizontally:

1

Select the figures or shapes to be packed horizontally.

2

Then click on the Arrange Menu, select the Distribute Submenu, and choose Pack Horizontally.

3

The following image displays the positions of a selected set of figures after using the Pack Horizontally option.

https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/Selecing-a-Figure.md
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6.2.12.4. Pack Vertically
The Pack Vertically menu item takes a set of selected shapes and "packs" them into the smallest space

possible vertically.

This option is enabled when three or more unlocked figures are selected in the drawing canvas. Complete the

following steps to pack a set of figures vertically:

1

Select the figures or shapes to be packed vertically.

2

https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/Selecing-a-Figure.md
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Click on the Arrange Menu, select the Distribute Submenu, and choose Pack Vertically.

3

The following image displays the positions of a selected set of figures after using the Pack Vertically option.

6.2.12.5. Pack
The Pack option can be used to "pack" a group of selected figures into the smallest possible rectangular space

within the drawing canvas. This option is enabled when two or more unlocked figures are selected in the

drawing canvas.
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To pack a set of figures:

Select the figures to be packed in the Drawing Canvas.

Click on the Arrange Menu, select the Distribute Submenu, and choose Pack.

Enter a padding value (if desired) and then click on Pack.
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The following images display the positions of a selected set of figures prior to and after using the Pack option.

In the example shown below, various stencils have been added to the canvas from the Shapes Library and

placed in random positions. This is how they appear before the action is performed:

After the pack, they appear as shown below:

6.2.13. Combining Shapes
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TouchDraw offers multiple options for combining two shapes within the drawing canvas. Options for selected

shapes include:

• Add

• Subtract

• Intersect

• Exclude

6.2.13.1. Add
The Add option combines two selected shapes into one figure. It remains disabled until two figures have been

selected. Use one of the following methods to Add selected shapes:

1

Select the Modify Menu and choose Add Shapes.

2

Use the Add button located on the Main Toolbar.
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The selection of two non-intersecting shapes has no effect on their appearance, but does cause the figures to be

treated as one shape.

The properties of the first selected shape will be applied to the combined shape. In the example below, the oval

is selected first.

The following images display two selected shapes prior to and after using the Add option.
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6.2.13.2. Subtract
The Subtract option removes the intersecting portions of the second selected shape from the first figure

selected in the drawing canvas. This option remains disabled until two figures have been selected. Use one of

the following methods to Subtract selected shapes:

1

Select the Modify Menu and choose Subtract Shapes.
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2

Use the Subtract button located on the main toolbar.

The selection of two non-intersecting shapes causes the second shape to be removed entirely.

The properties of the first selected shape will be applied to the combined shape. In the example below, the oval

is selected first.
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The following image shows the resulting shape after using the Subtract option.
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6.2.13.3. Intersect
The Intersect option removes all non-intersecting portions of selected figures from the drawing canvas. This

option remains disabled until two figures have been selected. Use one of the following methods to Intersect

selected shapes:

1

Select the Modify Menu and choose Intersect Shapes.

2

Use the Intersect button located on the main toolbar.

The selection of two non-intersecting shapes results in complete removal of both objects.

The properties of the first selected shape will be applied to the combined shape. In the example below, the oval

is selected first.
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The following images display two intersecting shapes prior to and after using the Intersect option.
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6.2.13.4. Exclude
The Exclude option removes the intersecting portions of selected figures from the drawing canvas. This option

remains disabled until two figures have been selected. Use one of the following methods to Exclude selected

shapes:

1

Select the Modify Menu and choose **Exclude****Shapes**.

2

Use the Exclude button located on the main toolbar.
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The selection of two non-intersecting shapes has no effect on appearance, but does cause the figures to be

treated as one shape.

The properties of the first selected shape will be applied to the combined shape. In the example below, the oval

is selected first.

The following images display two intersecting shapes prior to and after using the Exclude option.
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6.3. Handling Colors
TouchDraw provides multiple ways to select and change the color attributes of figures or text within the

drawing canvas. Color attributes can be changed for shapes, strokes, text, and the canvas background.

Color attributes are accessible in these three application areas:

• Sidebar

• Format Bar

• View Menu

Additional attributes are available for changing the shadow and fill style of a selected figure(s).

6.3.1. Stroke Color
The Stroke Color of a selected figure can be changed to meet a desired preference. This attribute can be

altered in one of the following ways:

1

In the Stroke tab of the Info portion of the Sidebar, click on the color well to bring up the standard OS X color

picker. If the color picker is already visible then TouchDraw will inform the color picker that it's value and

changes should be associated with the stroke color.

2

Use the Stroke Color button located in the Format Bar.
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A popup menu showing standard color choices will appear after the Stroke Color button is pressed, as shown

in the image below.

Click on a desired color to select it or click on the Show Colors button at the bottom to bring up the standard

OS X color picker. As with selecting the color well described in step 1, if the color picker is already visible

then TouchDraw will simply inform the color picker that it's value and changes should be associated with the

stroke color.

3

The example below shows a figure with the stroke color set to blue:
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A color change will be seen instantaneously when a stroke figure is selected. If no figures have been selected,

the color change will apply to all subsequently created stroke figures.

6.3.2. Fill Color
The Fill Color of a selected figure can be changed to meet a desired preference. This attribute can be altered in

one of the following ways:

1

In the Fill tab of the Info portion of the Sidebar, click on the color well to bring up the standard OS X color

picker. If the color picker is already visible then TouchDraw will inform the color picker that it's value and

changes should be associated with the fill color.

2

Use the Fill Color button located in the Format Bar.

A popup menu showing standard color choices will appear after the **Fill****Color** button is pressed, as

shown in the image below.
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Click on a desired color to select it or click on the Show Colors button at the bottom to bring up the standard

OS X color picker. As with selecting the color well described in step 1, if the color picker is already visible

then TouchDraw will simply inform the color picker that it's value and changes should be associated with the

stroke color.

A color change will be seen instantaneously when a figure is selected. If no figures have been selected, the

color change will apply to all subsequently created figures.

The Fill Style of a selected figure can be changed to solid, linear gradient, or radial gradient. To alter the style

of a figure:

1

Select the Fill tab located in the Info portion of the Sidebar.

2

Click on the Fill Style drop down menu and choose a desired style.
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Changes made to these attributes are only reflected on current or new figures within the drawing canvas when

the Fill option has been enabled. Click on the box next to the fill label to enable/disable this option. Refer to the

screenshots below:

6.3.3. Solid
The Solid fill style option is located on the Fill tab in the Info portion of the Sidebar. This attribute sets the fill

of a selected or any created figure(s) to a solid color. The Fill option must be enabled for a change in this tab to

be applied to currently selected or new figures. Click on the box next to the option name to enable/disable it, as

shown below:
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Follow the steps below to set this attribute to Solid:

1

Select the Fill tab located in the Sidebar.

2

Click on the Fill Style drop down menu.
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3

Choose the Solid fill style.

A checkmark is used to depict the currently selected style within the drop down menu.

A style change will be seen instantaneously when a figure is selected. If figures have not been selected, the

style change will apply to all subsequently created figures.

The following example shows a rectangle with the Fill Style set to solid and Color set to blue:
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6.3.3.1. Linear Gradient
The Linear Gradient fill style option is located on the Fill tab in the Info portion of the Sidebar. This attribute

transitions the fill from a specific start color to the specified end color at a designated angle within a selected or

created figure(s). The Fill option must be enabled for a change in this tab to be applied to currently selected or

new figures. Click on the box next to the option name to enable/disable it, as shown below:

Follow the steps below to set this attribute to Linear Gradient:

1

Select the Fill tab located in the Sidebar.

2

Click on the Fill Style drop down menu.
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3

Choose the Linear Gradient fill style.

4

The following example shows a rectangle with the Fill Style set to linear gradient and Color set to blue:
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A checkmark is used to depict the currently selected style within the drop down menu.

A style change will be seen instantaneously when a figure is selected. If figures have not been selected, the

style change will apply to all subsequently created figures.

Working with Linear Gradients

Click on a Gradient Handle to select a color from the color picker or click anywhere within the color slider to

add additional handles. The Gradient Handles can be moved to any desired position by clicking and dragging

to the right or left on the color slider.

More than one color can be added by setting each individual gradient handle to one of the desired colors. In the

example below, three gradient handles are used with these colors: white, blue, and green.
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Angle

Type in a value or use the incremental buttons to change the Angle of the linear gradient. This option remains

unavailable unless a figure has been selected within the Drawing Canvas. In the example below, a value of 75

has been entered for the angle.
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Reset Button

Click on the Reset Button to reset the angle back to zero and the gradient handles on the figure back to their

original position.

The Reset Button can also be used to reset the gradient handles on a figure(s) after they have been moved to

another location. In order for this to be seen, you must have the Gradient Locations option enabled within the

Bottom Bar.
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Once this option is enabled, you will be able to click and drag to move each gradient handle to another location

within a figure (see below).

After one or both gradient handles has been moved, click on the Reset Button to set the linear gradient handles

back to their original location.
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Swap Button

Click on the Swap Button to reverse the current color slider settings.

6.3.3.2. Radial Gradient
The Radial Gradient fill style option is located on the Fill tab in the Info portion of the Sidebar. This attribute
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transitions the fill from the specified start color to the specified end color by starting from the center of a

selected  or created figure(s) and then moving outward in a circular manner. The Fill  option must be enabled for

a change in this tab to be applied to currently selected or new figures. Click on the box next to the option name

to enable/disable it, as shown below:

Follow the steps below to set this attribute to Radial Gradient:

1

Select the Fill tab located in the Sidebar.

2

Click on the Fill Style drop down menu.
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3

Choose the Radial Gradient fill style.

4

The following example shows a rectangle with the Fill Style set to radial gradient and Color set to blue:

A checkmark is used to depict the currently selected style within the drop down menu.
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A style change will be seen instantaneously when a figure is selected. If figures have not been selected, the

style change will apply to all subsequently created figures.

Working with Radial Gradients

Click on a Gradient Handle to select a color from the color picker or click anywhere within the color slider to

add additional handles. The Gradient Handles can be moved to any desired position by clicking and dragging

to the right or left on the color slider.

More than one color can be added by setting each individual gradient handle to one of the desired colors. In the

example below, three gradient handles are used with these colors: white, blue, and green.
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Reset Button

The Reset Button can be used to reset the center point of the radial gradient after it has been moved. In order

for this to be seen, you must have the Gradient Locations option enabled within the Bottom Bar.

Once this option is enabled, you will be able to click and drag to move the center point to another location

within a figure (see below).

After the center point has been moved, click on the Reset Button to set the radial gradient back to its true

center point.



Page 387

TouchDraw for Mac

Swap Button

Click on the Swap Button to reverse the current color slider settings.
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6.3.4. Shadow Color
The Shadow Color of a selected figure can be changed to meet a desired preference. Follow the steps below to

alter the shadow color attribute:

In the Shadow tab of the Info portion of the Sidebar, click on the color well to bring up the standard OS X

color picker. If the color picker is already visible then TouchDraw will inform the color picker that it's value

and changes should be associated with the shadow color.

A color change will be seen instantaneously when a figure is selected. If no figures have been selected, the



Page 389

TouchDraw for Mac

color change will apply to all subsequently created figures.

Changes made to this attribute are only reflected on current or new figures within the drawing canvas when the

Shadow option has been enabled. Click on the box next to the shadow label to enable/disable this option. Refer

to the screenshots below:

The X Offset and Y Offset attributes set the offset of the shadow in the X axis and Y axis. Type a value in the

text field or use the "Up" or "Down" Buttons to alter the shadow offset for a figure(s). In the example below,

the X and Y Offset has been changed to 10 points.
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The Blur attribute sets the amount of blur applied to the shadow. Type in a number in the text field or use the

"Up" or "Down" Buttons to alter the Blur value for the shadow. In the example below, the Blur value has been

changed to 20 points.
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Use the Opacity slider, text field, or "Up" and "Down" Buttons to alter the opaqueness (opposite of

transparency) of a selected color. In the example below, the Opacity has been changed to 50.
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The Blending Mode drop-down menu can be used to set the style of blend applied to a figure(s). In the

example below, the Difference blending mode has been chosen.
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The following example shows a rectangle with the Shadow Color set to blue and the X/Y Offsets set to 10

points.
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6.3.5. Text Color
The Text Color of a selected figure can be changed to meet a desired preference. This attribute can be altered

in one of the following ways:

1

In the Text tab of the Info portion of the Sidebar, click on the color well to bring up the standard OS X color

picker. If the color picker is already visible then TouchDraw will inform the color picker that it's value and

changes should be associated with the text color.

2

Use the Text Color button located in the Format Bar.

A popup menu showing standard color choices will be shown after the Text Color button is pressed, as shown

in the image below.
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Click on a desired color to select it or click on the Show Colors button at the bottom to bring up the standard

OS X color picker. As with selecting the color well described in step 1, if the color picker is already visible

then TouchDraw will simply inform the color picker that it's value and changes should be associated with the

stroke color.

3

The example below shows a Text Figure that has been changed to a blue Font.

Note: A color change will be seen instantaneously when text is selected. If text has not been selected, the color

change will apply to all subsequent text entries.

6.3.6. Canvas Background Color
The Canvas Background Color can be changed to meet a desired preference. Follow the steps below to alter

this attribute:

In the Canvas tab of the Info portion of the Sidebar, click on the color well to bring up the standard OS X color
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picker . If the color picker is already visible then TouchDraw will inform the color picker that it's value and

changes should be associated with the canvas background color.

The image below shows the drawing canvas after the Canvas Background Color has been set to light blue.

A color change will be seen instantaneously when the transparent option is disabled. The drawing canvas will

continue to appear white if the transparent option has been enabled. Refer to the screenshots below:
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6.3.7. Standard Color Picker
The OS X Standard Color Picker is an available tool for setting figure, stroke, shadow, and text color for

objects within the drawing canvas. It can also be used to set the drawing canvas background color.

This standard Mac tool supplies five ways to select a color and set its associated attributes.

• Color Wheel Pane (as shown above)

• Sliders Pane

• Palette Picker

• Image Palette

• Crayon Color Box

The Color Wheel Pane allows for selection of a hue and the amount of saturation from a wheel. It contains a

slider bar to the right of the wheel for setting the brightness of a selected hue and an opacity slider at the

bottom for setting the degree of color transparency. The Sliders Pane can be used to set the degree of a hue,

the percentage of a particular color within a hue selection, or the percentage values for the selected hue's

saturation, brightness, and opacity attributes. Use the Palette Picker to select a hue from currently supported

palette groupings and to set its opacity. The Image Palette defaults to spectrum; however, an image can be

pulled in from any file and used for color selection. Use the Crayon Color Box to select a standard color and

alter its opacity value.
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The OS X Standard Color Pickercan be opened in one of the following ways:

1

Click on the View Menu and choose Show Colors.

2

Click on the color well of a desired attribute in the Sidebar.

3

Select a color well in the Format Bar and click on Show Colors.
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4

Use the Command-Ckeyboard shortcut.
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6.4. Handling Strokes
TouchDraw provides multiple options for altering the attributes of a stroke (line) for existing or new figures(s)

within the drawing canvas. Stroke attributes areaccessible through the Info of the Sidebar and can be used to

change:

• Stroke Size

• Start or End Scale

• Line or Endpoint Styles

• Line Caps

• Line Joins

• Line Location

• Line Colors

The Stroke Tab appears as shown below:

6.4.1. Stroke Visibility
The Stroke Visibility option is an On/Off toggle used to set the visibility of strokes/lines of a figure(s). If the

visibility option is turned off, the border/line of a selected or added figure(s) is not drawn at all. The Stroke

Visibility toggle is accessed by clicking on the Stroke Tab in the Sidebar, as shown below:



Page 401

TouchDraw for Mac

Click on the checkbox next to the Stroke label to enable or disable the Stroke Visibility option.

If Stroke Visibility is on, an outline around the figure will be present and if it is off and Fill Visibility is on, the

figure will appear with no border, as shown below:
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Note: Stroke attribute changes will not be reflected in a selected or added figure(s) until this option has been

enabled.

6.4.2. Stroke Style
The Stroke Style or line dash pattern and end decorations of a figure can be altered by clicking on the Stroke

Tab in the Sidebar, as shown below.

The Stroke Style of a line can also be changed by using the Format Bar.
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The Stroke Visibility option must be enabled for a Stroke Style change to appear in the Drawing Canvas.

To alter the Stroke Style of a currently selected figure(s) or new figure(s):

1

Click on the desired section (Start, Line, or End) of the Line Style section in the Stroke Tab.

2

Select a style from the Start,Line, or End drop-down menus. In this example, the _Start Stroke Style_is altered.

3

The new selection will appear in the Stroke Panel.
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4

For example, a Line with an arrowed Start and End Style and a Stroke Size of 3 would appear as shown below:

    Note: A line style change will be seen instantaneously when a stroke figure is selected. If no figures have

been selected, the line style change will apply to all subsequently created stroke figures.

6.4.3. Start/End Scale
The Start or End Scale for the Stroke Style of a figure can be altered by clicking on the Stroke Tab in the

Sidebar, as shown below.

https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/Line-Tool-Old.md


Page 405

TouchDraw for Mac

The Stroke Visibility option must be enabled for a Start/End Scale change to appear in the Drawing Canvas.

To alter the Start/End Scale of a currently selected figure(s) or new figure(s):

1

Click on the figure to make a selection and alter the start/end scale for a single figure or simply change the

value within Stroke Tab to change it for all new figures within the drawing.

2

The Start Scale can be used to change the size of the Start Line for a figure. Click on the text field to type in a

value or use the "Up" or "Down" Buttons to change the value by 1. In this example, the value has been changed

to 5.
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3

The figure will appear as shown below when the Start Scale has been altered.

4

The End Scale can be used to change the size of the End Line for a figure. Click on the text field to type in a

value or use the "Up" or "Down" Buttons to change the value by 1. In this example, the value has been changed

to 5.
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5

The figure will appear as shown below after both the Start and End Scale values have been changed.

6.4.4. Stroke Size
The Stroke Size of a figure (width of a stroke in pixels) can be altered by selecting the Stroke Tab in the

Sidebar, as shown below.
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The Stroke Size may also be altered through the Format Bar.

The Stroke Visibility option must be enabled for a Stroke Size change to appear in the Drawing Canvas.

To alter the Stroke Size, click on the "Up" or "Down" arrow buttons next to the text entry field to increase or

decrease the size by increments of one or click on the text entry field to open the text editor and type in a value.

The Stroke Size attribute provides the ability to convert other measurements (Pixels, Millimeters, Centimeters,

Inches, Feet, Meters, Kilometers, Yards, etc.) into points.



Page 409

TouchDraw for Mac

For example, if 1 centimeter (cm) is typed into this field, it will automatically be converted to its equivelent in

points when the Enter Key is pressed or you click in another area of the application.

If 25 millimeters (25 mm) is entered as the Stroke Size, it will be converted to 70.866 points.
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Note: A size change will be seen instantaneously when a stroke figure is selected. If no figures have been

selected, the size change will apply to all subsequently created stroke figures.

6.4.5. Line Cap
The Line Cap (Butt, Rounded, or Square) of a figure can be altered by clicking on the Stroke Tab in the

Sidebar, as shown below.

The Stroke Visibility option must be enabled for a Line Cap change to appear in the Drawing Canvas.

To alter the **Line Cap Type,**click on one of the choices (Butt, Rounded, or Square) under the line cap

heading. The selection will appear in dark grey as a visual indicator of the currently active line cap type.
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For example, the image below shows what a Line would look like with a Butt, Rounded, and Square Line

Cap.

A line cap change will be seen instantaneously when a stroke figure is selected. If no figures have been

selected, the line cap change will apply to all subsequently created stroke figures.

6.4.6. Line Join
The Line Join (Mitered, Rounded, or Bevelled) of a figure can be altered by clicking on the Stroke Tab in the

Sidebar, as shown below.

https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/Line-Tool-Old.md
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The Stroke Visibility option must be enabled for a Line Join change to appear in the Drawing Canvas.

To alter the Line Join Type, click on one of the choices (Mitered, Rounded, or Bevelled) under the line join

heading. The selection will appear in dark grey as a visual indicator of the currently active line join type.
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The image below shows what a Square would look like with a Mitered,Rounded, and Bevelled Line Join.

A line join change will be seen instantaneously when a stroke figure is selected. If no figures have been

selected, the line cap change will apply to all subsequently created stroke figures.

6.4.7. Line Location
The Line Location of a figure can be altered by clicking on the Stroke Tab in the Sidebar, as shown below.

The Stroke Visibility option must be enabled for a Line Location change to appear in the Drawing Canvas.
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To alter the Line Location, click on one of the choices under the line location heading. The selection will

appear in dark grey as a visual indicator of the currently active line location setting.

The example below shows what a Rectangle looks like when each Line Location choice is selected: Center,

Outside, and Inside.

A line location change will be seen instantaneously when a stroke figure is selected. If no figures have been

selected, the line join change will apply to all subsequently created stroke figures.

6.4.8. Miter Limit
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The Miter Limit attribute can be used to set the angle of connected line segments where they join. The join

will be more jagged or sharp depending on the entered or selected value. Miter limits are relative to stroke size

and become increasingly noticeable for line segments with increased thickness. The Miter Limit of a stroke (or

line) can be altered by selecting the Stroke Tab in the Sidebar, as shown below.

The Stroke Visibility option must be enabled for a Miter Limit change to appear in the drawing canvas.

To alter the Miter Limit, click on the "Up" or "Down" arrow buttons next to the text entry field to increase or

decrease the miter limit by increments of one or click on the text entry field to open the text editor and type in a

value.
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The Miter Limit attribute provides the ability to convert other units of measurement (Pixels, Millimeters,

Centimeters, Feet, Meters, Kilometers, Yards, etc.) into points.

For example, if 10 millimeters (mm) is typed into this field, it will automatically be converted to its equivelent

in points when the Enter Key is pressed or you click in another area of the application.

If 2 centimeters (2 cm) is entered as the Miter Limit, then it will be converted to 56.693 points.
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A miter limit change will be seen instantaneously when a stroke figure is selected. If no figures have been

selected, the line cap change will apply to all subsequently created stroke figures.

6.4.9. Line Color
A figure must be selected to alter the Line Color of a stroke. In the Stroke Tab of the Sidebar, as shown below.
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The Stroke Visibility option must be enabled for a Line Color change to appear in the drawing canvas.

To alter the Line Color of a selected figure(s) or new figures, click on the color well to bring up the standard

OS X color picker. If the color picker is already visible then TouchDraw will inform the color picker that it's

value and changes should be associated with the line color.

Select a color from the standard OS color picker and then close it.
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The example below shows a figure with a white fill, stroke size of 2, and the line color set to blue.

Note: A color change will be seen instantaneously when a figure is selected. If a figure has not been selected,

the color change will apply to all subsequent text entries.
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6.5. Handling Text
TouchDraw provides multiple options for changing the text attributes of figures that are capable of displaying

text. The Text Tool can be used to add a text box anywhere on the Drawing Canvas. Text may also be added as

part of these shapes:

• Rectangles

• Rounded Rectangles

• Ovals

• Circles

• Polygons

• Closed Paths (Custom Shapes)

The attributes for entered text can be changed to meet specific preferences and include:

• Font Family

• Font Size

• Font Style

• Font Color

• Text Alignment

• Text Margin

Variables may also be used to input a certain pre-formatted value as part of the displayed text within a figure.

6.5.1. Editing Text
The Text Editor Popover must be opened to edit the text content of a selected figure. Double click on a figure

to bring up the Text Editor.
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Entered text will be reflected within the drawing view in realtime to provide instant feedback regarding how it

will appear, wrap, etc.. within the figure.

Click in any location outside of the supplied popover to dismiss the editor.
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6.5.2. Font Family
A figure must be selected to alter the Font Family of entered text. Use one of the following methods to change

the font family for a selected figure(s):

1

Select the Text tab located in the Info portion of the Sidebar and click on the Font Family drop down menu.

Click on a family name in the provided list to make a selection and the drop down menu will close

automatically. The selection will appear in the Font Family section of the Text Tab, as shown below.
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In the above example, the Font Family was changed from Helvetica to Times New Roman.

2

Select the Font Family drop down menu located in the Format Bar.

Click on a family name in the provided list to make a selection and the drop down menu will close

automatically. The selection will appear in the Font Family section of the Format Bar and will be applied to

the selected figures as well as new text additions.

In the above example, the Font Family was changed from Helvetica to Times New Roman.

The currently applied Font Family will have a checkmark next to its name, as shown below.

6.5.3. Font Size
A figure must be selected to alter the Font Size of entered text. Use one of the following methods to change the

font size for a selected figure(s):

1

Click on the Text tab located in the Info portion of the Sidebar.
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Use the "up" or "down" selection buttons to alter the size or click on the actual field to make a keyboard entry.

2

Click on the Font Size drop down menu located in the Format Bar. Use the drop down size menu button or

click on the actual field to make a keyboard entry.

The Font Size attribute provides the ability to convert a different unit of measurement (Pixels, Millimeters,

Centimeters, Meters, Kilometers, Feet, etc.) into their equivelent measurement in points. To use the conversion

feature, simply type in the value for the unit of measurement and its abbreviation (px, mm, cm, m, km, ft, etc.)

and then press the Enter Key or click in another area of the application.

In the example below, the Font Size value has been entered as 2 centimeters (cm), which is equivelent to

56.693 points.
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If the Font Size is entered as 25 millimeters (25 mm), it is converted to 70.866 points.

6.5.4. Font Styles
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A figure must be selected to alter the Font Style of entered text. Use one of the following methods to change

the font style for a selected figure(s):

1

Select the Text tab located in the Info portion of the Sidebar. Click on the Font Style selection drop down

menu.

Click on a style to make a selection and the drop down menu will close automatically. The selection will

appear in the Font Style section of the Text Tab, as shown below.

In the above example, the Font Style was changed from Regular to Bold.
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2

Select the Font Style drop down menu located in the Format Bar.

Click on a style to make a selection and the drop down menu will close automatically.

The selection will appear in the Font Style section of the Format Bar and will be applied to the selected figures

as well as new text additions. In this example, the Font Style was changed from Regular to Bold.

The currently selected style will have a checkmark next to its name, as shown below.

6.5.5. Font Color
A figure must be selected to alter the Font Color of entered text. Use one of the following methods to change

the font color for a selected figure(s):

1

In the Text tab of the Info portion of the Sidebar, click on the color well to bring up the standard OS X color

picker. If the color picker is already visible then TouchDraw will inform the color picker that it's value and

changes should be associated with the font color.
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2

Use the Text Color button located in the Format Bar.

A popup menu showing standard color choices will be shown after the Text Color button is pressed, as shown

in the image below.
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Click on a desired color to select it or click on the Show Colors button at the bottom to bring up the standard

OS X color picker. As with selecting the color well described in step 1, if the color picker is already visible

then TouchDraw will simply inform the color picker that it's value and changes should be associated with the

stroke color.

The selection will appear in the Text Color section of the Format Bar.

3

The example below shows a figure with text that has been changed from black to blue.
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    Note: A color change will be seen instantaneously when a figure is selected. If a figure has not been

selected, the color change will apply to all subsequent text entries.

6.5.6. Text Alignment
The Text Alignment option alters the vertical and horizontal positioning of text within it's bounding box. A

figure must be selected to alter the alignmentpositionof entered text. To change the text alignment position

within a selected figure(s):

1

Select the Text tab located in the Info portion of the Sidebar.

2

Click on a horizontal or vertical alignment button to make a selection.
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3

The alignment of text can also be changed by using the Format Bar.

The currently selected horizontal and vertical alignment choices will appear dark gray, as shown below.

The following example shows the alteration of text within a figure from a left horizontal alignment to a right

horizontal alignment.
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6.5.7. Text Margin
A figure must be selected to alter the Text Margin of entered text. Click on the Text tab located in the Info

portion of the Sidebar. Use the "up" or "down" selection buttons to alter the margin value or click on the actual

field to make a keyboard entry.

The Text Margin attribute provides the ability to convert alternative units of measurement (Pixels,

Millimeters, Centimeters, Meters, Kilometers, Feet, etc.) into their equivelent measurement in points. To use

the conversion feature, simply type in a number value and the abbreviation for the desired unit of measurement
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(px, mm, cm, m, km, ft, etc.) and then press the Enter Key  or click in another area of the application.

In the example below, the Text Margin value has been entered as 1 centimeter (1 cm), which is equivelent to

28.346 points.

In this example, the Text Margin is entered as 5 millimeters (5 mm) and is converted to 14.173 points.
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If you enter 1 inch (1 in) as the Text Margin, then it will be converted to 72 points (1 inch = 72 points).

6.5.8. Adding Variables to Text
A Variable can be added to text within a figure through the Text Editor Popup Window by hand keying the

desired variable as part of the text or completing an insertion with the Variable Popup Menu.

On a subsequent page, there is a list of available variables.

In the following example, the Area variable is included as part of the selected rectangle's text.
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Double Click on a desired figure to open the Text Editor.

Begin entering text and then click on the Variable Popup Menu to select a currently supported variable from

the provided list.

The variable will appear in the Text Editor Popup Window after it has been selected.
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The selected variable shows as the actual value within the selected figure as it is entered.

The final text within the selected figure appears as shown below.

6.5.8.1. Available Variables
TouchDraw supports inserting Variables into a text area. Entered variables are replaced with the actual value
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when the drawing is rendered. The table below provides a list of currently supported Text Variables :

Variable Name Variable Type Description

Pre-formatted The minimum X-axis position of the figure bounds + the units

abbreviation.

Pre-formatted The maximum X-axis position of the figure bounds + the units

abbreviation.

Pre-formatted The minimum Y-axis position of the figure bounds + the units

abbreviation.

Pre-formatted The maximum Y-axis position of the figure bounds + the units

abbreviation.

Pre-formatted The length of the line (if the text is added to a line or line

connection) + the units abbreviation.

Pre-formatted The width of the figure bounds + the units abbreviation.

Pre-formatted The height of the figure bounds + the units abbreviation.

Pre-formatted The area of the figure + the units abbreviation.

Decimal The decimal representation (to 4 decimal points) of one of the 7

variables above where xxxx is the name of the variable.  For

example, {DLength} would return the decimal value of a line

length.

Fractional The fractional representation of one of the 7 variables above

where xxxx is the name of the variable.  For example,

{FLength} would return the fractional value of a line length.

Pre-formatted The name of the current drawing.

Pre-formatted The abbreviation of the unit of measure specified for the

drawing.

Pre-formatted The full name of the unit of measure specified for the drawing.

Pre-formatted The name of the layer that the figure is currently in.

Date The current date.
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6.5.8.2. Formatting Date Variables
By default, the {Date} variable will expand into a date formatted in the mm/dd/yyyy (or dd/mm/yyyy for

non-US locales) format as shown in the screenshot below:

TouchDraw allows the exact formatting style to be specified in scenarios where the date must be formatted

differently than the default setting. Use one of the following {Date:format} options to insert a desired

format. Refer to the sample table below:

Variable Description Examples

{Date:d} Default - Short

Date Formatting

6/15/2009 (US)   15/06/2009 (France)   2009/06/15 (Japan)

{Date:D} Long Date

Formatting

Monday, June 15, 2009 (US)   15      2009  . (Russia)   Montag,

15. Juni 2009 (Germany)

{Date:f} Full Date/Time

(short time)

Formatting

Monday, June 15, 2009 1:45 PM (US)   den 15 juni 2009 13:45

(Sweden)          , 15         2009 1:45    (Greece)

{Date:F} Full Date/Time

(long time)

Formatting

Monday, June 15, 2009 1:45:30 PM (US)   den 15 juni 2009

13:45:30 (Sweden)          , 15         2009 1:45:30    (Greece)

{Date:g} General

Date/Time (short

6/15/2009 1:45 PM (US)   15/06/2009 13:45 (Spain)

2009/6/15 13:45 (China)
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Variable Description Examples

time) Formatting

{Date:G} General

Date/Time (long

time) Formatting

6/15/2009 1:45:30 PM (US)   15/06/2009 13:45:30 (Spain)

2009/6/15 13:45:30 (China)

{Date:m} General

Month/Day

Formatting

June 15 (US)   juni 15 (Denmark)   Juni 15 (Indonesia)

{Date:M} General

Month/Day

Formatting

June 15 (US)   juni 15 (Denmark)   Juni 15 (Indonesia)

{Date:o} Round-Trip

Date/Time

Formatting

06-15T13:45:30.0900000

{Date:O} Round-Trip

Date/Time

Formatting

06-15T13:45:30.0900000

{Date:r} RFC1123

Formatting

15 Jun 2009 20:45:30 GMT

{Date:R} RFC1123

Formatting

15 Jun 2009 20:45:30 GMT

{Date:s} Sortable

Date/Time

Formatting

2009-06-15T13:45:30

{Date:t} Short Time

Formatting

1:45 PM (US)   13:45 (Croatia - Hrvatska)   01:45 (Egypt)

{Date:T} Long Time

Formatting

01:45:30 PM (US)   13:45:30 (Croatia - Hrvatska)   01:45:30

(Egypt)

{Date:u} Universal Sortable

Date/Time

Formatting

2009-06-15 20:45:30Z
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Variable Description Examples

{Date:U} Universal Full

Date/Time

Formatting

Monday, June 15, 2009 8:45:30 PM (US)   den 15 juni 2009

20:45:30 (Sweden)          , 15         2009 8:45:30    (Greece)

{Date:y} Year Month

Formatting

June, 2009 (US)   juni 2009 (Denmark)   Juni 2009 (Indonesia)

{Date:Y} Year Month

Formatting

June, 2009 (US)   juni 2009 (Denmark)   Juni 2009 (Indonesia)

In addition to the formatting variables above, you can also use the variable below to create your own custom

date formats. For example, we could do something like the following

{Date:MM/dd/yy H:mm:ss}

which would create something like:

06/10/12 15:24:16

Variable Description Examples

{Date:d} The day of the month, from

1 through 31.

6/1/2009 1:45:30 PM -> 1   6/15/2009 1:45:30 PM ->

15

{Date:dd} The day of the month, from

01 through 31.

6/1/2009 1:45:30 PM -> 01   6/15/2009 1:45:30 PM

-> 15

{Date:ddd} The abbreviated name of the

day of the week.

6/15/2009 1:45:30 PM -> Mon (US)   6/15/2009

1:45:30 PM ->    (Russia)   6/15/2009 1:45:30 PM ->

lun. (France)

{Date:dddd} The full name of the day of

the week.

6/15/2009 1:45:30 PM -> Monday (US)   6/15/2009

1:45:30 PM ->             (Russia)   6/15/2009 1:45:30

PM -> lundi (France)

{Date:f} The tenths of a second in a

date and time value.

6/15/2009 13:45:30.617 -> 6   6/15/2009

13:45:30.050 -> 0
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Variable Description Examples

{Date:ff} The hundredths of a second

in a date and time value.

6/15/2009 13:45:30.617 -> 61   6/15/2009

13:45:30.005 -> 00

{Date:fff} The milliseconds in a date

and time value.

6/15/2009 13:45:30.617 -> 617   6/15/2009

13:45:30.0005 -> 000

{Date:ffff} The ten thousandths of a

second in a date and time

value.

6/15/2009 13:45:30.6175 -> 6175   6/15/2009

13:45:30.00005 -> 0000

{Date:fffff} The hundred thousandths of

a second in a date and time

value.

6/15/2009 13:45:30.61754 -> 61754   6/15/2009

13:45:30.000005 -> 00000

{Date:ffffff} The millionths of a second

in a date and time value.

6/15/2009 13:45:30.617542 -> 617542   6/15/2009

13:45:30.0000005 -> 000000

{Date:fffffff} The ten millionths of a

second in a date and time

value.

6/15/2009 13:45:30.6175425 -> 6175425   6/15/2009

13:45:30.0001150 -> 0001150

{Date:F} If non-zero, the tenths of a

second in a date and time

value.

6/15/2009 13:45:30.617 -> 6   6/15/2009

13:45:30.050 -> (no output)

{Date:FF} If non-zero, the hundredths

of a second in a date and

time value.

6/15/2009 13:45:30.617 -> 61   6/15/2009

13:45:30.005 -> (no output)

{Date:FFF} If non-zero, the milliseconds

in a date and time value.

6/15/2009 13:45:30.617 -> 617   6/15/2009

13:45:30.0005 -> (no output)

{Date:FFFF} If non-zero, the ten

thousandths of a second in a

date and time value.

6/1/2009 13:45:30.5275 -> 5275   6/15/2009

13:45:30.00005 -> (no output)

{Date:FFFFF} If non-zero, the hundred

thousandths of a second in a

date and time value.

6/15/2009 13:45:30.61754 -> 61754   6/15/2009

13:45:30.000005 -> (no output)

{Date:FFFFFF} If non-zero, the millionths 6/15/2009 13:45:30.617542 -> 617542   6/15/2009
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Variable Description Examples

of a second in a date and

time value.

13:45:30.0000005 -> (no output)

{Date:FFFFFFF} If non-zero, the ten

millionths of a second in a

date and time value.

6/15/2009 13:45:30.6175425 -> 6175425   6/15/2009

13:45:30.0001150 -> 000115

{Date:g},

{Date:gg}

The period or era. 6/15/2009 1:45:30 PM -> A.D.

{Date:h} The hour, using a 12-hour

clock from 1 to 12.

6/15/2009 1:45:30 AM -> 1   6/15/2009 1:45:30 PM

-> 1

{Date:hh} The hour, using a 12-hour

clock from 01 to 12.

6/15/2009 1:45:30 AM -> 01   6/15/2009 1:45:30 PM

->

{Date:H} The hour, using a 24-hour

clock from 0 to 23.

6/15/2009 1:45:30 AM -> 1   6/15/2009 1:45:30 PM

-> 13

{Date:HH} The hour, using a 24-hour

clock from 00 to 23.

6/15/2009 1:45:30 AM -> 01   6/15/2009 1:45:30 PM

-> 13

{Date:m} The minute, from 0 through

59.

6/15/2009 1:09:30 AM -> 9   6/15/2009 1:09:30 PM

-> 9

{Date:mm} The minute, from 00

through 59.

6/15/2009 1:09:30 AM -> 09   6/15/2009 1:09:30 PM

-> 09

{Date:M} The month, from 1 through

12.

6/15/2009 1:45:30 PM -> 6

{Date:MM} The month, from 01 through

12.

6/15/2009 1:45:30 PM -> 06

{Date:MMM} The abbreviated name of the

month.

6/15/2009 1:45:30 PM -> Jun (US)   6/15/2009

1:45:30 PM -> juin (France)   6/15/2009 1:45:30 PM

-> Jun (South Africa)

{Date:MMMM} The full name of the month. 6/15/2009 1:45:30 PM -> June (US)   6/15/2009

1:45:30 PM -> juni (Denmark)   6/15/2009 1:45:30

PM -> uJuni (South Africa)
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Variable Description Examples

{Date:s} The second, from 0 through

59.

6/15/2009 1:45:09 PM -> 9

{Date:ss} The second, from 00

through 59.

6/15/2009 1:45:09 PM -> 09

{Date:t} The first character of the

AM/PM designator.

6/15/2009 1:45:30 PM -> P (US)   6/15/2009 1:45:30

PM ->   (Japan)   6/15/2009 1:45:30 PM -> (France)

{Date:tt} <The AM/PM designator. 6/15/2009 1:45:30 PM -> PM (US)   6/15/2009

1:45:30 PM ->    (Japan)   6/15/2009 1:45:30 PM ->

(France)

{Date:y} The year, from 0 to 99. 1/1/0001 12:00:00 AM -> 1   1/1/0900 12:00:00 AM

-> 0   1/1/1900 12:00:00 AM -> 0   6/15/2009 1:45:30

PM -> 9

{Date:yy} The year, from 00 to 99. 1/1/0001 12:00:00 AM -> 01   1/1/0900 12:00:00 AM

-> 00   1/1/1900 12:00:00 AM -> 00   6/15/2009

1:45:30 PM -> 09

{Date:yyy} The year, with a minimum

of three digits.

1/1/0001 12:00:00 AM -> 001   1/1/0900 12:00:00

AM -> 900   1/1/1900 12:00:00 AM -> 1900

6/15/2009 1:45:30 PM -> 2009

{Date:yyyy} The year as a four-digit

number.

1/1/0001 12:00:00 AM -> 0001   1/1/0900 12:00:00

AM -> 0900   1/1/1900 12:00:00 AM -> 1900

6/15/2009 1:45:30 PM -> 2009

{Date:yyyyy} The year as a five-digit

number.

1/1/0001 12:00:00 AM -> 00001   6/15/2009 1:45:30

PM -> 02009

{Date:z} Hours offset from UTC,

with no leading zeros.

6/15/2009 1:45:30 PM -07:00 -> -7

{Date:zz} Hours offset from UTC,

with a leading zero for a

single-digit value.

6/15/2009 1:45:30 PM -07:00 -> -07

{Date:zzz} Hours and minutes offset

from UTC.

6/15/2009 1:45:30 PM -07:00 -> -07:00
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Variable Description Examples

{Date::} The time separator. 6/15/2009 1:45:30 PM -> : (US)   6/15/2009 1:45:30

PM -> . (Italy) 6/15/2009 1:45:30 PM -> : (Japan)

{Date:/} The date separator. 6/15/2009 1:45:30 PM -> / (US)   6/15/2009 1:45:30

PM -> - (Algeria)

6.5.8.3. Formatting Decimal
Variables
The Decimal Variable can be inserted as part of entered text to show the value of another variable in decimal

form within the text of a figure. Refer to the Text Variable Table for a list of all supported variables.

Any of the listed pre-formatted numerical variables can have a "D" placed in front of it (as long as they

correspond with the type of selected figure) to insert the value as a decimal. The following screenshot shows an

example of this:

Both the D and first letter of the entered variable must be capitalized for the value to appear in the selected

figure.

By default, the decimal value will be presented with at most 4 digits after the decimal point. An alternative

formatting style can be specified by using the {Dxxxx:format} pattern. The table below outlines the

options for formatting the decimal value.
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Format Specifier Name Description Examples

0 Zero Placeholder Replaces the zero with the corresponding

digit if one is present, otherwise zero

appears in the result.

Width =

1234.5678

Variable =

Result = 01234

Width = 0.45678

Variable =

Result = 0.46

# Digit Placeholder Replaces the pound sign with the

corresponding digit if one is present;

otherwise, no digit appears in the result

string.

Width =

1234.5678

Variable =

{DWidth:#####}

Result = 1234

Width = 0.45678

Variable =

{DWidth:#.##}

Result = .46

. Decimal Point Determines the location of the decimal

separator in the result string.

Width = 0.45678

Variable =

Result (US) =

0.46  Width =

0.45678   Variable

=    Result

(Germany) = 0,46

, Group Separator Inserts a group separator character

between each group.

2147483647 ("#

#,#") =

2,147,483,647

(US)  2147483647

("# #,#") =

2.147.483.647

(Estonia)

, Number Scaling Divides a number by 1000 for specified

commas.

2147483647

("#,#,,") = 2,147
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Format Specifier Name Description Examples

(US)  2147483647

("#,#,,") =   2.147

(Estonia)

% Percent

Placeholder

Multiplies a number by 100 and inserts a

localized percentage symbol in the result

string.

0.03697

("%,#0.00") =

%36.97 (US)

0.03697

("%,#0.00") =

%36,97 (Greece)

0.03697 ("#

#.0%") = 37.0%

(US)  0.03697 ("#

#.0%") = 37,0%

(Greece)

‰ Per Mille

Placeholder

Multiplies a number by 1000 and inserts

a localized per mille symbol in the result

string.

0.03697 ("#

0.00‰") =

36.97‰ (US)

0.03697 ("#

0.00‰") =

36,97‰ (Russia)

EO, E+0, E-0, e0,

e+0, e-0<

Exponential

Notation

Zero - Formats in exponential notation.

E/e - Indicates case of the exponent

symbol in the resulting string.  Plus Sign

- Indicates that the sign character

precedes the exponent.  Minus Sign -

Indicates that a sign character precedes

only negative exponents.  The number of

zeros following the E/e symbol

determines the minimum number of

digits in the exponent (Must have at least

one zero).

987654 ("#

0.0e0") = 98.8e4

1503.92311 ("0.0

# # e +00") =

1.504e+03

18901385E-16

("0.0e +00") =

1.9e-16

'string', "string" Literal String

Delimiter

Indicates that the enclosed characters

should be copied to the result string

68 ("# ' degrees'")

= 68 degrees  68
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Format Specifier Name Description Examples

without changes. ("# ' degrees'") =

68 degrees

; Section Separator Defines sections using separate format

strings for positive, negative, and zero

numbers.

12.345 ("# 0.0#;

(#0.0#); -\0-") =

12.35  0 ("# 0.0#;

(#0.0#); -\0-") =

-0-  -12.345 ("#

0.0#; (#0.0#);

-\0-") = (12.35)

12.345 ("# 0.0#;

(#0.0#)") = 12.35

0 ("# 0.0#;

(#0.0#)") = 0.0

-12.345 ("# 0.0#;

(#0.0#)") = (12.35)

Other All Other

Characters

The character is copied to the result

string unchanged.

68 (" # °") = 68 °

6.5.8.4. Formatting Fractional
Values
The Fractional Variable can be inserted as part of entered text to show the value of another variable in

fractional form within the text of a figure. Refer to the Text Variable Table for a list of all supported variables.

Any of the listed pre-formatted numerical variables can have an "F" placed in front of it (as long as they

correspond with the type of selected figure) to insert the value as a fraction. The following screenshot shows an

example of this:
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Additional format specifiers may be added at the end of the variable to alter the number of shown placeholders

of a fractional value or to round the supplied value. Rounding is accomplished by placing a semi-colon (:) after

the variable followed by either #.### or #.000. The screenshots below are two examples of ways to round a

fractional value in the Text Editor.

Both the F and first letter of the entered variable must be capitalized for the value to appear in the selected

figure.
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By default, the numerator and denominator making up the fractional value will be presented with at most three

digits. An alternative formatting style can be specified by using the {Fxxxx:format} pattern. The table

below outlines the options for formatting the fractional value.

Format Specifier Name Description Examples

0 Zero Placeholder Replaces the zero with the

corresponding digit if one is

present, otherwise zero

appears in the result.

Length = 4 148/249   Variable

=    Result = 5      Length = 4

148/249   Variable =    Result =

4 63/100

# Digit Placeholder Replaces the pound sign

with the corresponding digit

if one is present; otherwise,

no digit appears in the

result string.

Length = 4 148/249   Variable =

{FLength:#####}   Result =

5      Length = 4 148/249

Variable = {FLength:#.##}

Result = 4 63/100

. Decimal Point Determines the location of

the fractional separator in

the result string.

Length = 4 148/249   Variable

=    Result (US) = 4 63/100

Other All Other

Characters

The character is copied to

the result string unchanged.

68 (" # °") = 68 °
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6.6. Handling Paths
TouchDraw supplies multiple actions for altering handles or segments within a created path. A handle may be

inserted or deleted at any point within the path and a figure can be split at a selected handle. Segments may be

removed from a figure or converted to a line, quadratic curve, or cubic curve segment by adding or deleting

corresponding control points. These additional actions are available for altering an existing figure:

• Opening a Path

• Closing a Path

• Joining Lines and Paths

• Trimming Lines and Paths

• Splitting Segments

• Creating and Separating Compound Paths

• Conversion of Shape or Text Figure(s) to Paths

A control point is displayed in gray when it has not been used and is referred to as a "phantom" control point.

This characteristic provides a hint to the TouchDraw application that it should function as a control point in

scenarios where the next drawn segment is a curve. A few basic actions can be used to alter the "phantom"

control point position as a path is edited. Refer to the sections below to learn more about each available action.

Click/Drag

A Click/Drag combination on any position in the drawing canvas creates the end handle of a curve segment in

relevance to the current "phantom" control point position. The "phantom" control point is re-positioned in

accordance to the newly created end handle while this action occurs.
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Option/Click

An Option/Click combination allows the "phantom" control point position to be set to a desired location on the

drawing canvas after a curve segment has been created.

Option/Click/Drag
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An Option/Click/Drag combination allows the "phantom" control point to be dragged to any point on the

drawing canvas and changes a corner point back to a smooth curve after a curve segment has been created.

6.6.1. Opening a Path
TouchDraw supplies options for opening and closing an existing path. A path can be opened to make individual

alterations such as segment additions. Follow the steps below to open a currently closed path:

1

Select the path to be opened.

2

Select the Modify Menu and choose Open Path.

3

The end/start handle of the closed path is separated into two individual handles. Once a path has been opened,

the connecting segments are treated as individual path segments. They can be moved or expanded to any point

on the drawing canvas, have handles added, be converted to a quadratic or curve segment, and be combined
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with additional paths.

6.6.2. Closing a Path
The Close Path option draws a straight line segment from the last segment end handle to the path start handle

to close an open path. Follow the steps below to close a currently open path:

1

Select the path to be closed.

2

Select the Modify Menu and choose Close Path.
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3

A straight line segment will be drawn from the last segment end point to the start handle of the chosen path.

    Note: A straight line segment can be converted to a quadratic or cubic curve segment by using the contextual

menu.

6.6.3. Joining Lines and Paths
The Join Lines/Paths option allows the intersecting end points of two or more selected lines or paths to be

joined to form a single path. A minimum of two intersecting lines or paths must be selected for a join to occur.

Follow the steps below to join two line end points:

1

Create two lines on the drawing canvas using the Line Tool and then select both line figures by holding down

the Shift Key while clicking.
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2

Select the Modify Menu and choose Join Lines/Paths.

3

The line end points are joined to create two path segments with corresponding end points (orange), a start

handle (orange circle with white center), and a rotation handle (red). To learn more about the types of handles

used within TouchDraw, refer to the handles reference table.
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Additional lines can be included as part of the join by adding another line object and repeating the above steps.

Two or more path end points may also be combined with the Join Lines/Paths menu option. Follow the steps

below to join two path end points:

1

Create two paths with at least one shared segment end point on the drawing canvas using the Path Tool and

then select both paths by holding down the Shift Key while clicking.



Page 457

TouchDraw for Mac

2

Select the Modify Menu and choose Join Lines/Paths.

3

As shown below, the intersecting end points are joined to form a single segment end point (orange) and a new

start point handle (orange with white dot) is added to the beginning of the first selected path to visually indicate

the formation of a single path. To learn more about the types of handles used within TouchDraw, refer to the

handles reference table.
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    Note: Intersecting path and line end points can be joined in the same manner as shown above.

6.6.4. Trimming Lines and Paths
The Trim Lines/Paths option trims a line or path when it intersects near it's end with another shape or line.

TouchDraw considers "near" to be when an intersection is within the first or last eighth (1/8th) of the line. If

the intersection is within the middle 6/8ths, then the line is not trimmed.

Follow the steps below to trim the ends of intersecting lines or paths:

1

Select the items to be trimmed.

2

Select the Modify Menu and choose Trim Lines/Paths.
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3

All lines or paths intersecting within the last 1/8th are trimmed. In this example, the additional portions of the

path extending past the straight line are trimmed.

6.6.5. Splitting Segments
The segments of a path can be split into individual segments. Follow the steps below to Split All Segments

within a selected path(s):
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1

Click on the path to be split.

2

Select the Modify Menu and choose Split All Segments.

3

As shown below, specific visual indicators are changed to show that all segments have been separated within a

path and are able to be moved or altered as individual objects. Segment end point handles (orange) are changed

to a bounds handle (blue) The start handle (orange with white center) remains at one end of each split segment

since they are still considered by the application to be a path and the control points (green) are left untouched to

allow for alterations to existing quadratic or cubic curve segments. To learn more about handles, refer to the

handles reference table.
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4

Click on a bounds handle (blue) to move or resize a segment. Attribute alterations are made just as with any

other created figure on the drawing canvas.

    Note: The Join LInes/Paths option can be used to connect segments after changes have been made.

6.6.6. Creating a Compound Path
The Make Compound Path option can be used to combine two or more paths into one figure (compound path)

that shares the same attributes and is treated as one object. At least two paths must be selected for this option to

be available. Follow the steps below to create a compound path:

1

Select the paths to be combined.
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2

Select the Modify Menu and choose Make Compound Path.

3

The two paths are combined to form a compound path with shared bounds handles (blue) and a shared rotation

handle (red). Attribute changes now affect both paths as if they were a single path. For example, if the fill color

is changed to red, all paths included in the compound path are altered to have this attribute. Refer to the images
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below:

4

If the top handle of the triangle is dragged into the other compound figure, the intersecting portion of these two

paths will appear in white.
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5

An attribute change of stroke color to blue with a stroke size increase alters the attribute for every segment in

the compound path.

6

The addition of a shadow with a rotation angle of twenty degrees would result in the image below.

6.6.7. Separating a Compound Path
The Separate Compound Path option separates a compound path into it's individual paths. Follow the steps

below to separate a compound path:

1

Select the compound path.
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2

Select the Modify Menu and choose Separate Compound Path.

3

The previously combined paths are now two individual paths, which can be altered separately.
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4

Attribute changes will be applied to the selected path only rather than both paths. For example, if the fill color

of the bottom path is changed to black, the upper path remains red. Refer to the image below:

6.6.8. Converting Shapes to Paths
The Convert Shape to Path option allows a selected shape(s) on the drawing canvas to be converted into a

path figure. Follow the steps below to convert a shape to a path:

1

Select the shape to be converted.
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2

Select the Modify Menu and choose Convert Shape to Path.

3

Each individual segment used to create the shape will be converted into a path segment with corresponding

segment end point handles (orange). A start handle (orange with white dot) shows the initial starting point of

the path. New bounds handles (blue) are assigned in relation to the created path and control point handles

(green) are added to each curved segment.
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4

Any attribute changes available for a path can be performed on the converted object. For example, the upper

right curve of the rounded rectangle can be dragged to another location to alter its size or shape. In the image

below, one control point is moved upward and the other is moved to the right to alter the path figure.



Page 469

TouchDraw for Mac

5

Perform a Click/Drag combination on one of the bounds handles (blue) to alter the size of the path.

6

Perform a Click/Drag combination on a segment end point handle (orange) to alter the size of individual path

segments. In the image below the circled segment end point handle is dragged to the left and downward within

the path object to create the shown change.
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Note: Refer to the handles reference table to learn more about individual handles used within TouchDraw.

Additional information about altering paths can be found in the handling paths section of this documentation.

6.6.9. Converting Shapes to Paths
New
The Convert Shape to Path option allows a selected shape(s) on the drawing canvas to be converted into a

path figure. Follow the steps below to convert a shape to a path:

1

Select the shape to be converted.
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2

Select the Modify Menu and choose Convert Shape to Path.

3

Each individual segment used to create the shape will be converted into a path segment with corresponding

segment end point handles (orange). A start handle (orange with white dot) shows the initial starting point of

the path. New bounds handles (blue) are assigned in relation to the created path and control point handles

(green) are added to each curved segment.
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4

Any attribute changes available for a path can be performed on the converted object. For example, the upper

right curve of the rounded rectangle can be dragged to another location to alter its size or shape. In the image

below, each control point is moved toward the center of the path figure.

5
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Perform a Click/Drag combination on one of the bounds handles (blue) to alter the size of the path.

6

Perform a Click/Drag combination on a segment end point handle (orange) to alter the size of individual path

segments. In the image below the circled segment end point handles are dragged downward within the path

object to create the shown change.
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Note: Refer to the handles reference table to learn more about individual handles used within TouchDraw.

Additional information about altering paths can be found in the handling paths section of this documentation.

6.6.10. Converting Text To a Path
The Convert Text to Path option converts a selected text figure(s) to a path. Size, color, rotation, scaling, and

moving alterations are performed as a path rather than by using the traditional text figure selection methods.

Follow the steps below to convert a text figure to a path:

1

Select the text figure to be converted.
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2

Select the Modify Menu and choose Convert Text to Path.

3

The selected text figure is converted to a path figure.

4

Perform a Click/Drag combination on a bounds handle (blue) to alter path size. In the images below, the

bottom bounds handle is dragged downward to increase the height of the path.
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5

Attribute changes are performed in the same manner as figures created with the path tool. For example, a fill

color change to blue would result in the following image.

6

The added rotation handle (red) can be dragged clockwise or counterclockwise with a Click/Drag combination

to change the angle of the newly created path.
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7

A converted path can be moved to any location on the drawing canvas or scaled to a specific size.

8

Adjustment, Stroke, and Shadow attributes may also be altered to change the look of the path. In the example
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below, the stroke cap, stroke location, and shadow characteristics have been altered.

6.6.11. Delete Handle
TouchDraw supports the insertion and deletion of handles or segments from an existing path. A different

behavior is received depending on the type of handle chosen for deletion:

• Cubic Curve Control Point Handle - Segment is converted to a quadratic curve segment upon deletion.

• Quadratic Curve Control Point Handle - Segment is converted to a line segment upon deletion.

• Segment End Point - The entire segment is removed including the control points (cubic or quadratic
curves).

Follow the steps below to delete a Path Handle:

1

Click on the desired handle to select it and then Right Click (Control-Click) to open the contextual menu. In

this example, the Quadratic Curve Control Point Handle (indicated by the color green) is being removed

from the path.
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2

Select the Paths Submenu and then choose Delete Handle.
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3

The selected Quadratic Curve Control Point Handle is removed and the segment is converted into a Line

Segment.

Follow the steps below to delete a Path Segment:

1

Right Click (Control-Click) on the desired Segment End Point to open the contextual menu. In this example,

the bottom left Segment End Point is chosen for deletion.
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2

Select the Path Submenu and then choose Delete Handle.

3
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The selected handle and segment are removed, as shown below.

    Note: Refer to the Handles Reference section of this documentation to learn more about each handle.

6.6.12. Split at Handle
The Split at Handle action divides a path into two separate sections at the chosen handle and allows each

section to be altered as an individual figure. In the following example, the End Point Handle located at the

bottom right of the path is chosen.

1

Click on the desired End Point Handle to select it and then Right Click (Control-Click) to open the

contextual menu.
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2

Select the Paths Submenu and then choose Split at Handle.

3

The path is now separated at the chosen End Point Handle, as shown below.
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    Note: Refer to the Handles Reference section of this documentation to learn more about each handle.

6.6.13. Insert Handle
TouchDraw supports the insertion and deletion of handles or segments from an existing path. A different

behavior is received depending on the type of segment chosen for handle insertion:

• Line Segment - The inserted handle splits the line segment into two connected lines.

• Quadratic Curve Segment - The inserted handle splits the quadratic curve into two quadratic curves and
the shape of the original curve is maintained.

• Cubic Curve Segment - The inserted handle splits the cubic curve into two cubic curves and the shape of
the original curve is maintained.

A new handle can be inserted into a segment or at the same location as an existing handle. In the provided

example, the bottom line segment is chosen for a handle addition. Follow the steps below to insert a handle or

segment into a path:
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1

Click on the desired handle or segment to select it and thenRight Click (Control-Click) where a new handle

will be inserted to bring up the contextual menu.

2

Select the Paths Submenu and then choose Insert Handle.
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3

A new Segment End Point Handle appears in the center of the selected line segment and can be used to alter

the path.
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    Note: Refer to the Handles Reference section of this documentation to learn more about each handle.

6.6.14. Delete Segment
The Delete Segment action removes a selected segment from an existing path. A different behavior is received

depending on the type of segment chosen for handle insertion:

• Line Segment- The entire segment is removed.

• Quadratic Curve Segment - The entire segment and corresponding quadratic control point are removed.

• Cubic Curve Segment - The entire segment and all cubic curve control points are removed.

In the provided example, the bottom Line Segment of the figure is chosen. Follow the steps below to delete a

segment:

1

Click on the desired segment to select it and then Right Click (Control-Click) to open the contextual menu.
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2

Select the Paths Submenu and choose Delete Segment.

3

The Line Segment and corresponding end point (orange) are removed. The remaining segment end points are

joined.

The following screenshots show the resulting control point and segment changes when a Cubic Curve

Segment is deleted from a figure. In this example, the top cubic curve is chosen for deletion. The selected

segment and both control points are removed.
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Note: Refer to the Handles Reference section of this documentation to learn more about each handle.

6.6.15. Segment to Line
The Segment To Line action will convert either a quadratic or a cubic curve segment into a straight line

segment. Essentially, it discards the control points of the curve.

In the provided example, a Quadratic Curve Segment is changed to a Line Segment. Follow the steps below:

1

Click on the desired segment to select it and then Right Click (Control-Click) to open the contextual menu.
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2

Select the Path Submenu and then choose Segment to Line.

3
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The control point (green) of the Quadratic Curve Segment is removed and the segment is changed to a Line

Segment to create a rectangle, as shown below.

The following screenshots show the resulting line when the Segment to Line action is performed on a Cubic

Curve Segment.



Page 492

TouchDraw for Mac

Note: Refer to the Handles Reference section of this documentation to learn more about each handle.

6.6.16. Segment to Quad
The Segment to Quad action will convert either a line segment or cubic curve to a quadratic curve segment. A

different behavior is received when the handle is inserted depending on the chosen segment type:

• Line Segment - A curve control point will be inserted at the center point of the line and can be used to
create the exact desired quadratic.

• Cubic Curve Segment - The two control points of the cubic curve segment will be averaged to create a
new control point for the quadratic curve, which is replacing the cubic curve.

In the provided example, the Line Segment located on the right side of the figure is converted into a

Quadratic Curve Segment. Follow the steps below:

1

Click on the desired segment to select it and then Right Click (Control-Click) to open the contextual menu.
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2

Select the Path Submenu and then choose Segment to Quad.
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3

A Quadratic Curve Control Point (green) is added to the center of the selected segment.

4

Perform a Click/Drag combination on the Quadratic Curve Control Point to create the desired curve

segment. In this example, the control point is dragged in a downward direction.

The following screenshots show the resulting control point and line changes when a Cubic Curve Segment is

converted to a Quadratic Curve Segment. In this example, the top cubic curve is chosen for conversion. The

two existing Cubic Curve Control Points (green) are averaged to generate a single Quadratic Curve Control

Point.
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The provided Quadratic Curve Control Point can be moved in any direction by performing a Click/Drag

combination. In this example, the new control point is dragged upward.

Note: Refer to the Handles Reference section of this documentation to learn more about each handle.
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6.6.17. Segment to Cubic
The Segment to Cubic action will convert either a line or quadratic curve into a cubic curve segment. A

different behavior is received depending on the type of segment chosen for handle insertion:

• Line Segment - Two curve control points will be inserted at the 40% and 60% locations along the line
and can be used to create the exact desired cubic curve.

• Quadratic Curve Segment - The shape of the quadratic curve will be approximated with a new cubic
curve segment.

In the provided example, the Line Segment located on the left side of the figure is converted into a Cubic

Curve Segment. Follow the steps below:

1

Click on the desired segment to select it and then Right Click (Control-Click) to open the contextual menu.

2
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Select the Path Submenu and then choose Segment to Quad.

3

Two Cubic Curve Control Points (green) are inserted at the 40% and 60% locations on the chosen Line

Segment.

4

Perform a Click/Drag combination to move either Cubic Curve Control Point in any direction. In this

example, the left control point is dragged upward and the right control point is dragged downward. Refer to the

image below:
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The following screenshots show the resulting control point and line changes when a Quadratic Curve

Segment is converted to a Cubic Curve Segment. In this example, the top cubic curve is chosen for

conversion. The Quadratic Curve Control Point (green) is approximated to create two Cubic Curve Control

Points and the associated segment.

The provided Cubic Curve Control Points can be moved in any direction by performing a Click/Drag
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combination. In this example, the left control point is dragged downward and to the right. The right control

point is dragged upward and to the left to create the desired Cubic Curve .

Note: Refer to the Handles Reference section of this documentation to learn more about each handle.
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6.7. Calculations
TouchDraw provides an easy method for calculating the area and dimensions of a selected figure(s) by entering

variables within the Text Editor Popup Window. Refer to the Available Variables table to find out more about

what can be obtained as part of the text of a figure.

6.7.1. Calculating Area
TouchDraw supplies the ability to enter variables into the text editor for a figure(s). The calculated area of a

figure can be obtained and included within the figure's text by:

1

Double Clicking on a figure to open the Text Editor Popup Window.

2

Entering {Area} as part of the text within the Text Editor Popup Window. The value will appear within the

selected figure in real time.
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3

The figure will appear as shown below:

6.7.2. Dimensioning
TouchDraw provides variables for determining the dimensions of a selected figure(s) The MinX, MaxX, MinY,

MaxY, Width, and Height can be entered as part of the displayed text within a figure. Refer to the available

variables table to learn more about what variables can be inserted. These values can be applied to show the

dimensions of a drawn object, as shown below:
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Follow the steps below to create the images shown above:

1

Select the Rectangle Tool and draw a rectangle.

2

Select the Rectangle Tool again and draw a square on top of the right half of the rectangle. Use a Shift/Click

combination to select both figures.
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3

Select the Modify Menu and choose Add Shapes to combine the two shapes.
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4

Select the Line Tool and create a line with two black arrow end points along the bottom of the rectangle.

5

Double Click on the figure to open the Text Editor Popup Window.
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6

Click on the Variable drop down menu, choose Length, and then choose . The value will be entered into the

Text Editor Popup Window and be updated on the line in real time.

7
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Follow steps 4 through 6 to create a dimension line for each side. The figure below shows the completed

dimensions for the drawn shape.
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7. Tips and Techniques
This section provides information on how to perform specific actions within TouchDraw and can be used to

master the basic features of the application. Listed below are links to several quick tips designed to help you

become more familiar with TouchDraw.

• Resizing a Figure Proportionally with Handles

• Creating Proportional Shapes

• Using the Selection Rectangle
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7.1. Resizing a Figure
Proportionally with Handles
TouchDraw provides several features for resizing shapes when you are working with figures in a drawing. If a

bounds handle is dragged to a location within the Drawing Canvas without using application features for

constraining proportions, the shape is resized to that specific location. The Shift Key on your keyboard may be

used to constrain proportions as you drag to ensure the original shape is maintained.

For example, a simple drag of the bounds handle without this feature enabled can result in a perfect square

becoming a rectangle or a circle becoming an oval, but by using this feature, the shape will remain as a square

or circle and only change in size, not proportions. The example below shows what the puzzle piece from the

Stencil Library would look like if the bottom right bounds handle is moved upward without using the Shift

Key.
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This tutorial will show you how to use the Shift Key to alter the size of a figure while constraining its

proportions to maintain the original shape. We will be using the Puzzle Piece (as in the above example) from

the Stencil Library to demonstrate how this feature can be used to easily constrain proportions when resizing

shapes in a drawing. View the Libraries section of the Sidebar and then select the Shapes category in the

library menu to locate this stencil.

You will see the puzzle piece as an available selection. Click on the stencil and drag it into your drawing. The

stencil will appear as shown below once it has been inserted into a drawing.
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Proportions are not constrained for a resized shape when the Shift Key is not used. When the Shift Key is

pressed during figure drawing, TouchDraw makes certain that the proportions are constrained during shape

resizing to maintain the original shape. For example, the puzzle piece will remain as a puzzle piece as a bounds

handle is dragged and only change in size. This feature can be used for any of a shapes bounds handles. Follow

the steps below to learn how to use the Shift Key to constrain proportions while resizing a shape.

1

Select the shape in your drawing by tapping on the figure. Bounds handles will appear around the chosen figure

once it has been selected.



Page 511

TouchDraw for Mac

2

Next, you will need to hold down the Shift Key on your keyboard to constrain proportions during shape

resizing. Click and Drag (without releasing the Shift Key) on a bounds handle to begin resizing the shape. In

this example, the bottom right bounds handle is selected and drug inward toward the shape.

3

The puzzle piece becomes smaller in size, but retains its shape as its proportions are constrained. Release the

Shift Key once resizing is completed
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7.2. Creating Proportional Shapes
TouchDraw offers a great amount of flexibility when creating shapes or figures in a drawing. A click and drag

action in combination with a selected drawing tool results in the addition of rectangles, squares, circles, ovals,

and additional shapes of any size and/or proportion to a drawing. The Shift Key can be used when adding a

shape such as a circle or square to your drawing to make certain it retains its proportions and only changes in

size. This prevents the shape from becoming a rectangle or oval.

For example, if you select the Rectangle Tool and insert the shape into your drawing, it can either be a square

or rectangle depending on where you click and drag on the Drawing Canvas. Dragging toward the bottom right

results in a rectangle with non-proportional Width and Height measurements, as shown below.

By holding down the Shift Key as you click and drag, you can create a proportional shape. In the example

above, a perfect square would be created when this feature is enabled and the same click/drag action is

performed. As shown in the Info Sidebar, the Width and Height of the square are proportionally the same.
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TouchDraw constrains the Width and Height to generate a proportional shape when the Shift Key is used in

conjunction with a Click/Drag action. This tutorial will show you how this feature can be used to create a

proportional shape.

We will be using the Rectangle Tool for this demonstration. Follow the steps below to learn how to use the

Shift Key to create a proportional shape in your drawing.

1

Select the Rectangle Tool in the Drawing Toolbar.



Page 515

TouchDraw for Mac

2

Hold down the Shift Key on your keyboard, click in a desired location on the Drawing Canvas, and then Drag

downward or in another direction without releasing the Shift Key.

3

Release the Shift Key once the shape is completed to disable this feature. You will have a perfectly shaped

square when finished.
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4

To view the Width and Height of your shape, open the Sidebar (if not already open) and then view the

Adjustment Tab. The dimensions of the shape will appear under the Size section.
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7.3. Using the Selection Rectangle
The Selection Rectangle provides an easy method for selecting multiple figures within a drawing. Click and

drag from left to right or right to left on any point in the Drawing Canvas and then release the click action once

the Selection Rectangle resides over the desired area. Figure selection will vary depending on the direction the

mouse is dragged.

If you drag the Selection Rectangle from left to right, it will select all figures within its bounds as well as any

figures it intersects.

While this approach is a great choice for making a quick selection in a defined area, it does not offer the

amount of control that is sometimes needed during figure selection. You can drag the Selection Rectangle

from right to left to select figures residing in its bounds without selecting intersecting figures. This provides

finer control for using the Selection Rectangle to select multiple figures in a specified area of the Drawing

Canvas.



Page 518

TouchDraw for Mac

For more information about selecting figures within a drawing, please refer to the Selecting a Figure page of

the documentation.
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8. Miscellaneous
TouchDraw supports specific file formats for importing or exporting and provides options for setting

application preferences. The following documentation sections supply information regarding:

• File Format Support

• Keyboard Shortcuts

• Handle Types

• Application Preferences
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8.1. File Format Support
Images or drawings from outside applications can be imported for editing within TouchDraw. A created

drawing in TouchDraw can also be exported into an alternative file format. See the Importers and Exporters

tables for additional information about supported file formats. Known issues during exporting or importing of

specific formats are noted in the the following documentation pages.

8.1.1. Importers

Importer Type Supported Import Methods

Image Importer TouchDraw supports inserting or pasting bitmap images into a

drawing.

SVG Importer NotesSVG (Scalable

Vector Graphics)

TouchDraw supports importing SVG files using the Open menu

item in the File menu.

VDX (Visio XML Drawing Format) TouchDraw supports importing VDX files using the Open menu in

the File menu.

EMF (Enhanced Metafile) TouchDraw supports importing EMF files using the Open menu in

the File menu.

WMF (Windows Metafile) TouchDraw supports importing WMF files using the Open menu

in the File menu.

8.1.1.1. Image Importer Notes
TouchDraw for Mac supports importing the following bitmap image formats.

• PNG

• JPEG

• GIF

• BMP

• TIFF
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Limitations

• None Known

Known Issues

• None Known

8.1.1.2. SVG Importer Notes
TouchDraw supports importing Scalable Vector Graphics (SVG) files. This page documents the known issues

and limitations of the importer.

Limitations

Not every SVG feature is supported by the importer. When an SVG feature has no equal within TouchDraw,

the original SVG command is ignored. As SVG is large and complex specification, the following is a

non-exhaustive list of limitations we are aware of:

• Elliptical gradients cannot be imported.

• Clipping regions are not imported.

Known Issues

• None Known

8.1.1.3. VDX Importer Notes
TouchDraw supports importing Microsoft Visio XML Drawing (VDX) files. This page documents the known

issues and limitations of the importer.

Limitations

Not every Visio feature is supported by the importer as TouchDraw does not have every feature that Visio

does, nor does Visio have every feature TouchDraw does. When a feature has no equal within TouchDraw, the

original command and/or data is ignored. As the Visio file format is very extensive, the following is a

non-exhaustive list of limitations we are aware of:
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• Only visual information (the look/layout of the drawing) is imported.  Any semantic information
(associated metadata) stored in the Visio file will be lost.

Known Issues

• None Known

8.1.1.4. EMF Importer Notes
TouchDraw supports importing Enhanced Metafile (EMF) files mainly for the purpose of importing embedded

stencil file in Visio documents. This page documents the known issues and limitations of the importer.

Limitations

• None known

Known Issues

• None Known

8.1.1.5. WMF Importer Notes
TouchDraw supports importing Windows Metafile (WMF) files mainly for the purpose of importing embedded

stencil file in Visio documents. This page documents the known issues and limitations of the importer.

Limitations

• None known

Known Issues

• None Known

8.1.2. Exporters

File Formats Options

Image (PNG, JPEG, TIFF, GIF, Refer to the Exporting a Bitmap Image section of the documentation.
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File Formats Options

BMP)

Scalable Vector Graphics (SVG) None

Portable Document Format (PDF) Include Grid

Microsoft Visio (VDX) None

Encapsulated Postscript (EPS) Include Border, Border Sizing

8.1.2.1. Image Exporter Notes
TouchDraw for Mac supports exporting drawings in the following bitmap image formats:

• PNG

• JPEG

• GIF

• BMP

• TIFF

Limitations

• None Known

Known Issues

• None Known

8.1.2.2. SVG Exporter Notes
TouchDraw supports exporting drawing files to the Scalable Vector Graphics (SVG) file format. The following

page outlines the known issues and limitations of the exporter.

Limitations

• Only the visual information will be exported as SVG does not support some TouchDraw features such as
connections.

Known Issues
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• None known

Notes

• Many SVG viewers and/or editors do not support all of the features of SVG that TouchDraw may possibly
use to export your drawing. Specifically, many SVG views do not correctly render shadows. The
Elevenworks team recommends using the Google Chrome web browser to view and validate that your
drawing was exported as expected. In our testing, Chrome has been found to have the most full feature
(freely available) SVG rendering support.

8.1.2.3. PDF Exporter Notes
TouchDraw supports exporting drawing files to the Portable Document Format (PDF) file format. The

following page outlines the known issues and limitations of the exporter.

Limitations

• None known

Known Issues

• None known

8.1.2.4. VDX Exporter Notes
TouchDraw supports exporting drawing files to the Microsoft Visio XML Drawing (VDX) file format. The

following page outlines the known issues and limitations of the exporter.

Limitations

• Font, font color and font size are the only font (text) attributes currently exported.

• Exporting of the drawing background color is not supported.

Known Issues

• None

8.1.2.5. EPS Exporter Notes
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TouchDraw supports exporting drawing files to the Encapsulated Postscript (EPS) file format. The following

page outlines the known issues and limitations of the exporter.

Limitations

• The EPS exporter is not supported on Mac OS 10.10 (Yosemite) or newer.

Known Issues

• None known
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8.2. Keyboard Shortcuts
The Keyboard Shortcuts within TouchDraw are available to provide fast access to application, file, editing,

etc... functions. Refer to the table below to learn more about each available shortcut:

Keyboard Shortcut Option Name Description

Command-Comma Preferences The Preferences... shortcut can be used to change general,

handle, and performance options for the application.

Command-H Hide TouchDraw The Hide TouchDraw shortcut hides all of the open

TouchDraw related windows.

Option-Command-H Hide Others The Hide Others shortcut hides all of the open windows from

other applications while leaving the windows for TouchDraw

open.

Command-Q Quit TouchDraw The Quit TouchDraw shortcut closes the application.

Command-N New The New shortcut can be used to create a new drawing.

Command-O Open The Open shortcut can be used to open an existing TouchDraw

document or it can be used to import a drawing or image in one

of the 3rd party file formats that TouchDraw supports.

Command-W Close The Close shortcut closes the current drawing.

Command-S Save The Save shortcut saves the current drawing.

Shift-Command-S Save As... The Save As shortcut saves the current drawing under a

different name.

Command-I Insert Image... The Insert Image shortcut can be used to import a bitmap

image stored on the local file system into the current drawing.

Command-E Export The Export shortcut can be use to export the currently active

drawing.

Shift-Command-P Page Setup The Page Setup shortcut can be used to bring up a window

used to specify page attribute, formatting, orientation, and

scaling options.

https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/File-Menu-Old.md
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Keyboard Shortcut Option Name Description

Command-P Print The Print shortcut can be used to print single or multiple pages

of a drawing.

Command-Z Undo The Undo shortcut removes drawing changes in the order they

were applied starting with the most recent.

Shift-Command-Z Redo The Redo shortcut reapplies drawing changes in the order they

were removed starting with the most recent.

Command-X Cut The Cut shortcut removes the currently selected item from the

active drawing and places it in the clipboard.

Command-C Copy The Copy shortcut places a copy of the currently selected item

into the clipboard.

Command-V Paste The Paste shortcut adds the most current item residing in the

clipboard to the active drawing.

Shift-Command-V Paste in Place... The Paste in Place shortcut copies the current clipboard item

into the exact location of the original.

Control-Command-V Paste Multiple The Paste Multiple... shortcut can be used to paste multiple

copies of a clipboard item at specific offsets.

Option-Command-V Paste Style The Paste Style shortcut applies the formatting properties of

one object to the currently selected object.

Delete Key Delete The Delete shortcut permanently removes a selected item from

the active drawing.

Command-D Duplicate The Duplicate shortcut creates a copy of a selected item in the

active drawing.

Shift-Command-D Duplicate in Place The Duplicate in Place shortcut creates a copy of a selected

item and places it in the same location as the original.

Command-A Select All The Select All shortcut selects all items residing in the

currently active drawing.

Shift-Command-A Deselect All The Deselect All shortcut deselects all items residing in the

currently active drawing.

Command-Semicolon Check The Check Spelling and Grammer shortcut opens the spelling
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Keyboard Shortcut Option Name Description

Spelling/Grammar and grammer popup window and runs a spell check when this

window is currently open.

Command-G Group The Group shortcut combines selected shapes residing on the

drawing canvas into a group to manipulate and treat them as a

single figure. It is enabled when two or more groupable figures

are selected in the drawing canvas.

Shift-Command-G Ungroup The Ungroup shortcut removes the grouping characteristic for

individual shape manipulations. It is enabled when one or more

grouped figures are selected in the drawing canvas.

Command-L Lock The Lock shortcut prevents a selected figure(s) from being

moved or resized until it has been unlocked. Attributes such as

stroke, fill, shadow, etc... can still be manipulated on a locked

figure. It is enabled when one or more unlocked (and lockable)

figures are selected in the drawing canvas.

Shift-Command-L Unlock The UnLock shortcut removes a previously set lock on a

selected figure(s) or group of figures to allow for moving and

resizing. It is enabled when one or more locked figures are

selected in the drawing canvas.

Shift-Command-Closing

Bracket

Bring to Front The Bring to Front shortcut moves a currently selected

figure(s) to the front of all figures residing in the same layer. It

is enabled when one ore more figures are selected in the

drawing canvas.

Command-Closing

Bracket

Bring Forward The Bring Forward shortcut moves a currently selected

figure(s) one step closer to the top of the stack within the layer

they reside in. It is enabled when one ore more figures are

selected in the drawing canvas.

Command-Opening

Bracket

Send Backward The Send Backward shortcut moves a currently selected

figure(s) one step closer to the bottom of a stack within their

residing layer. It is enabled when one ore more figures are

selected in the drawing canvas.

Shift-Command-OpeningSend to Back The Send to Back shortcut moves a currently selected figure(s)
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Keyboard Shortcut Option Name Description

Bracket behind all other figures residing within the same layer . It is

enabled when one ore more figures are selected in the drawing

canvas.

Command-Right

Facing Arrow

Rotate 90° Right The Rotate 90° Right shortcut rotates a selected figure to the

right by 90°.

Command-Left

Facing Arrow

Rotate 90° Left The Rotate 90° Left shortcut rotates a selected figure to the left

by 90°.

Command-Plus

Symbol

Zoom In The Zoom In shortcut increases the magnification level of the

drawing canvas to allow for working on the drawing in more

detail.

Command-Minus

Symbol

Zoom Out The Zoom Out shortcut decreases the magnification level of

the drawing canvas make a larger portion of the drawing

viewable in the window at once.

Command-1 Zoom to Fit The Zoom to Fit shortcut will dynamically resize the

magnification level and the location of the drawing within the

drawing canvas to make the complete drawing is visible in the

window.

Command-2 Zoom to Actual

Size

The Zoom to Actual Size shortcut returns a drawing back to

the normal magnification level (100%).

Command-3 Zoom to Origin The Zoom to Origin shortcut returns a drawing back to it's

normal magnification level (100%) and resets the visible

portion of the drawing canvas so that the coordinates 0,0 are in

the upper left hand corner.

Command-R Hide Rulers The Hide Rulers shortcut removes the left and top rulers from

the main application window. Select this menu option again for

the rulers to reappear.

Command-ApostropheHide Grid The Hide Grid shortcut toggles the visibility if the grid in the

drawing canvas.

Shift-Command-ApostropheSnap to Grid The Snap to Grid shortcut toggles whether or not figures are

aligned to the grid for more precise drawing.
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Keyboard Shortcut Option Name Description

Control-Command-F Enter Full Screen The Enter Full Screen shortcut switches the main application

window from the current setting to full screen mode.

Shift-Command-R Hide Format Bar The Hide Format Bar shortcut removes the formatting bar

from the TouchDraw application window. Select this menu

option again for the formatting bar to reappear.

Control-Command-R Hide Side Bar The Hide Side Bar shortcut removes the side bar from the

TouchDraw application window. Select the menu option again

for the side bar to reappear.

Shift-Command-C Show Colors The Show Colors shortcut can be used to toggle the visibility

of the standard Mac OS X color picker.

Option-Command-T Hide Toolbar The Hide Toolbar shortcut removes the main toolbar from the

TouchDraw application window. Select the menu option again

for the Toolbar to reappear.

Command-M Minimize The Minimize shortcut minimizes the main application window.

Left Arrow Key Nudge Figure to

Left

The Left Arrow Key nudges a selected figure to the left on the

drawing canvas.

Right Arrow Key Nudge Figure to

Right

The Right Arrow Key nudges a selected figure to the right on

the drawing canvas.

Up Arrow Key Nudge Figure

Upward

The Up Arrow Key nudges a selected figure upward on the

drawing canvas.

Down Arrow Key Nudge Figure

Downward

The Down Arrow Key nudges a selected figure downward on

the drawing canvas.

S Selection Tool The S key activates the selection tool for selecting objects

within the drawing canvas.

M Move and Zoom

Tool

The M key activates the Move and Zoom Tool for panning or

zooming within the drawing canvas.

F Freehand Tool The F key activates the Freehand Tool (Pen Tool) for drawing

freehand objects within a drawing.

L Line Tool The L key activates the Line Tool for creating line objects

https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/Sidebar-Old.md
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Keyboard Shortcut Option Name Description

within a drawing.

1 Line Connection

Tool

The 1 key activates the Line Connection Tool for creating

connection objects within a drawing.

2 East/West

Connection Tool

The 2 key activates the East/West Connection Tool to draw

connection lines that originate from the side (either west/left or

east/right) of the source figure and connect to the side (either

west/left or east/right) of the target figure.

3 North/South

Connection Tool

The 3 key activates the North/South Connection Tool to draw

connection lines that originate from the side (either north/top or

south/bottom) of the source figure and connect to the side

(either north/top or south/bottom) of the target figure.

4 Horizontal/Vertical

Connection Tool

The 4 key activates the Horizontal/Vertical Connection Tool to

draw connection lines that originate horizontally from the right

or left side of the source figure and connect vertically to the

side (top) of the target figure.

5 Vertical/Horizontal

Connection Tool

The 5 key activates the Vertical/Horizontal Connection Tool to

draw connection lines that originate vertically from the side

(either top or bottom) of the source figure and connect to the

side (either left or right) of the target figure.

6 Path Connection

Tool

The 6 key activates the Path Connection Tool for creating a

path connection that connects two shapes.

7 Hub Connection

Tool

The 7 key activates the Hub Connection Tool to create

connection lines that are able to receive connections.The

connection line can originate from any side of the source figure

and connects to any side of the target figure or to another hub

connection line.

O Oval Tool The O key activates the Oval Tool for creating ovals or circles

within a drawing.

C Circle Tool The C key activates the Circle Tool for creating perfect circles

where the radius increases in increments as the size of the shape

increases.
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Keyboard Shortcut Option Name Description

R Rectangle Tool The R key activates the Rectangle Tool for creating rectangles

or squares within a drawing.

RR Rounded

Rectangle Tool

An RR key combination activates the Rounded Rectangle Tool

for creating rounded rectangles or rounded squares within a

drawing.

H Polygon Tool The H key activates the Polygon Tool for creating regular

polygons within a drawing.

P Path Tool The P key activates the Path Tool for creating complex curves

and shapes with detailed control on every aspect of the shapes

appearance.

T Text Tool The T key activates the Text Tool for creating text areas within

a drawing.

+ Zoom In The + key can be used to zoom in on the drawing canvas.

- Zoom Out The - key can be used to zoom out on the drawing canvas.
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8.3. Handles Reference
TouchDraw uses color and decoration attributes to differentiate the varying functions of handles to allow for

quick identification regarding what a handle does. The following table lists the different handles and their

individual function:

Image Handle Name Handle Description

Bounds Handle The Bounds Handle is used to change the width and height of

a shape.

Group Bounds

Handle

The Group Bounds Handle is used to change the width and

height of a group. The white center dot is provided to show that

a group of figures has been selected, as opposed to a single

figure.

Path Start Handle The Path Start Handle indicates which point or a path is the

starting point.

Path End Point

Handle

The Path End Point Handle indicates which point is an end

(or start) point of a line or curve segment within a path.

Path Control Point

Handle

The Path Control Point Handle indicates which points of a

path are control points. Control points are used to alter the

shape of a Quadratic or Cubic curve segment to be altered.

Phantom Path

Control Handle

The Phantom Path Control Handle is a control handle

displayed in gray to indicate that it has not been used. This

characteristic provides a hint to the TouchDraw application that

the handle should function as a control handle in scenarios

where the next drawn segment is a curve.

Rotation Handle The Rotation Handle is displayed on shapes (or groups) which

can be rotated around their center point. This handle can be

rotated in increments of 15° when the Shift Key is held in

conjunction with the Click/Drag action.

Center of Rotation

Handle

The Center of Rotation Handleindicates where the current

center of rotation point lies in a selected shape(s) or group of
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Image Handle Name Handle Description

shapes. The Center of Rotation option must be selected in the

Handle Settings  popup menu for this handle to be visible.

Lock Handle The Lock Handle indicates that the selected figure (or group)

is currently locked, which means it cannot be resized or moved.

The white center dot is provided to show that the figure (or

group) cannot be altered.

Connection Handle The Connection Handle indicates that the selected line can be

used to connect to figures.

Gradient Location

Handle

The Gradient Location Handle indicates the current center

location of a gradient fill within a figure(s) or group of figures.

The Gradient Location option must be selected in the Handle

Settings popup menu for this handle to be visible.
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8.4. Application Preferences
TouchDraw provides a preferences popup window for setting general, handle, and performance preferences

within the application. Use one of the following methods to open Application Preferences:

1

Click on the Application Menu and choose Preferences.

2

Use the Command-Commakeyboard shortcut.
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8.4.1. General
General Preferences are grouped into three categories: General, Visio Importer, and Layers. These

preferences are located in the General section of the Application Preferences popup window, as shown below.

Enabled preferences have a check mark in their associated box.

General Preferences

Preference Name Description

Enable Support for

Versions

The Enable Support for Versions preference provides support for "Versions" feature

of Mac OS X 10.7 or newer. TouchDraw must be closed and reopened for this option

to take effect. For more information about this feature, see the following Apple

Knowledge Base entry.

Visio Importer Preferences

Import The Import Connections preference imports all connections in an imported Visio

http://support.apple.com/kb/HT4753
http://support.apple.com/kb/HT4753
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Preference Name Description

Connections Drawing when enabled. This option should disabled when you want to preserve the

visual look of a Visio diagram when TouchDraw routes connections differently due to

differences in it's drawing/layout engine from Visio.

Visio Exporter Preferences

Preference Name Description

Encode Embedded

Images as JPEG

The Encode Embedded Images as JPEG preference encodes any embedded images

residing within an exported Visio file as a JPEG image type to reduce the total size of

the exported file. This preference is automatically enabled (checked) by default.

Layers Preferences

Preference Name Description

Add new layer

when adding to a

locked layer.

The Add new layer when adding to a locked layer preference automatically creates

another layer if a figure is added to the drawing canvas when the current layer is

locked.

Select layer of

selected figure.

The Select layer of selected figure preference alters the currently active layer to the

residing layer of a selected figure unless the layer has been locked.

Layer Isolation The Layer Isolation preference isolates modifications to the currently selected layer

and prevents other existing layers from being selected for editing.

Prompt for name

of newly added

layers.

The Prompt for name of newly added layers preference opens a prompt for entering

a layer name when a new layer is added to a drawing and is disabled (not selected) by

default.

Miscellaneous

Preference Name Description

Enable Popover

Animations

The Enable Popover Animations preference toggles the fade in/fade out animation

of the popover windows that appear in the application. These animations are part of
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Preference Name Description

the extended toolbar and appear when a right click is performed in the drawing toolbar

or when a double click is performed to bring up the text editor popover. It is a

usability preference designed to make TouchDraw run faster when disabled.

Enable Streaming

Persistence

The Enable Streaming Persistence preference toggles TouchDraw to use the new (or

old) code for reading (opening) drawings. The new streaming approach performs the

necessary actions in one pass by analyzing the file as it is read to reduce memory

usage and make the application 2 to 5 times faster. When this option is enabled,

TouchDraw will use the new streaming approach for reading (opening) drawing. The

old version reads the data in two steps by reading the data into memory and then

analyzing the data to create the drawing. This type of reading is performed when this

option is disabled.

8.4.2. Handles
The Handles Preferences are used to configure which handles are visible for figures residing on the drawing

canvas for newly created or newly opened documents.

These preferences are located in the Handles section of the Application Preferences popup window, as shown

below.

If you want to change the handle visibility for the drawing you are currently editing, then you should use the

Handle Settings popup menu to do that.
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Enabled Secondary Handles have a check mark in their associated box.

Primary Handles

Preference Name Description

Bounds The Bounds preference toggles the visibility of the boundaries of path handles.

Boundaries can be shown on handles for all figures, strokes, and paths or for

everything but paths.

Path Segments The Path Segments preference toggles the visibility of segment handles for paths.

Path Control Points The Path Control Points preference toggles the visibility of path control points

between always showing, only showing active points, or showing none at all.

Secondary Handles

Preference Name Description

Rotation The Rotation preference toggles the visibility of the rotation handle on the drawing

canvas.
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Preference Name Description

Gradient Locations The Gradient Locations preference toggles the visibility of the gradient location

handle within a figure(s) on the drawing canvas.

Center of Rotation Enabling the the Center of Rotation preference allows the point at which a figure or

shape is rotated around to be edited.

8.4.3. Grid and Snapping
The Grid and Snapping Preferences are used for altering grid appearance and snapping objects to the grid,

lines or points on the drawing canvas.

Enabled Grid and Snapping preferences have a check mark in their associated box.

Grid Preferences

Preference Name Description

Show Grid The Show Grid preference toggles the visibility of the grid. The grid visibility is an

application level preference. It will remember what you have selected through the

application restart and will apply to all drawings that you edit/view.

Show Page Bounds The Show Page Bounds preference toggles the visibility of bounds of a page within

the drawing canvas. Any figure surpassing this line will appear on another page when
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Preference Name Description

printing.

Snapping Preferences

Preference Name Description

Snap to Grid The Snap to Grid preference aligns objects to the grid for more precise drawing

modifications.

Snap to

Pixels/Points

The Snap to Pixels/Points preference aligns objects to whole pixel numbers or points

for simplified object modification and increased accuracy.

Snap to Lines The Snap to Lines preference aligns objects with the nearest lines.

Snap to Shapes The Snap to Shapes preference snaps a figure to a selected shape vertex or center

point. It is disabled by default as an application preference.

8.4.4. Performance
TouchDraw supplies preference options for turning off certain features as images are rendered on the drawing

canvas. These preferences are located in the Performance section of the Application Preferences popup

window, as shown below.

Enabled preferences have a check mark in their associated box.

Fast Zoom The Fast Zoom preference hides text and additional items during zooming to increase
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Preference Name Description

rendering speed within the drawing editor. These items are not actually removed from

the drawing.

Fast Resize The Fast Resize preference hides text and additional items during resizing to increase

rendering speed within the drawing editor. These items are not actually removed from

the drawing.

Hide Handle

Shadows

The Hide Handle Shadows preference hides handle shadows while images are being

rendered within the drawing editor. This does not mean that shadows have been

removed from the drawing. Instead, shadows are not drawn in the editor to provide

increased rendering speed.

Show Text in Pan

and Zoom

The Show Text in Pan and Zoom preference toggles the visibility of text while

panning and zooming actions are being performed in the drawing editor. This does not

mean that text is removed from the drawing. Instead, text is not drawn in the editor to

provide increased rendering speed.
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8.5. Manually Accessing the
Libraries
While TouchDraw for Mac allows you to import and export libraries through the UI, it's sometimes handy to be

able to install (or remove) libraries through the Finder. This page takes you through the steps necessary to

access the folder that contains the libraries.

1

Make sure that TouchDraw for Mac is not running.

2

Switch to the Finder.

3

Open the Go menu.

4

Press the "Option" key on your keyboard, which will add a "Library" menu into the Go menu which should

click.



Page 544

TouchDraw for Mac

5

Open the "Containers" folder.

6

Open the "com.elevenworks.mac.touchdraw" folder.
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7

Continue navigating the hierarchy by navigating to the "Data->Library->Application Support-> TouchDraw ->

Libraries" directory.
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8

The "Libraries" directory that you (finally) navigated to contains all of the TouchDraw for Mac libraries. You

can add or remove files to this directory to install or remove libraries.
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9

Restarting TouchDraw will allow your changes to be viewed.
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8.6. Grouping a Path
Once you have created a path and have all of the control points where you like them, it is recommended to

group your path using the Group tool available under the Arrangement popover menu. This will allow you

stretch, resize and move your path (or path figure) without worry of changing the points. The following

screenshots show a before and after for the Fleur de Lis example drawing included with TouchDraw.

The path figure is the only figure that is allowed to be grouped by itself. Normally, you need one or more

figures selected before you can create a group.
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8.7. Hide Gradients
The Hide Gradients option toggles the rendering of gradient fills (linear and radial) in the drawing editor. This

option is located on the Fill Tab in the Info Old portion of the sidebar. Click on the box located next to the Fill

label to hide or show gradient fills. Refer to the images below:

The following image examples show what a figure looks like with this option turned on and off.

If gradients are hidden, that does not mean they have been removed from the drawing. It simply means that

they won't be drawn in the editor to increase rendering speed.

https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/Info-Old.md
https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/Sidebar-Old.md
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8.8. Hide Shadows
The Hide Shadows option toggles the rendering of shadows in the drawing editor. This option is located on the

Miscellaneous Tab in the Info Old portion of the sidebar. Click on the box located next to the Shadow label to

hide or show shadows. Refer to the images below:

The following image examples show what a figure looks like with this option turned on and off.

If shadows are hidden, that does not mean they have been removed from the drawing. It simply means that they

won't be drawn in the editor to increase rendering speed.

https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/Shadow-Old.md
https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/Info-Old.md
https://github.com/elevenworks/touchdraw-for-mac/tree/8cd5d4efc9ed3357e3c8f0b0efe75f7419b032ea/Sidebar-Old.md
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